Use of Metronome with Autorecord

I’m a novice Cantabile (and midi) user. I’m working on my time, so I want to autorecord with the metronome so I can hear whether I’m keeping good time on playback. But it seems that the autorecord won’t shut off while the metronome is playing. Is there a way to record my playing with the metronome, but stop the autorecord when I’ve stopped playing? I’m guessing (hoping) there is a setting or two that would let me do this and I don’t know enough yet to figure out what they may be.

Well, my ignorance has complicated matter. I played with a few settings, and now I can’t get my recordings to play back. I tried going back to the way it was set up before I started screwing with it, but I still can’t make it play a recording. Any suggestions?

Hi Joel,

Are you recording your keyboard performance on MIDI or Audio Or both? I know the metronome is audio.

What you are attempting to do is not possible with Cantabile. It can autostart the recording and metronome with a key press but cannot execute the auto stop without silence. The only solution is to provide for a manual stop button or key to stop the recording.


1 Like

Thanks Dave. I had both Midi and Audio on, then tried one, then the other, then went back to both, and still couldn’t get any sound. Came back this morning, rebooted, and it suddenly worked. Hope it stays functioning, but I also wish I knew what I did to make it stop, so I don’t do that again.

I think the autorecord feature would be significantly enhanced if it could be programmed to ignore the metronome for purposes of deciding when to stop recording.

Hey Joel,

I had some time to look at this and since I hadn’t seen a plan on how to do it I figured I would take a stab at it.

First off your needs as I understand them are you want to be able to auto record your performance VSTi audio and the metronome audio to a single easy to load file for playback in the media player in C3 or other media players so you can check your performance timing objectively after the recording is finished.

To begin I created a separate song to set up the conditions to aid in this pursuit.

Revised 12-17-2019

Brad found a bug in the auto record settings that really improves the method so I am revising this post to show what worked good for me after Brad’s explanation and bug fix.

So in practice you would have auto record set to on, the metronome running and when you would played the first note it would start the recorder. You would play till satisfied and then after the predetermined waiting period in the settings the recorder would stop. You can then right click on the file and select add to media player playlist and then press play on the media player and play the file back.

To set all this up I suggest the following plan. You first go to the options Audio ports screen and add a stereo port and name it Metronome if you don’t already have a stereo Metronome port. (I think mono is the default and it can simply be disabled if it is there). I did this because it was the only way i could think of to get the metronome audio and the VSTi performance audio onto the same stereo tracks. see picture …

While you are in options go to the Recording page and set the auto record to MIDI Input and set the auto record off time to your preference.


Go back to song level and set up your routes like so with the output of the VSTi audio routed to the new Metronome stereo out port and the media player playback output also routed to the Metronome out.

then we set the “Ports to Record” check-boxes for the Main Keyboard (MIDI Input)


and the Metronome stereo port.


Once that is done you can enable the auto record function on the recorder


and start the transport to turn on the metronome

Next you simply play the keyboard and the recorder will start


When you stop playing the recorder stops after the predetermined time from options settings

Then you can add the new recording to the playlist in the existing media player by right clicking on the topmost file in the recordings list and selecting "Add to media Player 1’s playlist


and play it back.

You can add bindings if you want to syncronize the recorder and the transport play and stop like this:

Auto start the Metronome with the Recorder using this binding

Auto stop the metronome when the recorder stops

You either one or both bindings depending on how you want to set up.

Repeat the process after that point for new recordings.


I had premixed the 2 audio ports by combining them on the Metronome port so you can already hear the mix of the metronome and the VST track. Normally the metronome is in mono and normally you would select both the metronome port and the Main Speakers Out port and in that case a multi-track recording would be produced and you would only hear the first 2 tracks on playback. You can add the other tracks to the playback by going to the current file editor for the media player.

Not sure if it will help but it was fun to put together!




OMG. I can’t believe you went to all this trouble just to answer my question. Thanks!

If I understand your proposed process, you have to press the stop button because Cantabile won’t stop the metronome automatically. As I said, I’m a novice. So I’m probably missing something. But if you have to press the Stop button in your scenario, why couldn’t I just press the Record button, which is red when recording and gray when it stops? Wouldn’t that do the same thing without having to go through setting up the Metrnome track you described? Am I missing something?

I would still rather have an automatic shut-off. To be honest, I’m not used to recording myself, and I get a bit self-conscious when I know the recorder is running. So my preference at least for the time being would be to not have to be conscious of the recording till I want to go back an listen to it. Having to stop the recording repeatedly just reminds me it’s running. Yeah - I know. What a wuss. But there it is.

1 Like

Dave is an amazingly great guy, just like the many others here who spend so much of their valuable time helping those of us who fall short in certain areas. I personally owe him a case of Bourbon and 3 beers. :wink:


Hi Joel,

You could but if the Metronome is still be running it would start the recorder up again since it was assigned to be recorded audio. That was why i proposed stopping the Recording and the Metronome together and also routing the media player playback so as not to cause record to start again when I wanted to listen to the playback. I hope that answers why I chose that way.

Not a problem Joel, Cantabile can do a lot of things but when a user finds a new need like the one you have detailed @brad can always assess it and see what can be done about it. That’s the best way IMO to get a more streamlined function to address this need you have brought out.



1 Like

I think the problem here is that you’re recording audio which includes the metronome sounds, and using audio signal as the trigger for the auto record.

What you could do, is trigger the auto-recording just on MIDI input. Go to Options → Recorder and set the “Start Recording On” options to just MIDI input.




Scarecrow: “I should have thought of that with my brain!”
Tin Man: “I should have felt it with my heart!”

But of course!!!


1 Like

@brad How does it auto stop the recording when he quits playing?

“Start Recording On” is a bit of a misnomer. Is really means “start recording when activity detected on and stop recording when activity no longer detected on” - but that’s a bit long for the UI :slight_smile:


Hi Brad,

No problems with the auto record starting up but I read the section under Auto-record setup to mean “Stop auto-recordings after xx seconds silence”. This means audio silence as far I can tell. That’s part of what the OP was asking about, he had mixed the metronome audio with the live playing from a vsti and when he would quit playing the metronome kept going and feeding audio to the recorder which didn’t sense the playing was over as a result. I’m not trying to be sticky here but want to be sure we are seeing the same question. Thanks for you responses!



Another misnomer… “silence” in this scenario also means lack of MIDI activity for the MIDI recorder.


Thanks Brad, That is cool. I didn’t know it could do that. The OP could use that for sure!


I went to test this out and it didn’t go like I thought so I will break it down.

I set the auto record to ‘MIDI Input’ in options.

I set the audio output route of the VSTi to the Metronome port to merge it with the Metronome signal and send it to the metronome audio out port. I set the ports to record to record only that port. ( this might be where I am messing up)

I set the auto record switch on the transport.

I start the metronome and oops the recorder starts with it, no MIDI input yet. I don’t play for the xx seconds silence but the recorder keeps going. I press stop on the transport and the xx seconds silence counts off and the recorder stops. This behavior does not seem right.



I have done a little more looking at this and here is what it seems the relationships are. The “Ports to Record” affects the auto record switching.

this is the setting I used to test, MIDI Input is the auto-record starter.


If only MIDI ports are chosen to be recorded the auto - record works as expected, it starts with MIDI input and auto stops after the predetermined non MIDI activity period.

If a MIDI port is selected and also an Audio port is selected the auto record starts as expected and stops after you quit playing for the predetermined period.

If a MIDI port and an Audio port with the Metronome playing through it is selected the auto record starts as soon as you start the transport to start the metronome. No matter whether you play MIDI or not the recorder runs until you stop the metronome from the transport bar, it then waits the predetermined non-activity period and stops the recorder. If you try to stop just the recorder it just starts again because the metronome is still playing.

So it looks like the audio activity overrules the MIDI activity when both are chosen for recording even if the MIDI input is assigned as the Auto record starter.


Brad - I tried what you suggested - set “start record” for Midi Input only. It didn’t work. At least, it didn’t do what I’m trying to do. I started the metronome, then started playing the piano. After several seconds, I stopped playing the piano. The metronome kept clicking, of course. I watched the Recordings pane, waiting for the recording to show up even though the metronome was still clicking away. It didn’t show up. I manually stopped the metronome, and after the 5 seconds I had set in the Auto-record settings, the recording did appear in the Recordings window. And when I played it back, of course the metronome was still going after the piano had stopped.

So is there another way already established in Cantabile that would allow me to set it to stop when I stop playing even while the metronome is beating away? Or is that something new you’d have to develop? If the latter, is that something you can readily do? I’d really appreciate it!!

I would think that, there should (might?) be a way you could mark the metronome with some kind of code and then create a rule so that Auto-record could be instructed to ignore the metronome for purposes of deciding when to stop (or start, for that matter). Does that make sense?

Definitely a bug… those last two check boxes aren’t working.

Fixed in 3636 (available now).


1 Like

Double Yikes!! That was record setting … working well with the MIDI Input as the auto record source and recording performance and metronome on same stereo track. Works like it should here.

I did a rewrite on the instructions I did above so as not to lead people too far down the wrong way lol … far better to use this way IMO. :slight_smile:


Brad -

By “3636” do I understand correctly that you are referring to a later version of Cantabile that resolve my metronome issue?