[Solved] VB3 II switch between A and B setup


#1

I have tried to read the old postings about VB3 II without finding the answer, I apologies if I missed it (and being new to Cantabile there was a lot of history to go through).

My question: VB3 II only uses “Organ Preset Octave” to switch between A and B, and I have asked Guido about getting normal CC events for this, but he said that it was not on the roadmap. I often use a split keyboard with Pianoteq and VB3, and then it does not work well with the “Organ Preset Octave”. How do you handle this? I have tried setting up my SL MixFace to send notes, but they get transposed with the settings on the zone on the SL 88, so for this to work I would have to set up individual programs on the MixFace for each song, I would prefer to avoid this tedious task.


Recap/solution: requires Performer, then it is straightforward to use bindings and map events to the “midi-in” of the VB3 II plugin. Read the entire thread for details.

Thank you to all who helped resolving this.


#2

Hi

Maybe use a CC on your boards and map them to notes. See the following page


#3

That was a sneaky workaround, I will try out.

Thanks!!


#4

Hmm, I could not make it work - does it require Performer to map to other bindings?


#5

Hi Torsten,

Derek was right about the CC to note trick, here is a CC 92 that makes a Bb and a CC 91 that makes A. This will switch the A/B switch in VB3 II. No triggers needed. Just bindings.

requires Solo or performer to do this.

Dave


#6

Thanks - I will give it yet another try, really appreciate your help on this!


#7

It is weird. I managed to name the route to make it appear in the list of possible targets, but then I only get these options:

I have tried reading the guides about bindngs carefully, but I can not figure out why I get different options than you.


#8

What version of Cantabile are you running? Lite, Solo or Performer?


#9

I am running Solo - and I have made sure that I did not accidentally switch to Lite. And also that I am on the latest stable build.


#10

Hi Torsten, can you post your Routings page too so I can see the racks and plugins? What is selected in the Action column, It is blocked by the drop down menu.

I also see you are using the same source I used which is the Onscreen keyboard. I meant it only as an example. If you have 2 buttons on your controller you can use them instead by using the learn function on the Binding Source menu

when you select the one you want from the list you then select your target.

Sorry if you already knew this.

Dave


#11

Thank you very much for the input. I only used the Onboard Keyboard as source to be as close to your example as possible, i.e. to eliminate all possible sources of deviation. It seems to me that my problem is that I can not find the right way to set the target - as you point out you can not see it on my screenshot, but it is because it is empty, I can not select anything.

Thank you for the input on the learning part, that will come in handy when I get the target setting sorted out.

I have tried to add a few more screenshots, but basically my setup is very simple (still rookie, I just want this to work, then I can make the advanced setup). A verbal description of my setup:
Source: midi input from SL Mixface, with an SL88 Grand keyboard attached.
Plugins: VB3 II organ module, channel 1 -3, and Pianoteq on channel 4
Output: Focusrite w ASIO drivers

I have named the input route to the VB3 II plugin
image

Then on the bindings page I can select the named route as target, but I can not select any action.

I can of course select the actual plugin as target instead, and there I have the option to select ‘Notes’ as part of the target, but then the Value insists on being ‘(Invalid binding)’.


image

I am really grateful for your assistance on this.


#12

Hi Torsten,

Thanks for posting your setup. Do bindings to the pianoteq plugin behave the same? The default when you create a new target in the binding is MIDI CC so this is weird enough to me I am going to get help from @brad to see about it, I don’t recall seeing this problem before. Did you try the MIDI learn function on the bindings to see if it worked for you to get some buttons on your controller to trigger it instead of the onscreen keyboard? Onscreen keyboard control buttons must be created in the Controller bar (View>Controller Bar) and when called it appears at the bottom of the window. Right click on the blank buttons to configure (customize) them.

Let me know how the pianoteq binding acted, try creating the buttons for onscreen keyboard that match my configuration I showed and we’ll see about getting this sorted.

Dave


#13

Hi Dave,

Thank you again for your help. I tested this, and found:

  • same behaviour for Pianoteq and VB3, no difference. I also tried other instrument plugins, also the same.
  • I tried midi learn from the SL Mixface, same result

Regarding the Controller Bar, it requires Performer, so I did not test that.

I am considering uninstalling and reinstalling Cantabile, to see if that makes any difference. I recently upgraded to build 3587, but there might be some settings that have survived. I only use the setup I described previously, so recreating everything from scratch should be fairly easy.


#14

That might explain the trouble. I was trying to use what isn’t there lol … but the bindings that you made using learn didn’t work either so it’s not the problem.

Worth a go, I have the call out to the developer posted so he will likely respond after the weekend.

Dave


#15

Thanks, I will give it a try. I did ask Brad about this feature (he helped me a lot on an issue with the Pianoteq plugin that had issues with the GPU on specific graphic cards), and he suggested that I asked on the forum :-).

Anyway, I will post my findings when I am done uninstalling and cleaning up, then reinstalling from scratch.

Have a lovely weekend.


#16

I just tried installing Cantabile on a spare PC, and got exactly the same behavior.

I am not sure what to try next, I have been through all the settings in the Options panels, but did not find any that I expected could affect the bindings.


#17

Well, VB3 II is I assume still playing using the setup you have now and the issue is with the bindings, for the A/B swithch, is that the case? I never asked before.

Thanks

Dave


#18

Yes, that is the case.

I consider using the midi filters to handle transposing - it will make my setup more complex, but then I can get around the problem that the switch-setup-notes gets transposed.


#19

Hey Torsten

I think the issue is that you are trying to use a route as a target for your binding, instead of simply using the binding to send MIDI directly to the MIDI input of the plugin (not the plugin itself), ignoring the route.

I just tested this with my studio keyboard using two buttons that send CC 71 and CC72:

Works perfectly - so the correct selection you need to make for the binding target is “VB3-II 1 - MIDI In”. No need to name any routes.

Cheers,

Torsten


#20

Thanks! But I fall to see the midi in option in the list of targets.