Occasionally all sounds are transposed +1. Fixed by using Cantabile power button


#1

System boots up as normal and loads Cantabile. Everything works, with the exception that all sounds are transposed +1 semitone. It is as if the global transpose has been clicked +1.

If I press the C3 power off and back on, then I am back to normal.

When in this state, I have checked the following.

  1. The global transpose is definitely showing “-”.
  2. All VSTs are affected. I checked Pianoteq, Kontakt and I think VB3.
  3. If I show MIDI monitor across various routes including the input to the plugins then this shows the notes I am playing, not the notes being heard. If I am playing C5 on the keyboard, the midi monitor will show C5, but the sound heard is C#5.
  4. I cannot be certain as I ran out of time to test, but I think Pianoteq MIDI monitor was also showing the same as Cantabile - it was showing C5. But the sound heard was C#.
  5. I have not adjusted any settings on the keyboard itself.

I have had this 3 times now, since updating to 3500 series in Mid December. It fixes itself by powering off and on within Cantabile.

Anyone else seen this? Or any suggestions on what to check next time it happens?


#2

See if these threads relate to your problem


#3

Thanks Corky, my experience is not quite the same as either of those threads

In my case, when I load C3 it always loads a particular default song which has global transpose set to 0.
yet the sound I hear is transposed +1 semitone or half a step.

If I then use Global Transpose to move down a semitone, the display will show -0.1 and the sound then matches what I am playing on the keyboard.

It has only happened 3 times in the last month, and it has not yet happened when I’ve had time to diagnose further.


#4

Just a shot in the dark here that probably doesn’t relate…have you gone to settings and disabled the load of that default song, and see if the song may have a transpose setting you’ve missed?

Just thinking out loud. :grin:


#5

Thanks for the suggestions - please keep them coming. :slight_smile:

I didn’t try that specifically, but I think I moved to different songs and the problem persisted.

I want to build up a list of things to try next time it happens.


#6

The really odd thing for me was that the MIDI monitors and logs showed the notes I was playing, not the notes I was hearing. ie. C5 not C#5.


#7

Just for info…what version C3 are you running?

Also, where in C3 are you transposing?


#8
  1. It 1st happened somewhere after 3512.

#9

Ignore global transpose is ticked everywhere except on the final route to the plugin within the rack containing that plugin.


#10

There was a bug fix in 3524. @dave_dore is online right now. Maybe he will chime in. Dave?


#11

Hi guys,

I know that there are some items that Brad is looking at for me and others that are delving into 35xx, I think Torsten posted a new one yesterday and Brad has been picking off stuff as it comes up but I don’t have an experience like this. A few questions though. Is this a pre-loaded setlist we’re talking here? Or is it just 1 startup Song with your instruments? Just trying to narrow it down because I have been having some grief from one of my set lists in 35xx and Brad’s looking at it but nothing yet to show why. When you say you see the - do you mean like this?

h77

Dave


#12

Hey Dave, some answers.

  1. Yes - my complete preloaded setlist. I didn’t get a chance to narrow it down and start a new setlist and song
  2. Yes - seen like that, although I would have been in live-view so using the controller bar transpose buttons.

#13

Hi Al,

This definitely sounds like a first Song Load thing. I am pretty sure the global transpose affects and is a Song file level event and that the first song file that loads is occasionally messing up on a set list load. I have been having set list load problems, the way I corrected them in 35xx was by not allowing an automatic setlist load and instead set C3 to start to a new song and then then manually loaded my big set list with the pre-load on. That eliminated the problem I had. I don’t know how often your problem happens but @brad will want to know about this 35xx quirk you’re experiencing and may have some things to ask. That’s about all I got for right now. :slight_smile:

Dave


#14

If the MIDI monitor is showing the correct note then it’s highly unlikely this is a transpose/MIDI problem. My guess would be the audio driver is running at a slightly different sample rate for some reason.

eg: suppose the audio driver is running at 48Khz, but Cantabile (and therefore any loaded plugins) think it’s running at 44.1Khz then any plugin trying to synthesize a “A” note at 440Hz would actually be played at…

440 * 48000 / 44100  = 479 Hz

Which is pretty close to A# at 475Hz.

Of coure then the question becomes why is the audio driver running at a sample rate different to what Cantabile instructed it to… which I don’t have an immediate answer.


#15

That could be it. I have a “startup” batch file that loads Reaper, C3, and sometimes some other programs which are all going to be talking to the sound driver at roughly the same time. Windows sound is also using ASIO channels 1+2. I did change the load order before Christmas which might be why I didn’t see it before then.

I’m using a MOTU interface. Is there anything I can do when it happens next to take logs, or confirm the sample rate issue?


#16

I’m pretty sure after setting the sample rate Cantabile asks the driver for it back again and uses that as the engine’s actual sample rate so you could check what’s shown in the Monitor panel:

image

Do you have a way to determine externally to Cantabile what sample rate the driver is actually running at? It sounds like the driver is reporting back the setting Cantabile has specified, but the hardware perhaps not actually running at the rate (or someone else is changing it after the fact).

I guess the other thing you could check it that all apps using the driver are configured to run at the same sample rate.


#17

Here is a snip when it happens
Capture

Here is a snip after going Tools -> Options -> Audio Engine -> OK.
Capture2
After which the notes are pitched normally.

The sample rates show the same.

The MIDI monitor, and PianoTeq VST MIDI viewer are both showing the correct played non-transposed notes, but the note out of the speakers is transposed.

Notes from another VST - Kontakt were also transposed, so doesn’t seem to be a PianoTeq problem.

The audio was not distorted, just not playing the correct note!

I could look at the control panel setting? Did you have anything else in mind?

I do have Windows audio going out on MOTU channel 1 & 2, No other Apps are using audio that I am aware of. Is there a tool that will confirm this?

Any suggestions on what to capture next time it happens?


#18

Hi @a6325435

Tip: you shouldn’t need to do that - just power cycle the engine using the power button top right of Cantabile’s main window.

I was hoping the motu driver might have somewhere else where it displays current state. (eg: like how asio4all displays a popup when started that shows the selected sample rate etc…)

The other thing you could try as an experiment is recording the audio using Cantabile’s audio recorder - that should give you a 48khz recording and I’d assume the notes would be the correct pitch in the recording. If so, this would almost guarantee this is a problem with the driver. If not, this must be a Cantabile problem.

My best guess here is simply that the device is running at a different sample rate and the driver is unaware of it. It certainly seems that driver is reporting 48Khz back to Cantabile which Cantabile passes on to the plugins and they’re rendering at the a different sample rate to the driver.

Wouldn’t hurt to contact Motu about this too - perhaps just point them to this topic, or pass on my contact details if you like.

Brad