Transpose Settings in Live View - Possible Bug?

In “LIve View” when I click the transpose “+” button, the screen changes to +.1, however the notes are transposed one full step not a half step. This then occurs each time with each incremental increase raiseing the notes 2 x .5 steps instead of one .5 step.

I assume that this is a bug?

Hi John,

Just had a quick look at this and couldn’t see any issues. Is the transpose display actually showing 0.1 but the notes actually transposed by 0.2? One possible reason for this is the notes are getting passed through two MIDI routes. You can work around this by turning on “Ignore Global Transpose Setting” in the routes settings dialog.

(That said there was a small bug where sometimes a MIDI route will ignore the global transpose all together. This is fixed for the next build which is cooking now. Should be up soon)


Brad, Yes… the transpose says +.1 yet plays +.2.

Starting with C, when I hit the transpose button the C is transposed to

+.1 = D
+.2 = E
+.3 = F#
+.4 = G#

Etc. So that when once octave is hit, the note is actually 2 octaves higher.

I will look into what you have suggested.

Note: I am using a rack within the song, within a play list, and then hitting the transpose within “Live Mode”.

OK, I’m guessing that two MIDI routes are applying the transpose.

Check the route from keyboard tot he rack and then the route from the rack’s midi-in to the instrument. (assuming you’ve got it setup like that). On the route from the rack input to the instrument turn on “Ignore Global Transpose” should fix it.


Yep, that Fixed It. It looks like for the most part, “Ignore Global Transpose” should be a part of Most Rack Builds, so that Transpose can be controlled at a Song Level? Yes?

1 Like

Yes, although it depends if the route is from an environment port or from a rack input port. I could make it smarter for sure.