Cantabile on Linux under Wine

Really keen to see if this can be run in Linux - at the moment I am getting hung up on a ngen.exe error in the installer - WINE-Staging 6.17

Hi @pax-eterna

I moved this to this post to its own topic because it’s a whole area that’d be interesting to follow. Some notes/thoughts:

  • I don’t think anyone has got Cantabile 3 working under Wine at this stage, but it’s been a long time since I last looked at it.
  • The ngen step is completely optional - it just precompiles some stuff to reduce runtime JIT stalls.
  • Instead of the installer, you might be better off using the .zip packages available on the release notes page.
  • The TechUpdate2021 build that I’m working on uses .NET 5, but it looks like that works under Wine.
  • If you get it working, you’ll need still need Windows plugins, this won’t let you use Linux plugins - even though you’re running linux.


Hi Brad, thanks for the reply.

Yep I’ve got windows plugs (well, the ones I want to use anyway) working fine. I’ll try the zip and see how it goes.

Reason I am re-visiting this is that WINE has come along quite a long way since I last tried this , hence seeking an update :slight_smile:

The issue with the ngen.exe is a bit perplexing as the installer seems to think it is compulsory and “hangs” the installation. Last time I had to reboot to fix the issue. But again, I 'll try an alternate install method as above :slight_smile:

Hi @pax-eterna,

Yep, Linux and Wine have both come a long way recently.

My lounge room gaming PC is now a linux machine - mostly running Windows games, which is a phenomenal achievement for both the Wine and DXKV developers.


Well yeah, the installer will complain if ngen doesn’t run - because it should. I don’t know why it just hangs under Wine.

haha, no probs - it wasn’t a criticism :wink:

Ok had some minor success using the zip version. However the issue now is with how the Audio is setup. Only options are WASAPI (via PulseAudio) or NULL. No ALSA capability (which as you’d know is essentially the same as ASIO)

I’ll keep experimenting with the MIDI side though and see if I can get that to work, albeit with no sound.

yes Proton has made a big difference! A lot of my games now have platinum status on WINE HQ.

But I digress, I should keep this strictly about C3 and Linux/WINE haha!

Okay, got audio working…but issues with MIDI, it’s not receiving anything? C3 sees the MIDI in device I have it set as main keyboard and as default but no input?

Don’t know off hand. First thing I try is this:

  1. Go to Tools -> Options -> Diagnostics and turn on Console Logger and Log MIDI In Events
  2. Play some notes and see if they show up.

(if for some reason Console Logger doesn’t work under Wine, leave it turned off, play some notes, shutdown Cantabile and then check the log.txt file).

Also, check the log file for errors.


Thanks Brad…set it all up and re-booted and for some reason it started working and I got audio and MIDI…then the system dropped the USB audio device (XR18) and I had to shut down and start again.

So that’s an issue I need to address separately - but for a while I had it working :slight_smile:


ok, so it seemed USB_AutoSuspend was on…was supposed to be off :hot_face: Since I set that, all good so far.

One thing, it needs the share option set to on…with it off the audio engine (within Cantabile) stops. And interestingly also stops the MIDI service.

Experimentation continues :slight_smile:

EDIT: Oh just to add at this stage I am running Sampletank4 (VST3) and Pianoteq (VST3)

1 Like

Excellent. Sounds like you’re making some good progress. I think you should post some screen shots :slight_smile:

Thanks Brad - still some random audio gremlins as in, C3 will not start the audio engine by itself, it already needs to be running in another app. Maybe Qjackctl may help here? I haven’t installed or run it as yet. Basically the only option I get in C3 is “Wasapi out - Pulseaudio” or Null - so I need to somehow have C3 see the pulseaudio/alsa as a surrogate for Wasapi - may even be a config somehwhere in WINE??

Although once started its pretty solid!

More experimentation needed :smiley:

When I have a definitive method to get it working 100% all the time I’ll will post some stuff.

1 Like

Ok just installed the new Pipewire architecture (it replaces Pulseaudio) - I have stopped and started C3 several times now and it runs the audio engine fine, yay!

Slight issue with latency though, I estimate it’s about 12-15ms which is just noticeable, but enough to be annoying. Just researching how I can sort that.

It’s not possible in C3 as the dropdown only goes to 256 - I suspect as it is being governed by the underlying system.

Ok got that sorted now too…ran pipewire-jack dropin reset there to the 128/48000 and it’s pretty good now :slight_smile:

Here is C3 running in Linux Manjaro (Pahvo) with WINE-Staging 6.14, Pipewire and Qjackctl (the latter ONLY being used to set audio rates)

Nice. Why is the menu bar text green. Is that the system color for menus?

tbh, not sure, that’s probs just how wine (under the colour scheme of Linux) presents it. It’s green in another WINE app iirc, but I can’t recall which one haha! (I can make some further investigation if you like Brad? I personally like it :slight_smile: )

Yeah this Pipewire is the bomb I reckon…all I did essentially was remove pulseaudio packages, install Pipewire, reset the system output device to the USB Audio (XR18) and started C3, and it started fine! It still uses ALSA (as you know the ASIO/WASAPI equivalent in Linux, Pipewire sits immediately above that.
I used Manjaro as it has a GUI Kernel manager and will allow one to run a RT (real time) kernel - not sure how much difference it makes nut it does seem to speed up the system a bit.

I even ran some media files in it from a Linux drive partition, all good…hahaha! SO far :wink:

1 Like

That’s awesome. No need to investigate the menu colors - just seemed odd, but if other apps do it then fine.

1 Like

Brad, an interesting (well not really it’s a bit annoying hahaha!) glitch…

I reset WINE audio to default to ALSA (as you know the pseudo ASIO equivalent in Linux) and when I opened C3 after that it asked me to re-enter my licence details, which I thought ok fair enough, BUT when I did that I get the message : Error: TrustFailure (Authentication failed, see inner exception)
All I can do from there is close down the app.

Any idea why changing the default WINE audio could cause that?

Hi @pax-eterna

No idea why changing the audio config would require Cantabile to re-activate as nothing about the audio is used by the licensing code. I guess something about the config change made Cantabile think it was on a different machine. Weird.

That sounds like an internet error rather than something internal to Cantabile. Can you access the Cantabile website from that machine? One workaround would be to use offline licensing.