Win 10 Version 1903 Issues


#1

Hi All,

I have read where some users have already upgraded to this version (1903) without reported incidents. I have not had the same luck or experience. On 3 laptops and a studio tower I performed the upgrade to 1903 and on all 3 I ran Latency Monitor to do an initial look at whether there was any change in the latency readings. They were a little higher than on the previous version but seemed stable for 3 or 4 minutes of testing on the first laptop so I thought all was well and upgraded the rest of the machines. Upon testing the tower it became apparent right away that there were DPC spikes occurring that were causing pops and glitches that were not there before. I ran the latency monitor for a longer period on all devices and discovered that there were random spikes all being caused by ntoskrnl.exe. Some spikes were as many as 8 minutes apart! This had never occurred before on any install so off to the net I go to see if anyone else had the problem and low and behold many people have had the same issue since this latest release. Luckily Win 10 allows for version rollback and so I rolled back to version 1803, retested all of the machines and presto, back in business. As of today this is not affecting everyone and is not a solved issue as far as MS through any patches etc for those that are having this trouble. If anyone else has some had some experience with this problem (I think it’s a newly introduced bug) Please post here with any fixes or possible tests or things I may have missed.

Thanks!

Dave


#2

I haven’t updated to 1903 yet, but have found similar complaints after researching the update in response to reading another thread here. There are also a lot of mention that Microsoft will force this update on users soon even if they have rolled back.

  • Paul

#3

Nice catch Dave… hopefully MS will get this sorted before forcing it on us.

If you find external references to this issue, could you please paste links to them here - it’d be good to have one place to keep track of all such discussions.


#4

Same topic in this forum :
https://forums.geforce.com/default/topic/1120890/geforce-drivers/win10-ver-1903-ntoskrnl-exe-large-latency-spikes-/4/


#5

I pinging Pete Brown at Microsoft about this:


#6

Following the twitter posts, there seems to be a page for reporting problems on GearSlutz, which I thought I’d post here directly.

https://www.gearslutz.com/board/showpost.php?p=14041946&postcount=7060

Will be checking my systems out later…


#7

haha in a way I am lucky as my laptop simply refuses to update to 1903. Not sure why. SO even if MS “force” it, it won’t update unless I re-install the OS from scratch…which seems to be the “temporary” consensus on how to fix it.

Me? I 'm not going to bother I think.


#8

OK … So he would like this if you have a machine loaded with this update and are having audible glitches

  • Open the Feedback Hub app. Report a problem.
  • Summarize the problem as appropriate. Select “Devices and Drivers” and then “Audio and Sound” for the category.
  • Choose to “recreate my problem” and record audio with glitches present https://matthewvaneerde.wordpress.co…-feedback-hub/
  • Once filed, grab the link from Feedback Hub > Feedback > My feedback and send to me pete dot brown @ microsoft dot com with an obvious audio-related subject.

This seems do-able and easy compared to the old days but I’ll need to get somes gigs behind me and set up the conditions before I can help but I am 100% certain there were noticable audio glitches that corresponded to CPU spikes pointing to ntoskrnl.exe in the Windows Assesment toolkit tests I ran in addition to the Latency Monitor tests I ran. In some cases they didn’t occur for many minutes so short tests would not necessarily catch them. Hope to help out when I can get it set up again but my studio and live gear has to be reliable for the next while before I can afford the time to help MS out.

Dave


#9

Hi, I keep telling you what the likely problem is and the solution :wink: but of course, if you don’t want to update, leaving it broken is not a bad move :slight_smile:


#10

I updated two days ago to 1903.

I did the test with LatencyMon this morning and initially did see dxgkrnl.sys and nvlddmkm.sys (NVIDIA Windows Kernel Mode Driver) both cause the test to fail in less than ten minutes time, and tried three times (one test failing within 3 minutes of starting the test).

I went into the device manager and selected the properties of the Nvidia graphics card and selected “Update Driver” from there, and it did find a driver (that wasn’t there a few days ago) and installed it. After a restart, during which I checked into my BIOS to see if anything was amiss there, the test passed with flying colors for 3 hours 11 minutes. This is an installation that had been optimized with the “Glitch Free” optimizations before the Windows 1903 upgrade, and nothing was done afterward other than this morning’s graphic card driver update.

So, see if you have a graphic card update waiting for you to fix this already. It seems they are on it.

Terry


#11

haha yep I know :wink: but hey, if it’s working then it ain’t really broke then is it? :wink:


#12

That’s why i stay at 17xx version with all updates disabled. :slightly_smiling_face:


#13

Ok, more to report.

I have a unique situation here, in that I have one decent computer that I dual-boot into two Windows 10 installations on separate SSD’s, one optimized for Audio (ala “Glitch Free”) containing only audio programs on it, and the other Windows has everything plus the kitchen sink! So, seeing the audio-only one had defeated the ntoskrnl.sys/dxgkrnl.sys/nviddmkm.sys overloads in LatencyMon, I had now to figure out why the OTHER Win 10 1903 installation on the other drive was still acting up! It already had the latest video drivers and all drives were trimmed and scanned, memory and paging optimized, etc. but I was still getting the full-on RED bad-boy result from LatencyMon.

I reasoned it likely was an errant piece of software, similar to how a bad plugin will mess up our host (Cantabile) or DAWs, because to my understanding ntoskrnl.sys, dxgkrnl.sys and nviddmkm.sys are all pretty much just mindless robots that have to take orders from on-high, that is, from other programs, and those other programs are what drive them into the red zones.

I also had a lot of game stuff on this installation, and reasoned that it likely was some piece of software that “phoned home” regularly looking for some updated whatever from the cloud, was a heavy DirectX Graphics user, and was misbehaving. I uninstalled the following in the order presented:

  1. GOG Galaxy
  2. Nvidia GeForce Experience
  3. Steam
  4. Dropbox (first paused, then quit)
  5. Airtable

Removing Airtable (which connects to a cloud database server and I am guessing uses a lot of DirectX Graphics commands to draw its user interface) was what finally stopped the overloads. Yes, running a browser did just barely overload LatencyMon still, but I don’t count that. It stayed nice and low in “passing” grade with the system idling for over half an hour.

Now I am going to reinstall each of the first programs I removed. Airtable is definitely a culprit, of that I have no doubt. But I need to discern now which if any of the other programs might have been contributing to the problem.

I’ll be back with more info later, but that is my detective work to date, and I now do have both systems (even though the “loaded” one is still full of all kinds of programs installed) working in “Pass” mode in LatencyMon.

Terry


#14

I know some people like that! :rofl:


#15

Hey Terry,

Were both installs working on version 1809 or what ever you were running before and got cranky after the update? And did you notice a drop or increase in the DPC averages?

Thanks

Dave


#16

Dave,

The audio installation was perfect (in 1809) until the 1903 installation, and it only took the driver update to set it right again.

I never cared about a perfect LatencyMon score in the other installation when in 1809, but would not have accepted a monsterous red burst like I was getting in 1903! So, yes, it got worse in 1903, but it seems to be something to do with DirectX heavy programs that are cloud connected in some way and regularly “phone home” for updates or data. NONE of my MULTITUDES of software on the “loaded” installation are acting up now, and even with Chrome open it is not going crazy. (Still waiting for that shoe to drop… I think browsers natively do nutty things to LatencyMon eventually!)

Terry


#17

Thanks Terry, good to know. Let us know when you do an extended music performing/recording session like you are known to do!

Dave


#18

Heh - will do!

Terry


#19

Steam is very naughty if present in tray, but might behave if exited from tray icon. Still checking that.

GOG Galaxy checks out ok whether present in tray or not…

Terry


#20

Today I updated an older HP computer that ran an AMD Phenom X4 830 processor with an older Nvidia GeForce GT520 graphics card on it. I don’t think I will have any hope of getting an updated graphics driver on that one, and it is exhibiting the latency issues pretty badly on 1903, so I have rolled it back. Awaiting further news as far as that computer is concerned. (It is my streaming computer.)

At least rolling back only takes five minutes…

Terry