Use MOTU sound Module or Dante software

I am currently having a high audio load that results in occasional glitches. My PC is I7-8700, 32G RAM, Samsung 960 pro 512G so I should have enough power. My sound module is MOTU 828X running from USB-2 port. Buffer set to 128. Very recent version of Cantabile. I typically see 50-65% load when I am not playing anything.
Reading other posts concerning this type of behaviour has left me confused as to where the problem actually lies. So I think I have two choices, try to resolve the MOTU issues or switch to a Dante software controller that will feed my digital signal to the Dante system in our church and skip the D/A conversion altogether. This, of course, would not be a solution in a non-Dante situation. Dante also makes a dongle from USB-3 to ethernet which I would switch to if I can integrate with the rest of the system.

If you have experience with Dante system integration I’d like to hear about your experience.

If you have experience with MOTU sound modules like the 828:
which driver worked best for you, MOTU or ASIO4ALL?

Is the audio load related to buffer size ( ie make it bigger, more latency, but load goes down) or is it a measure of how the sound module is keeping up with the PC. that part is not clear in my mind.

I guess a third option is to get a better sound module. What models are hot right now?

Thank you all in advance for any advice you may have.

If you haven’t read @brad’s “Glitch Free”, it is the best first place to go (it is free on site). You always need to use the interface driver, instead of Asio4All. Audio load is related to buffer, but I would 1st ask, what are you loading into a song. If you are using several instances of large sound sample programs, it will eat your resources very quickly.
Following “Glitch Free” advice, you will cut out all the resource hogs that are standard to most computers. Also, look at Task Manager while using Cantabile. It will point you to problem areas. I don’t have the computer power you have, but I rarely run over 50% cpu load. That’s even when I run Omnisphere and Keyscape. It is important to run lean vsts on a live rig, just to keep everything in check. Again, massive sample libraries will eat your resources. I use modeled vsts as much as I can. I find very little difference in live sound. If I am recording, yes, the beautiful sample libraries come into play, but not live.
Also, don’t put all you eggs into one basket. If you don’t use the libraries in certain songs, don’t load them into every song. Just load what you need. Another sound module will not correct your problem. Correct it 1st, before running to other sources.
Hope this helps. A screen shot of your settings, and song routing helps in diagnosing your problem with the the experts here, of which I’m not.



PS…Also use the profiler in Cantabile (under "view) while using your normal load. It will also pinpoint resource problems.

1 Like

Thanks for the reply Corky. Just to clarify a couple of things, I have religiously applied Glitch-Free. i don’t even hook my PC up to a network if I can help it and that helps to control Windows updates.
I have one song that I use and I enable/disable each instrument instance using an Arturia BeatStep (pads, knobs). While this takes more RAM to load everything, I was under the impression that audio load was only incurred when a particular instrument was enabled to actually play something.

Thanks for the tip on the profiler location. I will get a screen shot of that asap.
My instrument list includes:
Lounge Lizard - modeled
Omnisphere - sampled
Keyscape - sampled
Blue3 - modeled?
B3X - modeled?

I can run all those without a problem. First off, are you pre-loading everything? This from @Torsten:

I found that de-activating and re-activating racks over the course of a song may create CPU spikes during the switching process, so I’d rather activate and de-activate routes to my song racks and leave them all active. If a song creates so much load that it requires deactivating plugins, this is a sign for massive risk of spikes when switching. In these cases, I try to reduce CPU load

I also disable routes, instead of disabling plugs. I find @Torsten to be correct on his observation. Leaving everything “abled” seems to be the best way, avoiding spikes. With everything preloaded, you are at the maximum, and disabling routes only disconnects the route. I do this a lot, especially when I am using only one keyboard.

Here is my profile. Note CPU vs Time Load. That seems like a problem.

Yes, I disable routes and leave all plugs enabled.

That actually looks good. If you put your organs or pianos in a combined rack, you could disconnect the rack, instead of all the plugs.

The one thing I didn’t mention is I am using only SSD drives now…big difference on load time.

Drive C is SSD, the drive with the songs, etc will be SSD this year. The time load % is the problem though. because I’m interpreting it to mean without playing a single note I have less than 50% of my processing power in the sound module to actually use to make music. Am I understanding that correctly?
Would increasing the sample size a bit help that?

I take time load to be CPU use in loading. If you look at the right frame, it matches your max CPU use. As it is sitting there, your meter reads 3.9% in Cantabile, and your system at 4.7%. Not bad at all. I use one of the buttons available at the bottom of Cantabile page bound to current running CPU load. Truly, in my old eyes, it looks really good. Someone may call me out on it, but that’s what I’m seeing. :wink:

I use it as a CPU monitor, as well as a clock on another button. Very handy.

Corky, I appreciate the input. Maybe some of the others will chime in…

BTW…I use 512 buffers (works well for me), and I use 44,100 samples instead of 48,000Hz. In live playing, it will affect your CPU. I would only use 48,000 in recording. The buffers at 512 really reduces CPU, but others would say that’s too high. It works well in my Focusrite with super low latency. It’s always good to experiment.

1 Like

CPU and Time Load % are not bad. It might be a DPC problem. You can try running LatencyMon for about one hour and see what happens.
Corky, what do you think?

Yeah, buffers at 256. Split the difference. I use 256 and never notice the latency. Also, take a look at Process Lasso. It manages a lot of the settings and power management.


certainly 256 bit buffer size is a more balanced value, however Steve’s PC is an i7-8700, a desktop 6-core processor. There is something odd, it supposed such PC is suitable to run smoothly his plugins configuration. That’s why i think a trouble with a driver and/or hardware. LatencyMon should detect them.

From what I’ve been able to learn, the CPU load on your system is pretty high compared to the Cantabile load, which possibly means there is something else outside of Cantabile causing the spike. As @cpaolo mentioned, making sure you have the newest MOTU driver, or reinstalling the driver you have, could cause a problem. Many of us seem to develop a corrupt driver occasionally. Computers… :crazy_face:
@RackedBrain was right about 256 being a starting point for buffers. Process Lasso is a good suggestion.

I had problems on one of my new machines recently. It turned out to be a graphic card default setting conflicting with Cantabile. It took 3 months to sort out. Just to show, any little thing can cause big problems.

Hi Steve,

This may not be helpful but in my experience the 3 IK plugs you are running (B-3X, 2 X Leslie) are the big resource eaters here and they are only idling in your profile picture. My machines would definitely not be able to handle that load at the same time. As soon as I would ramp up any of the leslies (you have 3 going at once) it would overload the processing cycle and pops will occur. The resource use numbers on all 3 match up with what I would see here on my machine so your plugs are working the same as mine. The method I adopted was to pre-load my plugins and racks but only had the ones I used in any given song in the set list. If you use all 3 in the same song then of course it wouldn’t be for you but I thought I’d make the observation to see if when you truly disable or remove the extra leslie plugins you have running does it get better. I’m pretty sure it would. Just my 2 cents …


OK I have some things to try. i will report back what i find. Thanks to all for your input!

1 Like

TBH, an idle load of 65% would be something I’d want to avoid - you’ll want ample CPU headroom for when the notes come in. On PC-based audio applications, you don’t want to get anywhere near 100% time load - there’s too much in the rest of the OS that can cause spikes and glitches when things are too critical.

I usually try to keep all my setups at a maximum of 70% time load (when playing!!) on my live system - anything above that is playing with fire…

I’d strongly suggest you “clean house” in your setups - The B-3X is already pretty greedy - why another two IK Leslies? Whenever I have multiple hammonds im my songs, I usually use the B3-X only for the most prominent part, and other (less resource-hungry, e.g Blue3 or VB-3) plugs for layering or chord work.

Omnisphere and Keyscape are also known as pretty resource-hungry, so maybe you’ll have to prioritize per song - only use one or two “big” plugins for the critical sounds and “cheaper” ones like Korg M1, Xpand, … for the bread-and-butter around them.

One factor for me is also the effects side of things - I’ve narrowed down on Valhalla VintageVerb for all my reverberation needs - far lighter on the CPU than other options like FabFilter Pro-R or others.

So I’d encourage you to slim down your songs - use only the racks / instruments you really need for that specific song and avoid “everything and the kitchen sink” types of setups.

Hope this helps!