Switching states while playing changes gain for disabled midi route

I love how Cantabile won’t change the midi routing when switching states until you let go of all the notes. This makes it easy to set up for next part of song while keeping current part going. However, it will change the gain setting, which is a problem. Let me explain. Imagine I am using just a Jupiter plugin on verse and just a Prophet plugin on the chorus. I enable and disable the midi routings in each state and it works great. Now in the verse I decide to lower gain for Jupiter. If I am playing the Jupiter patch and I switch to chorus state, the gain jumps because I did not change the Jupiter gain in the chorus state. The workaround is to change the gain to the exact same value in both states. But this seems like a bug to me. The gain of a disabled midi route should have no effect. Furthermore, I’d prefer that no behaviors in the state change while notes are held, not just midi routes. Could be an option if some folks want instant switching. Am I missing something?

could you post a pic of your instrument rack while it is opened to show what midi and audio routes you have and how many states you have. I think I understand but a pic might help … and when you change the Jupiter level what do you use to do it. Slider, Expression Pedal …?



Thanks for your help. I am changing the gain using the gain control in routings tab. I attached some screenshots to make this clearer.

Thanks that helps but the behaviors of the Jup 8 plug won’t show unless you select it in the lower pane.


But I still think I am getting to where I get your situation. If I am understanding you start on the first state with the jup 8 on 0 db and during the state you turn it down. On state 2 it isn’t used because you disable the MIDI route. Then when you switch to the 3rd state the jup slider jumps to 0 db and you want it to remain where it was before you did state 2. is this correct?

When I switch from first to second state while I hold a chord on the Jupiter, the gain on the Jupiter changes even though its midi route is disabled.

Ok, Thanks, The reason for this is that you have the Gain Level State Behavior checked for Jupiter 8 and likely all others since it is a default behavior that Cantabile racks loads when you place a new vsti in it. The audio slider is not affected by the MIDI route switching at all. It simply blocks MIDI messages from reaching the synth. The rack and it’s plugins are still on so state changes will affect the audio sliders even if the MIDI route is OFF. Unchecking the state behavior for the gain level will stop this from happening but may present new issues in your setup. Anyway, that is what is happening and is the normal way it works.

Now that you explain it, it does make sense that plugin gain is independent of midi routing. With this established, let me lay out my scenario again so I can more clearly explain why I found changing states so surprising.

I set up all the midi routings to change between Jupiter and Prophet in first and second states. It worked wonderfully. I was happily surprised that the sound did not change until I released all the notes, since this is exactly what I wanted and I did not see anything about this in the user guide.

After getting it all working, I decided the Jupiter patch was too loud in relation to the other patch and I lowered its gain. I was very confused when the Jupiter volume jumped up as I switched from first to second state. I was assuming that the state did not change until all notes were released. But it appears that the state does indeed change, and only the MIDI routing change waits for all released notes. Thus the second state is in a mixed combination of old and new until the notes are released. This is not what I expected.

Ideally the state would not switch at all until all notes are released. Since some people would not like this, it could be a per state or global option On the other hand, there is no option to make midi routing instant even if notes are held, so maybe everyone expects this.

1 Like

Glad we got it sorted, as far as documenting this issue, it will be OK, the whole forum site is a huge data base with a great search function and since we had a discourse others can locate it now too. There are also of course the videos and online docs on the mother site as well. And there is a WIKI that was started here



I still think the current behavior is not ideal, since holding notes leaves the state in a mix of old and new settings. It would be better if the whole state switch waited for note release. I will request this feature.

I have not discovered a good workaround yet. That is, I cannot find a way for the first state to use the gain behavior on a plugin but for the second state to ignore it. Here are the poor workarounds I have come up with:

  • Set gain and plugin preset to be the same in the first and second states.
  • Change states only after releasing all notes. For songs with quick transitions, this is quite challenging.

Is there a better workaround I am missing?

Hrm… this is a problem and I don’t really have an answer. Let me think about this and see if I can come up with something. Delaying state switches might be a possibility but it sound messy so I’ll need to look into it.


Thanks, @brad. I look forward to seeing what you come up with!

Another idea: When changing states, do not make any setting changes to a plugin if midi is not being routed to it.