SpeakUp not communicating


#1

I’m trying to use the SpeakUp VST combo (SpeakUp Sensor and SpeakUp performer) to create a bit of live audio ducking.

SpeakUp Sensor does it’s job as a simple gate that detects when your volume crosses a certain limit.

SpeakUp Performer however, the VST that does the actual ducking, receives no signal from Sensor, so it does nothing.

Any way to get 2 VSTs to interact?


#2

Hi ZyphenVisuals and Welcome,

I’m not sure which version you are using but generally this is done with the audio routing. Shown below is an example of 2 vsts routed in a series configuration. The mic goes to the Desser and it feeds the Compressor and it’s output goes to the speaker out …

this is the graphic version of the same thing if your version has that feature …

Cheers,

Dave


#3

HI Dave, that’s not quite what I’m talking about.

The Sensor and the Performer are each placed on different audio routes/drivers/whatever you call them.

Think of it like a sidechain compression technique for voiceovers.

The Sensor is placed on the vocal track, and it detects when you speak and when you don’t.

The Performer is placed on the background track. It should (but in my case doesn’t) receive from the Sensor the information of wether you’re speaking or not, and duck the sound accordingly.


#4

Apologies for my misunderstanding. I will look at the question from that perspective and see if I can see a solution …

Dave


#5

No problem!

For now I’m using Reacomp from Reaper to achieve a similar though slightly worse result. Since that one doesn’t use 2 VSTs but rather 2 inputs on 1 VST, it was much simpler to set up.


#6

Hi ZyphenVisuals,

This is a revised explanation based on more info on the plugin. Apparently it needs no side-chain port but has it’s own discreet control channel system. In the videos that explained you simply dropped the sensor on the voice route or track as the last insert and do the same with the performer plugin on the backing track. All the rest of the setup happens on the sensor and performer GUI’s of Speak up after that. I am explaining this with no test. So …

To wire this in Cantabile you would route it like this example I created below. The first input is optional if the dry mic vocal is through the mix board. The second input is from the same mic and goes to the input of the Speakup Sensor plugin. Notice that it’s output is routed to the side-chain route I spoke of in the Speakup Performer Plugin.

graphical view

The Control settings on the 2 plugins need to be set to the same control channel. A, B or AB.

I hope this is more on the right track and might work out … :grinning:

Dave


#7

Hi, thanks for answering.

When I add a stereo Input port for Performer, I can’t see any sidechain channel. Am I doing something wrong?


#8

No you are not, you did it right. I am vexed by this. Do you have the manual or a link to it? It is not available to look at on the site, it would help me out. Thanks.

Dave


#9

I don’t have it unfortunately. I’ll try updating all the software involved tomorrow. Ended up using reacomp


#10

Sorry, If I can get more info I’ll check back, maybe there are some good videos on it.

Best Wishes!

Dave


#11

I did a look at the videos available and based on that I re-wrote the explanation above

If this doesn’t fly could you give details I am curious how it works in C3. It looked easy to use in a DAW as you said. :grin:

Dave


#12

Yep, this is what I first attempted, using them without connecting anything. I’ve even tried it in Reaper and FL Studio and both work. However, it doesn’t seem to work in cantabile. Just gave up on the plugin :sweat_smile: