[Solved] Mouse Down after Scroll Wheel lands in the wrong place

I’m having an issue when moving to the Binding Window, scrolling down using the scroll wheel (may be related to Mouse scroll wheel question ??), and then clicking somewhere. The mouse click lands on an unexpected widget - and looks to be the widget that would have been at that screen coordinate if I had not mouse-wheel scrolled.

Here’s a video, showing this happening after I change songs.

May need @brad attention …

This is something that happened to me quite a few times…but I hadn’t noticed the correlation with the mouse wheel!


I just tried it by grabbing the slider on the right side of my (long) list of bindings, and it also fails (wrong mouse target) in the same way … so … the Mouse Wheel thing may be a red herring …

I’ve seen this issue for quite a while, but it’s one of those “oh I must have clicked in the wrong place” things … only until I had to do a repetitive task like 40 times was I inspired to report it …

Wondering whether this Brad should be alerted on this?? Was concerned it could be my issue …

I think we should alert him, but I guess it would be very difficult to debug if there is no way to reproduce the problem at will.

Yes, i’ve seen this for a while (maybe since the beginning of Cantabile 4 ?) . Anyway, quite easy to reproduce.

  1. Open Cantabile
  2. Select a song with more than a screen’s worth of routes and obects (in, my case, it’s the last song in the setlist, if that matters)
  3. Scroll down with mouse wheel
  4. Click the handle of any object → screen scrolls back up with the wrong item highlighted.

@Brad ?

I too have a problem. I’ve noticed selecting a song from the setlist with mouse, but it will jump to another song. Noticed this for the last several gigs, and it delays me from jumping to selected song as another unselected song loads. I am not with my rig today, so I can’t tell what version I am using, but will post info when I am able to check it out.

Thanks for reporting this.

I was about to post back that I couldn’t reproduce it… and it happened.

Not sure what’s causing it but I’ll dig in and get it fixed asap.

Found it + fixed it for the next build.


Thank you Brad!

1 Like

Fixed in 4163 available now.


Fixed! … in v4.163