Single Shots in Media Player not ending


I use media players together with bindings to fire single shots triggerd by keyboard notes. This worked flawlessly. Today I loaded some songs that use this and found that I’m still able to trigger the media player but media player wont stop (I get values far above 100%) so I have to separately stop it.

Could it be that some new functions were introduced during one of the latest updates I’m not aware or could this be a bug?

Kind regards, humphrey

I think this is the same bug that’s afflicting my media bindings, Humphrey.

Hi Ade,

found the corresponding posting. Thanks for clearification - this could fit.

Regards, humphrey

Guys can I get some clarification of exactly what’s not working here. I’ve just run some tests and the play range with no loop seems to be working fine. Is that the problem or is it something else?

Hi Brad,

not at home atm, so only as I rember it:

  1. Load an existing song with media player in it. No loop and binding key-start = worked flawlessly and play stopped at the end
  2. Loading same file now leads to: file in media player starts but doesn’t stop automatically
  3. Meanwhile found: replay parameter = All (and cannot be changed - there is another setting who’s name I din’t remember atm). To change it I have to move markers first (even miving forth and back again is sufficient) - behaviour can be changed and everything works as before…

Here’s the test project I set up for autoplaying a media list.
It works in 3210 but 3216 fails. (2.5 KB)

Ah ok I see - it’s when there’s not play range set that playback doesn’t stop at the end of the file… got it, I’m onto it.

New experimental build 3217 should fix this.


Just gave it a try - works now as expected (even for older songs).

Thanks and regards, humphrey

1 Like