Problem With Controllers and Routing

controllers
Tags: #<Tag:0x00007f52bd487788>

#1

The last two weeks, I’ve had daily gigs and rehearsals (very busy). Both laptops were using 3583. I was using my small gig rig for most of the gigs, so same controllers, and everything was working perfectly. Got to a gig, no lower keyboard sound. Frantically found my main keyboard was unchecked for key1 (main keyboard). I never had this problem before. Still no sound…checked meters and midi activity lights. Midi was now working, but meters were not lighting at output. Thanks to the wiring view, I immediately discovered there was no output route to main speakers, and many of my long used and reliable songs now had routing and binding issues. I also found the same issues on my backup laptop.

I checked release notes and found 3586 Fixed - issues with system-wide keyboard bindings. I upgraded to 3587 (since it was stable). It checked out fine…went to gig last night…no lower keyboard. I had to (again) check the box for my keyboard in key 1, and re-routed the output again on the fly. No doubt it has been stressful, and was wondering if anyone has had these issues. I do not understand why many of my midi input ports bindings and routings are suddenly missing, even though I have corrected them in both laptops.

Corky

EDIT: BTW…I always use the same usb ports for my controllers.


#2

I’m guessing you have some back up files of the same songs that went haywire, but have you tried copying one of those to your system to see if it loads funny too? Also, is happening on every reboot of your music laptops?


#3

Hi Dave

I did back up my files and put them on my 2nd laptop. I started having this problem about 2 weeks ago on my main laptop. I haven’t tried using a backup file on my main system. It is not happening every reboot. What mystifies me is, I do the corrections on the same rig I use in performance, then go out to gig and will have to check the tick box in midi ports to enable the keyboard. Then, I will have to edit output port in several songs because there is no connection from vst. I use the same usb ports for the same controllers. It has always worked fine, but now has become a problem. I tried it on another rig, and it also seemed to uncheck those controllers for the main keyboard. Really strange.


#4

Thanks Corky, from your description my money is on the hub being the problem or a possibly a USB cable but I figured you probably did the cable dance, intermittent connections can often be cable based or loose USB ports but who knows if that’s the case here. I’ve never seen C3 uncheck a port box before in options like this (it usually says “disconnected” when you put it in a differenent port) … funny too that it’s always the lower keyboard, I’d try putting new or known good cable in that connection to rule it out.


#5

I’ve tried different cables also. After your last post, I am thinking maybe the usb ports could be wearing out, but that doesn’t solve the midi port deselection. Got another gig tonight so I will have to test at the venue.


#6

How about a downgrade? Did you test an earlier version of Cantabile?


#7

Hey Christian

Thought about it because I normally do that when things go haywire without explanation. I will have to wait till after gig tonight as everything is packed. Hopefully I will have some time before gig to check out a few things. I barely got setup last night before starting. Venue at fault.:rage: I started checking rig 2 minutes before countoff. I corrected as I was performing.


#8

Hi Corky,

Sorry to hear that’s happening, definitely stressful. After several minor mishaps during my first onstage uses of Cantabile (due to inexperience, misconfiguration and amazing coincidences of weirdness with hardware*). My first few times reacting to problems were not my best troubleshooting moments so I’m very interested in following how you solve this. I have a Cantabile goal to be able to quickly run down a list of things to check for no midi and no/wrong sound.

  • Arrive at venue, forgot headphones so borrow bass player’s Vox headphones made to plug directly into bass guitar. Can hear things are working but there is AM radio and static. One of my song states was for Hybrid - it sounded strange but figured it was the headphones - turned out the filter cutoff was reacting to the drawbar sliders and my beautiful strings were mostly static!

#9

Hey @Corky

Sorry to hear about this.

I can’t think of anything that has changed recently in the area of environment level MIDI/Audio ports, so I don’t have any explanation off hand.

My first thought was the MIDI driver chose a different name for the device when plugged into a different USB port - but you say you’re not doing that.

Unfortunately without some more details it’s going to be extremely hard for me to figure out what’s going on here.

Can you reproduce this? If so, the best bet would be to get a copy of the settings and song/rack files before you make and changes, and then a copy after you’ve fixed it. I could then take a look and see if something was just missing before or had a different name etc…

Anyone else seeing issues like this?

Brad


#10

@brad

I had time to check things over before beginning last night’s gig, and one of my controllers was unchecked in the tick box, even though I checked it the night before. Before I ticked the box, I made sure that it didn’t say disconnected, and it didn’t. It stayed checked all night, which it didn’t the previous night.
I set the same rig back up at home this afternoon, and all was well. I plan to disconnect all controllers and fire everything up again later this evening to see if I can recreate it. Much easier to do this at home instead of in the middle of a gig. :wink:
I will follow your advice and get back with you, and give more details.

Thanks

Corky


#11

@Corky - you have a “Ghost in the Machine” that is literally un-checking things from within the vapor void of the non-insular cytoplasmic realm inside Cantabile now. You need a countering protoplasm to be installed.

I do this kind of work, and I am cheap for friends, but my psychic is stupidly expensive. I’ll see if I can talk her price down for you.

Terry

P.S. - Do NOT try a cheap ectoplasmic injection from Ebay - you’ll be very sorry if you try those, even though they are inexpensive.


#12

Damn Terry. You might have just nailed the problem.

Well, I need something…I’ll take one of them thangs…whatever they is.

Well…I am cheap TO my friends. Is this psychic a gypsy woman on the Jersey shore? If so, she owes me $75. Talk the psychic down as soon as you can cause I am in a helpless state.

I did get a cheap shot from a guy on Beale Street who said it would cure all my problems, but all it did was put me to sleep and when I woke up, I was in an alley with no shoes and no wallet. Maybe I’ll just call the Ghost Busters, or get an injection from Craigslist. :joy:


#13

Yes, that’s her!!! I’ll remind her about the $75.

Terry


#14

Yeah, when you see her, tell her I want my money, cause she was wrong about getting that shot on Beale Street.


#15

That area of advice is definitely not her strongest suit. But for GITM’s she is great.

Terry


#16

Then send her to me. I have a strong feeling I will regret this. I will have to write her a check to keep my boxes from unchecking. Maybe I just need to be checked in somewhere. Possibly in a box.

Us old folks are up late tonight…aren’t we?


#17

Just saw this. I had a similar problem. I KNEW I fixed that route or setting, but next time it was broken again. I started to blame Google or Dropbox or sync processes, but I traced it to Cantabile not having proper focus when I pressed cntl-s. The fix wasn’t in. So, Barney Google wasn’t to blame (you’re really old if you get that reference).


#18

Thanks for confirming. I have not yet recreated this problem, but it did happen to me on stage and in rehearsal. It started at a rehearsal where I have an older keyboard that is rarely used. No USB so using MIDI cable into interface. Never had a problem before. I was scrambling as the guys were getting impatient. Then it happened at 2 or 3 gigs (don’t remember now) with my smaller rig. Always happened at setup test, never during gig. Once I checked the box again for my controller, it was fine. Still testing.


#19

So it was fine until you rebooted?


#20

No…I had to check the controller boxes in midi inputs. Twice I had to re-add the controller to my main keyboard list. It just dropped off the list. More than one controller involved.

Once I reconfigured, it stayed on thru the gig.