Popping sound when using VST Plugins


when i start using 2 or more VST plugins at once I start hearing some popping sounds, how much CPU or RAM do i need to be able to use several VST plugins at once, so I can get a good laptop to use in church?


Have a look at the buffer size set up in Options / Audio Engine. If this is too small for the capabilities of your machine and audio interface, you’ll get the pops and clicks. What audio interface are you using? Often the number of VSTs you can run without pops is dependent on your audio hardware and its driver.



Hey David.

I’ll try not to be too technical about this - so apologies to the tech-savy crew for not being 100% precise at all times for the sake of simplicity…

“Popping” sounds are usually an indicator for the audio stream being interrupted. This happens when data doesn’t arrive at your audio interface in time to fill a new buffer when the current one has already been played. Essentially, this is the sound of scraping the bottom of an empty barrel :wink:

There are a couple of main reasons for the buffer running empty:

  1. the audio buffer for your interface is too small, so your system is constantly busy filling the buffer instead of calculating the sound. A larger buffer means essentially that your system has more time to actually perform calculations (i.e. creating sound) instead of running back and forth sending new buckets of sound to the audio interface. So a larger buffer will take strain off your system and allow you to process more plugins and play more CPU-hungry synths. But there is a cost: a larger buffer means more LATENCY: essentially this is the time it takes between creating the sound (hitting a key) and hearing the sound. So optimizing buffer sizes is always a compromise between performance (avoiding pops and clicks) and latency. Usually a reasonable starting buffer size for ASIO drivers is 128 samples.

  2. even with a reasonable buffer, your processor may not be able to keep up with the effort of calculating sound in time to fill the next buffer. Have a look at Cantabile’s load meter - it will tell you (to some extent) if your processor is maxed out. There are two solutions to the processor power issue: (1) get a faster one and / or (2) get more cores to work on the processing in parallel. For “normal” plugin and VST instrument usage, a current quad-core Intel i7 processor is more than adequate - most setups can actually be run on a current dual-core i5, unless you really are using tons of CPU hogs like DIVA…

  3. If the processor is not maxed out and you are using a number of sample-based instruments, it could be an issue of samples needing to be continually loaded and unloaded or streamed from disk and the disk drive not keeping up with the task. First category: if your samples are all loaded into RAM but your don’t have enough RAM, Windows will continually try to swap the ones you are not using out of current RAM to your disk drive and get them back when they are needed. Needless to say, this is a sloooooow process - will disrupt your output. Check for that in Cantabile’s memory usage indicator - it will show you how much RAM your current setup is consuming. There are also samplers like Kontakt that don’t load all their samples into RAM - they stream part of them from disk when needed. Again, if your disk is too slow, this will create breaks in the audio stream. You can fix this either by loading more of the samples into RAM or by getting a faster drive for your samples (M.2 SSD is currently the fastest option).

  4. Lastly. there are vast differences in the efficiency and quality of audio interfaces and their drivers (normally you’re best off using ASIO drivers if your interface has them!). Some you can run quite safely with a buffer of 64 samples without getting pops and clicks, with others you’ll have to use a 256 sample buffer to be safe - on the same machine!

So in summary, I would recommend a current Intel i7 quad-core processor (if you can afford it, otherwise a decent i5 dual-core can already do a lot), at least 16 GB of RAM (more if you use mainly sample-based instruments) and a good low-latency audio interface (RME, Zoom, Focusrite Scarlett); this should give you a good setup to play reasonable setups in Cantabile.




Hi @thejammer213

I’ve writtten an entire book about this, but before anything else, make sure you’ve got your PC set to High-Performance power plan. Any modern PC in this mode should be able to handle 2 or 3 plugins easily (unless they’re very demanding plugins).



Ok thanks for the help, ill have to check those out :slight_smile:


just had a look at the buffer size, it was set to 4 hundred and something, I increased it and now it handles it with no problem, thanks for the help!!! is there a good place to find the plugins? or do i just have to search the web for them?


I’ve posted a list in a recent post - look here: New User here--I can’t get any sound to come out at all! Help me!

This - together with Google - will get you a pretty decent arsenal…




Hi I have read your book and do have Cantabile performer but I still don’t have the confidence to use my rig live do to occasional pops and glitches even after constant tweeking . I have a Asus notebook with windows 10, I7 processor , 16 GB of Ram . My audio interface is Natve Komplete Audio 6 and my main plugins are Spctrosonics Keyscapes , Stylus RMX , Garritan Instant Orchestra and Sample Tank LE . I was wondering if anyone else has had problems with Komplete audio 6 or these other plugins . I usually have 2 or 3 plugins loaded up at a time to create my own patches. I have trimmed down the polyphony on Keyscapes to 20 notes polyphony ,use a buffer of 256 and the load for all 4 plugins is at around 20 percent . Any suggestions that produce the desired results would be greatly appreciative. Thanking you all in advance


If you increase the buffer more does that solve it?


@grossmano, it sounds like your notebook should be powerful enough for the job. I have a machine of roughly similar spec, and routinely run songs with 15-20 plugins loaded simultaneously, without any glitches. I’m not sure about the Komplete Audio 6, but I have heard that Keyscape is very heavy and demanding. Do you still have problems if you don’t have Keyscape loaded?


Hey Neil,
Thanks for your quick response. I haven’t tried my plugins lately but I did have the same problems with Sample Tank running several sounds. but not that often . I am curious to know what audio interface you are using . I am willing to try another interface and see if that does the trick. thanks again.


Hi Fred , Thanks for responding . I have tried moving the buffer to 512 and the results were similar . , thanks , michael


OK… it really sounds like with that rig you shouldn’t be having issues. I’m going to guess a Windows process is running in the background that you haven’t found and shut down yet. it’s just a guess though. Have you made sure your drivers are updated and current for the NI interface?


I agree with Fred - I think if you doubled the buffer size to 512, the glitches should have disappeared, or at least reduced significantly, if it was down to general audio processing load. More likely some other process is kicking in periodically and preventing Cantabile from filling its audio buffers. Do you have wifi and bluetooth disabled? Have you been through Brad’s excellent free book about solving audio glitching problems, mentioned above?


The Komplete Audio 6 shouldn’t be an issue - this is my backup audio interface (my main one is an RME Babyface) and it works nicely with my rig (some very complex setups) at a buffer of 128 samples. Do you have the latest drivers installed and are you using ASIO?

Keyscape seems to be notorious for pulling on system resources, Garritan equally so - looks like a lot of disk streaming going on; not the best proposition for live usage. Are you using a “traditional” hard disk drive in your laptop? Than, moving your samples to a fast M.2 SSD could help.




Thanks all . I have an internal SSD 500GB don’t know if its M.2 though. I’ll keep working at this though . Thanks for the suggestions and encouragements. michael


If you take a look at this thread, you’ll see that others are struggling to get Keyscape to run without buffer underrun as well - even on a pretty high-powered i7 machine with 32GB of RAM.

So it looks like Keyscape is truly a demanding resource-hog; maybe not the best instrument for live use? Maybe start out with some more resource-friendly plugins to build your setup and work your way up towards the more demanding ones step by step.

My favorite resource-friendly instruments as possible substitutes to Keyscape are:

  • Addictive Keys (XLN Audio)
  • Lounge Lizard (AAS)
  • Pianoteq 6

These should cover a lot of similar ground - not at the same quality level, but definitely good enough for live use! I’ve got them at the core of my live setup (current pre-loaded setlist around 160 plugins!), and I use them with absolute confidence.

There is also a whole thread on resource-efficient instruments that lend themselves best to live use - look here.




Thanks Torsten . Good to know i’m not alone . Thanks for the suggestions and the links. :slight_smile: michael