Onscreen Keyboard not working after changing language - Solved

Hi to all.
Some time ago I posted a strange problem regarding somehow the choice of language (in my case the Italian language) to view Cantabile in Italian.
To better explain one of my screens, I sent a jpeg here in the forum but it was translated into Italian. Torsten, rightly, had pointed out to me that it would have been more appropriate to give it in English also to show it to others, so I moved the translator file (… it.json) from Cantabile, restarted C3 and sent the jpeg file containing screen again, but in English.
After this step, I had had sound problems, in the sense that pressing the keys of the onscreen keyboard you could not hear anything. The problem was strangely solved when, however, I had reinserted the Italian language.

Now, having started the recent video that Corky posted for me (instructions for placing multiple instruments in a single rack), I chose to check the various steps with my C3, but this time in English. Following the video step-by-step, at the same time I wanted to check the results in C3: also this time, like last time, by pressing the keys of the onscreen keyboard there is no sound.

So, my questions:

  • Does the “strings-it.json” file contain anything at the configuration level?
  • When the file is reinserted, the sound of the keys is active again. Why?


Not at all. The language file only includes the text strings written in JSON format.

I’m involved in Italian translation, part of this is fiddling with the file to debug it (put, delete, edit, etc.). I can assure you I never experienced the behavior you described. I have no doubts it happens to you, but I don’t know why.

Little advice: although your question is fair, it’s off-topic here. Please create a new thread next time. This will help other users in their search, if they run into a similar problem.


This is behaviour is by design and happens because the name of the onscreen keyboard device changes when you switch languages.

There’s a couple of solutions:

  • If you rarely switch between languages then you can just go to Tools -> Options -> MIDI Ports -> right click on the Onscreen Keyboard port and choose it with its new name “Tastiera su schermo”.

  • If you’re often switching between languages and you want it to always work regardless of language, try this:

    1. In English mode

    2. Go to Tools -> Options -> MIDI Ports

    3. Double click on the “Onscreen Keyboard” port.

    4. Place a check mark next to “Onscreen Keyboard” device

    5. Save options, and restart Cantabile in Italian.

    6. Go to Tools -> Options -> MIDI Ports

    7. Double click on the “Onscreen Keyboard” port.

    8. Leave the check mark next to “Onscreen Keyboard (disconnected)” device but also add a check mark to “Tastiera su schermo”

Now Cantabile will use whichever device is available.

I hope this helps.


1 Like

thanks Brad