Multi-port Audio

I play in a unit w/ two keyboardists. Tom’s rig has two keyboards and he plays out through a Kontact Komplete 6 … which has four outs. I play 3 keys and have an 8 port ESI unit on the way.

Our sound man wants to control each keyboard’s levels in live mix.

We both, on my recommendation, use Cantabile 3 as VST host, and are very happy with it.

Is it possible to multi-port out? In ASIO, I can only see stereo (1/2) porting (via both ASIO4All and Native Instrument Drivers), but in WASAPI, I can see 1/2 as one selection (in Audio engine tab), and 3/4 as another selection.

I can choose one or the other, but not both. Once the selection is made, in Audio Engine tab area, then the appropriate audio ports appear in the Audio Port tab … but I can’t seem to get all four to show at once.

Am I missing something obvious? Does Cantabile support multi-port routing? If so, what’s the trick to getting all the ports to show?

Thanks in advance for any/all suggestions/help!


Hi Kev,

first off: C3 is definitely able to do Multi-port Audio. So not sure what’s happening in your case. Some guessing:

  1. Did you check the asio4all dialog box? As far as I remember audio outs can be activated here. Possibly only 2 are active atm?

  2. How many audio out ports are available in the audio port dialog box in cantabile? I think default setting is one main out & one out for metronome. In this case it would be clear that you only can decide which of the stereo pairs is mapped to the main out. Here you’d have to create a second virtual stereo out (call it main2 f.e.) and map it to the second physical pair.

Good luck and regards, humphrey

Hi Humphrey!

Thanks for the reply!

I did check the ASIO4ALL box, and there were only outs for 1/2 … which I thought strange until I converted the audio engine (in C3 to the ASIO drivers written for the device (by Native Instruments) … which also were only 1/2 out. Going to the Audio ports tab using each only revealed L/R 1/2 out. No multi-porting.

In the drop down box for the WASAPI drivers (Audio Engine tab again), I had a choice of the Master out 1/2 OR Audio out 3/4 … but again, I couldn’t figure out how to get BOTH … because if I chose either of them in the Audio Engine Tab, I’d again have L/R 1/2 choosing OR 3/4 as stereo ports, but not all four of them at the same time. Only two were offered at a time. For instance when I went to “add ports” w/ only 1/2 listed as available ports, then … well, I could choose 1 or 2 … but 3 and 4 weren’t appearing.

Nice to know that C3 will multi-port out … but perhaps it’s a shortcoming with whoever is writing the drivers for NI?

Hey Kev,

I assume your issues are with the Native Instruments Komplete 6 - correct? I happen to own one of these beasts. I like it a lot - decent latency, very stable, and 4 output ports.

Now I’m not sure why you are trying to work this with ASIO4ALL or WASAPI - it has a wonderful ASIO driver of its own, which does expose all its input and output ports to Cantabile (which doesn’t work with WASAPI, which seems to require choosing the individual port at the driver level).

Having installed NI’s ASIO drivers, I simply select ASIO - Komplete 6 in the Audio Engine dialog box.

Now you can choose any one of the NI Komplete’s output ports for your Cantabile outputs:

If you want to route your instruments to multiple stereo pairs, you’ll have to create multiple outputs, utilizing different hardware outputs. So, first create a new output port. Then, for each of these, you’ll have to add physical ports to each of their channels (“Add” button):

Then you have an Audio Ports dialog that looks like this:

Now you can route any of your instruments to one of the three outputs (piano to main, organ to secondary, solo synth to third) and your sound man can go crazy…

Hope this helps!



1 Like

BTW: one even more cool thing: you can have alternative assignments for your fallback stereo audio interface that map all three ports to the same physical output. Now all your three outputs get routed to the same stereo output for this interface. So if your Komplete breaks down and you pull out your backup audio interface (RME Babyface in my case), there is no need at all to fiddle with your song files; everything will still work in your fallback configuration.

But your sound man will be frustrated - no way for him to affect your submix anymore…



Helps? Kompletely solved! :smile:

Thank you so much!

It is that unit that Tom has (along with Ultimate 10), and that will give us all the versatility I need. Your step by step explanation is a wonderful template for when I get my ESI unit in too.

That was amazingly straightforward and easy to follow.

Thanks again – you saved me so much time!

I’d also wondered about the WASAPI drivers … because though I was trying to get sound out of all the ports, I couldn’t understand why they wouldn’t create signal through the unit … and now I know they just don’t work.


Thanks again for the great tip, Torsten! That’s a great advance thing to know.

I just wanted to stop back in and thank you again, Torsten. It worked flawlessly, and we were able to balance our sound all that much better. The latency on the Komplete 6 ASIO drivers are also much quicker than the ASIO4ALL.

Now I can’t wait to get my new device.


1 Like

Extra question: I have a multi-port audio interface (KMIX); I would like to route the Audio output of a RACK (not a plugin) to two stereo audio output ports simultaneously.

I would also like to route a media player the same way. Can you help?

Another ?: Can you just mirror the main output?

Ha … I’ve moved so much further on than my original question. Cantabile is a great program. We’ve new devices … but the basic premise still holds.

I advise you to review above in the information given. You’ll be able to figure it out from there.

It boils to understanding how the program works to make it work w/ the devices you have.

Figured it out…set plugin outputs to: rack stereo out… then in song part, set RACK destination to the actual interface outputs, add route, then set it to another output.

But then I need to change this for every damn state in every song I have!!! or, can I set off the target port in State behavior?

That should work - you’ll still need to adjust every song though but better than every state in every song.

Greetings all! My first post in a very long time!
I seem to have somewhat opposite issues with ‘multiple audio interface’… I have a Yamaha TF3 that I want to control and use both in the studio and out ‘n’ about! The problem is that the ASIO driver (Steinberg) does not clearly expose/identify the port NUMBER as Cantabile reads it, so when I create a port or edit and existing one, when I go to select the physical port, every one of them is labeled simply, ‘Yamaha TF’. With my trusty Focusrite Scarlett interfaces, it lists the actual port numbers on the respective interfaces.

I’m thinking that this is simply because the Steinberg people didn’t think it was important to expose the port number in their software for ‘generic’ applications. I run this board in Cubase, (it was FREE, OKAY?), Sonar Platinum, and another one I can’t remember right now, and they all ‘see’ the port numbers in the driver so I can easily pinpoint the physical port I want to use as the input port in these DAWs.

I guess the question might be, is there any way to edit these ports somewhere else so that I can distinguish them? (34 ‘no-number’ ports are listed for selection!) Now, I try to count down from the top of the list to select input ports from the list of 34, and Criminy, but there’s also 34 OUTPUTS on the confounded mixer, (Gad, but I do love this mixer though…)!
Thanks in advance for any help/advice!
Brion Bell - “I LOVE Cantabile!”

Hey Brion,

You can edit port names here : Options>MIDI Ports


Hi Dave!

…and thanks, but my question is about ‘hardware’ ports, not MIDI ports. The Yamaha TF3 is a digital mixer that connects to the PC like any other USB Audio Interface. It has 26 physical inputs, 16 physical outputs; and 34 logical inputs and outputs. When creating ports, in the Audio Ports section, for example, I create a mono port under which the assigned port is labeled ‘Signal’ by default. When creating/editing the ‘assignment’ for that port, I am presented with a list of 34 items when clicking the ‘Add’ button, and opening up the selection for the actual physical ports on the audio device. Every one of those items is simply labeled, ‘Yamaha TF’ without a numeric distinction. As I said, the driver exposes these numbers when I assign them as input source for tracks in several different DAW systems, but not in Cantabile! Interesting…
Thanks though!


Hey Brion,

You can also customize the audio port names in Options>Audio Ports. Also you can use aliases. See here


Hi, Dave! …and thanks! If you go to the suggested page in your link, you will notice that in the second screen shot, the ‘Channel’ designation points to “Plugin Output - Output #1” - In my scenario, when I click on ‘Channel’ I get 34 listings of 'Yamaha TF" with no numeric description. I must click on the correct one by counting from the top line and as one approaches the bottom of the list, it’s very easy to lose count, especially if one wishes to select a port above say 16 or so where the list must ‘paginate’ or scroll. My query has to do with this ‘Channel’ selection… Using my other hardware interfaces, the Focusrite Scarlett series, The ‘Channel’ selector in Cantabile lists each ‘channel’ with a number, E.G. - “18-i20-Input #2” or just “Input #2”… For my Yamaha TF3, it does not identify the actual 'Channel NUMBER.'
Thanks, though!

Hi Brion

Never heard of this before - sounds like a limitation in the ASIO driver but to be sure, could you post me a screen shot of the channel selection in Cantabile and in another app just so I can see exactly what you mean.


Hi Brad!
Thank you for replying!
(I know it’s been a long time, but it still persists.)
I also know that when I actually assign the ports to channels, the ‘handle’ for that port will always be identifiable. It’s just that I have to carefully count from the top to make sure that I have the correct Yamaha channel for the input.
Maybe it’s really a driver issue.

Image from Cantabile:

Image from Sonar:

Thanks again!

For some reason, the last message had two of the same image, sorry!