Implementing Full Screen Mode


Hi Brad

I’ve spent about 7 hrs trying different things, including straightening out my jbridge error boxes popping up during setlist preload. Never had those pop up before. I did disable the custom menu bar, but it didn’t change anything. I tried all the GuiKits with custom menu bar enabled, and disabled, but could not see any difference.

Here is what I found so far:

GUIKIT 297 worked ok, no crashes, but slow reactions. Quick scan still took about 2 minutes to start scanning.

GUIKIT 298 Crashed without ticking disable custom menu bar. I un-ticked full page, clicked on restore down box in upper right corner. C3 window reduced size, but froze. Ran task mgr and it would not end process. Had to shut down computer. The quick scan DID however, start scanning in 2 seconds, compared to 2-4 minutes in the others.

GUIKIT 299 held up somewhat better, but eventually crashed after I preloaded a large setlist, ran a setlist verify, got out of full screen mode, and reduced C3 screen at restore down box to see setlist verify page (behind C3). That is the same process I used causing it to freeze in 3605, and in GUIKIT 298.

I reverted back to 3599, and even though it was slow going, it did not crash. So, I guess, this somehow involves large setlists (preloaded) and coming out of full screen mode. I’ve had no crashes so far with smaller setlists. Task mgr is consistently showing “implementing full screen” when I pull it up to shut the program down.

I will test some more tomorrow, Hope this helps. Will try any further suggestions you may have. I sent you some logs earlier.



I’m so sorry :frowning: Thank you though, because this information is super helpful. I think I may have reproduced at least one issue here when coming out of full screen mode where it hangs. That’s something I can debug through and hopefully get fixed.

Not sure I understand this. Can you post a screen shot cause I don’t get where this is coming from. It’s not the title from web browser with this forum/topic open is it? This topic is called “Implementing Full Screen Mode”.

Leave this with me for a bit before wasting any more time on it and I’ll see what I can come up with.


Sure. Here it is:


BTW…I wasn’t complaining about the hrs involved. It was just me discovering it is 4AM. Reminded me of the many nights writing code in Fortran quite a few years ago. . :wink:

That is it…I had the topic open, reading your instructions. Sorry, my bad. :laughing:


Hi @Corky

OK, found one bug here where if you start Cantabile and it’s in full screen mode and then exit full screen mode it was incorrectly hiding Cantabile’s main window. This is fixed now in build 3507.

I haven’t looked into issues with scanning yet, but give this build a test first and let me know how things go.

If there are still weird issues relating to scan times, can you send me a log of it:

  1. Start Cantabile
  2. Do the quick scan.
  3. From Tools menu Open Settings Folder
  4. Close Cantabile

From folder opened in step 3, send me log.txt, log-previous.txt, settings.json and plugins.cache and I’ll check it out.



Will check it out. Thanks Brad!




So far working well. I installed 3507, and performed a quick scan. It started scanning within 30 seconds, so much faster.
I preloaded a 35 song setlist with 68 plugins, and was much faster(didn’t time it). I ran a setlist verify, no errors, chose to review. It loaded on top of C3 screen, which is historically normal, but loaded behind C3 screen in last build. I exited verify list, exited full screen, and clicked restore down box. It worked perfectly well in the smaller screen. So far running smoothly without any stutters or slowing down. Amazing how this one bug could make such a mess of my computer.
Will test with larger setlist and report back.


Excellent. Thanks @Corky

Unfortunately, @Neil_Durant’s tell’s me the issue on his machine still persists… so I’ll keep hunting.



Hm, i got a crash when closing down 3507 on stage. Worked well at home.
I’ll keep you posted.


Today I did a quick scan, and it took 1 minute 10 seconds before scan began. I also loaded 83 songs with 121 plugins. They were loaded with many sample plugs, like Kontakt and UVI. I also threw in a few jbridged plugins that were giving me trouble in the last build. It took 18min, 41sec to load it all, but no errors. C3 was running very slow and here is the reason:

95% of my physical memory was used.
I had no errors, especially with the jbridged plugs. C3 slowly held steady through a setlist verification and coming out of full screen mode.
It is going with me to a gig tonight, but I will only preload separate sets and less hungry plugs. :wink:

EDIT: 3607 worked well at gig. Hope @Neil_Durant finds solution for his problem. Still keeping an eye on mine.


The current status of this is that everything seems to be working fine except for the one issue described by @Neil_Durant. My current understanding of it is this:

  1. Only happens when in full screen and the menu bar is hidden.
  2. Happens after loading a set list - and only after loading the set list via the main menu bar (doesn’t happen after loading a set list via the hamburger menu)
  3. Doesn’t happen everytime, (perhaps, not sure, more often if the mouse is left near the top of the screen where the menu bar was activated)
  4. When it does happen, parts of Cantabile’s main UI don’t work. eg: you can work sliders, but you can’t click to select a plugin slot - the button goes dark likes it’s pressed but then reverts to the previous selection.
  5. Try as I might and despite having some half-theories about what might be happening, I have not been able to reproduce it here.

Given that nobody else has reported this, given the other work I’m trying to get done and given that the current stable build has an annoying issue for some users updating from old builds I’m probably going to mark 3607 as stable with the caveat not to use full screen mode with menu bar hidden.

In the meantime I’m going to put in some extra logging that will hopefully provide some more insight into what’s happening on Neil’s machine to try and get to the bottom of it.



Just a quick note - we’ve now found a fix for this issue. It’ll be in the next build. Many thanks to @Neil_Durant for his help and patience in getting this resolved - it was a tricky one to track down.


Uh-oh, it looks like something got broken.

I was so looking forward to these changes, and finally installed the latest build (3614) [originally mis-typed as 3604, sorry for the confusion] on my gig machine (Lenovo IdeaPad Yoga11S, Win 10 Ver 1903). Unfortunately, i’m finding a problem that makes it unusable - in Full Screen Mode with the Menu bar hidden, the touchscreen stops working (for instance, on the ticker bar). Works ok either in Full Screen Mode or with the Menu bar hidden, but not both at the same time.

Going back and installing earlier builds, i found that the touchscreen is working ok back in Build 3604, where the Full Screen feature was first implemented, but then something got broken starting with Build 3608. Hopefully @brad will be able to look at the changes in that build to see what happened.



Just a question. Why are you not using the the newest stable build 3614? It fixed issues with the earlier builds you are using. Works just fine here, but I am not using touchscreen either. You can always revert back if it still gives you a problem, and would confirm a possible bug.



I thought that at first too, but I think he made a typo and did install 3614 initially.


Hi @JimboKeys

Are you running with OpenGL rendering enabled? ie: Options -> General -> Enable GPU Accelerated Rendering (OpenGL)

If so try turning it off. There’s an issue here with some display drivers that I’m currently in discussion with Microsoft devs about but don’t have a fix for yet.



Good thought, @Brad — but i just checked, and Enable GPU Accelerated Rendering (OpenGL) is not enabled. Hmmm. I’m running Build 3607 now which is working fine, but Build 3608 and onward exhibit the problem.


Hi @JimboKeys

I’ve made a possible fix for this, but since I can’t repro the problem I can’t tell for sure if it will work.

Fix will be in the next build, or you could test it now as follows:

  • Reinstall build 3614,
  • Copy over the GuiKit.dll file from the attached zip file into the installation folder (C:\Program Files\Topten Software\Cantabile 3.0)

Let me know if it works.



Hi @Brad - thanks for the quick turnaround. Unfortunately, installing the new GuiKit.dll file doesn’t seem to help.

For further research, i tried reinstalling Build 3607 (which is the last version in which the touchscreen was working ok in Full Screen Mode with the Menu bar hidden). After copying the new GuiKit.dll onto Build 3607, the touchscreen was again no longer working. So it’s something in the GuiKit.dll file that’s messing things up.

And just for completeness, i tried the GuiKit.dll file from Build 3607 with the latest Cantabile build, which doesn’t even start up (not too surprising if the newest executable is trying to call a function that doesn’t exist in the old dll).


Hi @JimboKeys

Ah my mistake… I confused what you were describing with another issue. Just put up a new build 3615 that should resolve this. Let me know if not.

Sorry about that.



3615 has a major bug on my new pc, when turning back from fullscreen live modus I get this:
(the bottom bar keeps on stacking every time I push F5)

update: fixed it by disabling openGL