Implementing Full Screen Mode


#81

Hey @So_Godly

Trying to understand what might be causing this. Does this happen everytime or only occasionally? What happens if you resize the main window after it happens - do things go back to normal.

Brad


#82

I tried everything but it doesn’t get back to normal.
Everytime the controller bar adds 1 extra.
Only switching off openGL fixes it.


#83

Ah ok… so this only happens when OpenGL is enabled?

Brad


#84

Hm,
OpenGL is disabled, but today there was the problem again.
Every time I press F5 it builds up and I cannot get out unless restarting?


#85

Hrm… this is not good but I suspect I’ll need to reproduce it to be able to figure it out.

What graphics card (including GPU memory size) are you running?
What screen resolution?
How long had Cantabile been running when this happened?

Also, if this happens again, could you do this:

  1. Bring up task manager (Ctrl+Shift+Escape)
  2. Switch to the Details tab
  3. Right click on the column headers and choose “Select Columns”
  4. Turn on the column for “GDI Objects”
  5. Let me know what the GDI object count for Cantabile is when it happens.

Brad


#86

Would it help upgrading to the latest build? I’m still on 3615
I’ve found out it’s onlu when C3 is closed in Live modus.
I’ll send you the email with video


#87

Hey @So_Godly

Thanks for sending through the video - that clarified things and I can now reproduce this. I’ll get it fixed asap. I think this only happens if you start Cantabile in full screen mode but will report back when I know more.. Confirmed: this is related to starting Cantabile in full screen mode.

Have made a fix for the next build.

Brad


#88

Yeps. That’s correct