Implementing Full Screen Mode


#41

I struggle also also with this bizarre function. Why not simply uncheck in the view menu?


#42

@brad

May be just me, but since I up’d to 3603, I click normally on the setlist menu to use a selection, such as “save setlist”, and the “preload” automatically ticks on or off, as if it also responds to the menu select. By just clicking on menu, a preload starts, which I have canceled many times. It is as if the menu drop down is set too close to the menu select.

serlist%20menu

Regards

Corky


#43

Hmm, this could be the reason for one of my setlists inexplicably losing preload status…


#44

Very possibly. In the past, I would click on the menu, it would stay open, then I would make my choice. Now I have to click-and-hold to make a selection most of the time.


#45

Thanks for reporting these issues - I’ll look into it. Yep the menu is incorrectly positioned - I’ll get it fixed.

The reason for this is to provide consistent keyboard behaviour. In the case of the ticker bar, it would be weird if the slash ‘/’ key activated the ticker bar the first time, and then the second time it hid it. Since the menu serves as visibility into the available short cut keys (by showing the ‘/’ on that menu item) it needs to behave in the same manner.


#46

Build 3605 includes a couple of fixes/tweaks.

  1. Clicking on the hamburger menus now shows the menu in the correct position.

  2. In full screen mode, the menu bar now includes the current set list name, song name and state name:

Brad


#47

Thank you @brad! :grinning:

Works very well.


#48

I’m sorry i don’t get it why that would be weird. It’s a standard on off switch behavior, makes sense when you hit it multiple times. Or am i getting something wrong?


#49

The typical use pattern for the ticker bar with the keyboard is:

  1. Press ‘/’ key to activate the ticker bar
  2. Use arrow keys to navigate around and select a song or a state
  3. Press OK to select that song or state.
  4. You work with that song, probably moving focus away from the ticker bar
  5. You now want to navigate again with the ticker bar so you hit ‘/’ key again to pick another song or state

If, like you suggest, the ‘/’ key toggled the ticker bar on off, then step 5 would become:

  • You now want to navigate again with the ticker bar so you hit ‘/’ key again and… the ticker bar disappears.

#50

Ok thx Brad now I see the use of it, :slight_smile:
So it’s only related to people who navigate with the keyboard.
I always work with mouse/touchpad, so that’s why I didn’t think of this.


#51

I’m not sure where I find the menu bar when I hid it ?
I can go to full screen and get it back when hovering the top, but it’s gone in window modus?


#52

As mentioned above, in non-fullscreen mode if you hide the menu bar it’s only accessible via the keyboard. Press “Alt” to just activate the menu, or “Alt+V” to activate the view menu directly.


#53

Thx works perfect.
Just gigged with it and it’s stable.


#54

Actually there is an outstanding issue here that’s preventing me from marking this as stable.

@Neil_Durant has encountered a situation where there are selection issues in the main routing panel after loading large pre-loaded set lists via the new menu bar. I’m still not sure what the exact cause is but we’re working to isolate it.

If anyone else is encountering this issue please let me know and in the meantime you can work around it by disabling the new menu bar in Options -> Diagnostics -> Disable Custom Menu Bar.

Brad


#55

What is large?
I have some 40 songs loaded max?


#56

@brad

I attempted preloading an 81 song setlist in 3605 yesterday, and even though it was mostly emulation vsts, it took approx 7 minutes to reach near the end, where it crashed with a jbridge error, although I am not aware of anything being jbridged.

Other things I am seeing, is quick scan hanging up. To get it to move on, I have to click anywhere to wake it up. Also, had full screen freeze, and somehow became transparent, as when I clicked on anything in C3, it would start icons on main screen behind C3. Very strange. I had to use task mgr to get out of the freeze up.

I plan to go back today and test to see if I have a rogue vst problem, or just a computer problem. The quick scan freeze started in 3603. I will be sending logs of today’s potential errors, if any, and will be testing my backup laptop as well. I did not preload any setlists in my last 4 gigs this past week, and everything ran smoothly in 3603.

Regards

Corky

So far in today’s testing…

Preloaded 35 song setlist and it took 4 min 55 sec to load.

Ran quick scan and it took 2 min 21 sec to start the scan.

Verified setlist with no problems.

Found a vst authorization problem near the end of my 81 song setlist and fixed it.

Full screen is selected. Preloaded 80 song setlist, two jbridge notifications appeared. I think I now know where they are coming from after reading log. Preload stalled 19 min in at 114 plugins of 119. Cancelled preload…blue circle of death. Task mgr “implementing full screen” wouldn’t close, and had to stop it. Re-started C3, pulled up setlist, ran setlist verify. To get to the verify page, I clicked the restore down box (upper right corner) to reduce C3, instant freeze. This where I was yesterday. C3 was unresponsive, and anything I tried to select on C3 was being selected behind reduced C3 window.

@brad
I am sending you the last 3 logs.

Sorry, only the last one was available.


#57

In my case it was only about 20 songs, but they’re big ones, totalling about 130 plugin instances. It seems to be worse when loading lots of plugins in a pre-loaded setlist, whereas if I load a small setlist of only a couple of songs, the bug happens a lot less frequently. The bug I’m seeing is that when you try to select something in the normal routing view, the selection just flashes, so you can’t select it.

It would be useful if someone else was seeing anything similar, as it could help us track it down.

Neil


#58

You can find out which one via the log file. Tools -> Open Settings Folder -> log.txt (or perhaps log-previous.txt if you’ve restarted since the crash) and look for jBridge.

Interesting. Can you try disabling the custom menu bar and see if these problems go away. Tools -> Options -> Diagnostics -> Disable Custom Menu Bar.

Also, if you’re really keen, I’ve got three patched builds of GuiKit to help try and diagnose this issue. Some of these will have degraded menu bar interactivity because I’ve disabled parts of the code to try and isolate the problem.

If you can reproduce this issue reliably with the custom menu bar enabled then I’d be very keen to hear which, if any of these GuiKit builds fix the problem. Just extract the GuiKit.dll file from the zip file and replace the one in Cantabile’s installation folder (typically C:\Program Files\Topten Software\Cantabile 3.0). You can rename or back up the original dll file or you can just re-run the latest installer to get back to latest official release.

Also, if anyone can reduce this to a simple reproducible scenario please let me know - I’d really like to be able to reproduce it myself so I can get it fixed without having to waste other people’s time.




#59

Will give it a try. Thanks Brad. :grinning:


#60

Hi @Corky

Definitely try disabling the custom menu bar and let me know how that goes. Since posting the GuiKit links above, Neil has gotten back to me saying the problem he’s seeing still happens with those builds so probably not worth trying them (unless you’ve got nothing better to do :slight_smile:)

I’m at the point now where I really need to figure out how to reproduce this here. If anyone can help in that regard, please let me know because try as I might, I can’t make it happen here.

Brad