Disappearing bindings and more [RESOLVED]

I have been a happy, impressed and excited user of Cantabile but have started to run into problems.

I have been a fairly lightweight user so far, but am embracing more and more of what it can do, but recently I keep am finding that the bindings suddenly don’t work - sometimes this has happened live and i end up fumbling in the dark changing states with my mouse. The only way round it is to delete all the bindings and re enter them, but even so at the next performance some of songs have lot the bindings again. I mainly play in a worship band, and as such I use a new set list every week.

In addition, today I also found that for some reason the various states are going haywire, with external voices and plug-ins from other songs suddenly appearing in whatever song I am trying to play. Thankfully this was as I was preparing for tomorrows event, but my concern is that I’ll end up with who knows what appearing in my set list, especially as there will be alive stream happening, and a solo performance which is very important. I do not want to let the singer down.

So far my budget doesn’t stretch to the £300 - £400 need for a MDI foot controller, so I assign the top four notes of the keyboard as I never use them in worship music. I set them up using the “learn” function, double clicking on the option of the note I have pressed in the drop down box, and then click on “Set List” then “Next State/Song” as appropriate. This has worked well for several months.

It may be pointless, but I have redone all the bindings by clicking on the note to be assigned and then clicking on “OK” instead of simply double-clicking on the drop down option. I am probably clutching at straws, but am baffled as to what is causing the disappearing bindings. Similarly, I don’t know what is causing the song settings to be randomly mixed up.

So any suggestions would be greatly appreciated.

Oh. I think we’ll need a little more information, ie what version are you on, and can you provide some screenshots of your bindings and your state settings (normally lower left window in the editor)? And are the bindings completely gone, or are they disabled?

Thanks for responding. I am using version 3.0 build 3694. The occurrences have been somewhat random, in that sometimes the bindings work, but aren’t displayed on the bindings page, although more often they are displayed but simply don’t work. This was the case on Saturday as I was preparing and practicing for the Sunday set. So I methodically went through each song, deleted all the bindings except for the “engine” binding for “all notes off”, and then set them all up again.

I am running an i5 1.0GHz processor with 8Gb of Ram, and wondered if I was running to it’s capacity, as I had a lot of VSTs pre-loaded in the set list of 6 songs. So I deleted 4 of the songs from the set list, leaving the two which ran together in the set. The other 4 could be loaded individually as required. This would then reduce the VST load on RAM.

On Sunday, everything worked, except for one song, which I was running on its own, where the bindings displayed, but didn’t respond - a shame, as this was the feature song, on which everything else was dependent! So I had to resort to grappling around with a mouse to change from state to state, whilst supposedly playing two-handed!

The song in question is the one in the screen shots. I hope this helps!!

Routing page upper|690x389

It looks like one of the screen shots didn’t quite make it, so here is take 2!

Hi David,

It would be good to know what keyboard controller you’re using as well. I notice you use different MIDI channels for some of the bindings. Does your controller always sends notes OMNI MIDI channels? Also have you tried locking the states that are working so no other editing might change them? Just trying to get an idea of what all is in play.


The screenshots appears rather blurry on my screen, is it only my setup, or do others also have difficulties reading them?

And a question regarding the setup: what are you pressing to activate the bindings? It seems to be that you have used notes as the ‘trigger’ for a binding, instead of a Controller, is that intentionally?

Hi Dave

I am using my Yamaha MX61 as keyboard controller. I used it exclusively at the start, but wasn’t impressed with its choir sound and bought the Olympus choir vst, followed shortly after by Spitfire Audio’s BBC Symphony Orchestra Discover. It was Derek who introduced me to Cantabile and I am really grateful for that! I now use a combination of the sounds on the MX61 and a selection of vsts, so the use of different MIDI channels is to be able to differentiate between the keyboard voices and the vsts on my laptop. The vsts work fine if I leave the control column on OMNI, but specify the MIDI channels because the vst hots such as Halion SE and UVI workstation require me to choose a channel for the sound that I want to use, which then has to match up with the MIDI channel in Cantbile, so that I can run more than one sound from any particular host.

I may well not have to do this, and simply run in OMNI mode all the time, but I can foresee a time when I will need to be MIDI channel specific, and felt that it would be a good discipline to practice this from the start. You will no doubt deduce from that comment that I am fairly new to MIDI. In fact I am fairly new to music tech altogether, as I spent nearly 30 years away from it all due to RSI!

I was eagerly heading towards recording work on my DAW, where I believe MIDI channels may well be important, but then playing live took precedence, and learning Cantabile took me away from working on the DAW - for now!

I haven’t tried locking the states once set up because I simply didn’t know about doing that until only a couple of days ago - as I said I am at the beginning of the learning curve.

I hope this helps.

Hi Torsten

Sorry about the screenshots being a little blurry - it is not apparent on my laptop. I resized the pictures to make them a little larger before saving them and uploading them, so that may be the reason.

You asked “what are you pressing to activate the bindings?” - I presume you mean what an I assigning to each binding to trigger it? Although it does look as though you already know that I am using notes as the trigger. This is because a MIDI controller pedal, such as the Roland FC300 are outside my budget. And because of the type of music I am playing, I tend not to use the top octave or so on the keyboard, so apart from giving a momentary sound, they are not ideal but do the job for now! Maybe Father Christmas can come to the rescue!

IN case what you wanted was how I actually set the bindings, I do the following: I click on “Add binding”, “learn”, then press the appropriate key, then choose either “Set List” or “Song States” from the drop down list, then click on “Next/Previous State/Song”. As I said to Dave Dore, I didn’t know about locking the bindings until a couple of days ago , because I am relatively early on in the learning curve for Cantabile.

I hope this is helpful.

Hi David,

Thanks for the pictures of your rig routing and bindings. The first thing I would like to say is that I can only address the problem of a note binding not working when you press the key. For bindings that are disappearing altogether I have only seen that happen when I thought I had saved the song with a Ctrl+S but saved a rack or setlist instead and when I wnet back to load the song the changes weren’t there. On the bindings picture you posted the MIDI channels are different. I would set these all to Omni. The MX61’s performance parts are set to different MIDI channels and that might be why the bindings quit responding on some songs. All depends on what the MIDI transmit channel the MX61 is set to.

Also select each binding and check that there are no checked boxes it the states behaviors pane for it. Checked boxes can cause surprises on a state switch as well.

Another helping hand might be to move your bindings group to the background rack and avoid having to edit all your songs. You would only need to edit the group in the background racks. You could disable or delete that group of bindings from each song and save a lot of editing.

Hope this helps,


Re “Bindings disappearing altogether”: this has only happened on a few occasions. Normally the problem is that the bindings are sat there on the screen, but not doing anything!

Re MIDI channels: I have set these in order to differentiate beteen the various sounds and vsts I want to play at any one time. I have been led this way in part by the architecture of the MX61 keyboard. It is a budget ROM player, aimed at live use. To recap, a Performance has 16 voices or sounds which are allocated to MIDI channels 1 - 16, so sending the channel to OMNI makes the keyboard respond to it’s basic channel (channel 1) on the MIDI page of the keyboard. I set all the channels on one particular song to “SAME” ie same as the input channel, nad all the sounds actually triggered voice number 1.

Similarly, the vst players I have (Halion SE and UVI Workstation) have 16 slots in which to allocate sounds, and each of these slots is set to the appropriate MIDI channel. Once again, this is to differentiate between the different sounds in the player. SO that is what the Routing page is showing.

I while ago I tried to put the bindings on to the Background Rack, but it didn’t work - there were no changes occurring when I pressed any of the assigned keys. It was, as you suggest, to cut down on the amount of programming for each song.

When I opened my current set list to prepare for this reply, the bindings were all there, but the “Previous Song” one didn’t work. When I looked on the Background Rack, that particular binding didn’t exist, and as soon as I created it, my set list began to function correctly. Quite why the bindings on the Background Rack didn’t work when I first created them, but are working now is a mystery. I am guessing that there is some sort of interaction between the bindings on the Background Rack and the individual songs (although the songs I tried the Background Rack bindings with didn’t have bindings of their own at the time).

So things appear to be working at the moment, although I will now have to embark on a de-programming exercise for all the individual songs. This will have to be later, as I am about to go out to tonight’s practice. So that is going to be the moment of truth! I will report back in due course!

So many thanks to the two of you for your help so far. It is appreciated!

1 Like

Hi David,

I’m glad it’s working for you but must reiterate that the bindings you show would not work if the MX61 performance set had parts that were not among the MIDI channels you are using in the bindings and that having all the bindings channels set to Omni would be the way to stop the problems. None of the targets of the bindings are channel specific. Just the bindings set to omni, the MIDI channel routing to the VSTis is fine.



Thanks Dave! I don’t know if you remember Monty Python, or are even old enough to remember them, but this is starting to sound like one of their sketches, said Dave to Dave!

I was rather confused about MIDI channels with respect to bindings because the MIDI info is in a different place to where it is o n the routing page, and I simply hadn’t noticed it! Now although I had a temporary fix last night, the usual problems arose at the practice. So tonight I made a dummy set list, then deleted all the “in song” bindings, relying only on those in the Background Rack, and everything works! So it would seem that initially everything would work, but then having two sets of binding instructions eventually led to conflicts. Hopefully now the problem has been sorted. All I require now is that when I put together a set list using existing songs, I will have to de-programme the bindings, and all should be well!

My only other problem is why, when I first set the bindings on the Background Rack all that time ago nothing actually worked, but now, without changing anything, everything works as it should!

Once again, many thanks for your interest and responses.

Oh, and Happy Christmas!

1 Like

Glad to hear that it works well now! Be aware that the bindings in the background rack has the lowest priority (see details here), so if you have had any leftover bindings in the song or in any rack they will have overruled the background rack, and thus making them appear to ‘not working’. If you want to test background rack bindings, then you will have to start out with a new song with no racks in it, then you should be good to trust that the bindings in the background rack will be active and ‘reachable’.

Thanks for yet another quick response. And as is well that seems well … well it was, but is not anymore!

I had a set list in existence, but created a new one, and for each song added, I went through and deleted all the in-song bindings. And everything worked. I close everything down, and then went and switched it all back on, and the set list worked perfectly.

Coming back to it today, I created a completely new song and added it to the existing set list, intending to use the Background Rack bindings, which worked so well last night. But now, nothing, for the entire set list.

All the bindings are there in the background rack, but now nothings happens, following the pattern i had when using in-song bindings. It is almost as if the song doesn’t know where to look for the binding, or the binding commands don’t know how to find the current song. I have evidently missed something while setting the Background Rack up, but don’t know where to go from here. I can’t find anything in the guides to give more detail on setting up Background Rack bindings so that they work whenever I add a song or create a new set list.

I am due to play tomorrow morning, so either I find out how to get things working, or I will have to delete the Background Rack bindings, and re-programme them back into all the songs I have deleted them from! Or try and play, while shifting states using the mouse!

Now what do I do?

Just to make sure, is the audio engine running? That is a prerequisite for anything to happen.

Do you mean the Audio interface, as in my Steinberg ASIO Audio Interface? If so, then yes. Because I use Cantabile every time I play, my keyboard MIDI is set to “Local Control Off”, so the only way to hear sounds from the keyboard, as opposed to VST sounds, is with the interface running.

So I looked through the tabs and found the “Run Audio Engine” and clicked it, and it flagged up a warning about the interface. So I reconnected to the keyboards and got the Audio interface back up and running, and noticed that the “Run Audio Engine” tab now had a “tick” against it, so of we go, and everything is back working OK again.

I am constantly trying new aspects of Cantabile, even though I am barely scratching the surface, yet there is so much to learn! I hadn’t really considered the Audio Engine or what it does - I presume it is pretty central to Cantabile, but it seems ok once more, although I have been here before!

Lets hope tomorrow’s Christmas event goes smoothly!

Have a great Christmas, Torsten!

1 Like

Great to hear! Glad it works now - good luck tomorrow, I feel confident that Cantabile will be on your side. And yes, there are many quirks to learn.

1 Like

So having put all my bindings onto the background rack, everything has worked really well, and so far all the hiccups I was experiencing have gone.

However I created my first two linked racks, and have included one in my next set list. The bindings all work with all the songs in the set list, apart from the song for which I use the linked rack, where the state bindings do not work.

Thankfully the transition between verses, chorus and bridge a slow so I can change state with the mouse for that one song.

What do I need to do to make the linked rack work to all the bindings?

I am not sure what could be the issue, but one thing spring to mind, be aware that there is a specific order for bindings, see Song, Rack and Background Rack Bindings.

If you don’t think this is the cause of the problem, try to make a new song with the linked rack in it to see if the problem persists, and/or also make a copy of the song and remove the linked rack - the idea is to find out if the problem is caused by settings in the linked rack or in the song.