Cpu usage fluctuating wildly

Hi, on my gig last night I experienced a couple of drop outs (and a couple of strange momentary fades without dropping out altogether) and a few small clicks. I noticed that the CPU percentage was fluctuating from around 34-40% all the way to 170+% at times. The setup yesterday was Ivory Grands (x3), Scarbee EP88, Scarbee Pianet, Lounge Lizard 3 and 4, and the Sonalksis FreeG. I tried reducing the Ivory Grands to one but the heavy fluctuation continued. I use a Steinberg UR22 as the interface (buffer was set to 512).

Any ideas that can help me?

Is this a new behavior? Have you installed anything recently that might be running a background process that is hogging resources? I’d start there…

I have had this happen once before (at the same venue strangely enough) with the difference that it dropped out very dramatically (twice). It’s never happened when I use my organ setup (HX3 separate module with Hammond XK3 as controller) with umpteen plugins for other sounds running in Cantabile.

I’m using a Surface Pro 4 (8 gigs memory). I haven’t recently installed anything none-vst/Kontakt related but I’ll now try and replicate it at home and see if anything is running in the background. I’m wondering if Ivory Grands might be the culprit though I really need that when I do piano stuff.

Any further ideas gratefully received and I’ll report back if I can discover something myself in the meantime.

Is it a windows 10 machine with update turned on? That can cause it and there has been a big update recently that stole resources from me on my desktop. @FredProgGH is right on it though, it sounds like an update on something new caused the problems. If this is not the case it could also be hardware, cables …etc. I’ve even tracked latency problems down to video card settings. You can sometimes use Latency Monitor to track down the offender.



1 Like

Complete drop-outs doesn’t sound like Cantabile, though. Usually CPU overages just sound like CRAP!

I get drop-outs from my Motu boxes (Ultralite and 828 mk3 hybrids) if there is a brownout, just as a data point.

But the CPU usage fluctuating wildly is a sign of something further going on, for sure! LatencyMon to the rescue!


I’ve found the resonance settings in Ivory can really increase Cantabile’s load meter significantly. Do you have that enabled, and if so, do you need it?


I’ve been trying different things and watched the cpu/pf usage at the top of Cantabile. Ivory is interesting as I use three instances, one of which shows a cpu reading of around 35-40%, the other two around 60-70%. The problem is I can’t figure out why! It’s not the resonance after all, as that is ‘on’ in the low cpu usage piano but ‘off’ in the others. So, still a mystery there. Lounge Lizard 4 and the EP88 constantly show around 70-80%. If I make a new song with only one vst the cpu usage is around 30-40% but I suppose that’s to be expected?

The big spikes, however, seem to happen when the Sonalksis FreeG fader is on screen - then the reading jumps often to 170% or more. Of course, in the live performance I had it on screen for easy(ish) changes to volume. I’ll try deleting this and see if it does solve the drop-outs etc…

I also turned off wifi and any sleep configurations but this hasn’t affected the cpu readings.

Any other thoughts out there? Meanwhile I’ll keeping experimenting and see what happens.


Hit ctl, alt, delete and see what is running in the background. Do you have a virus protector running? Make sure no scheduled utilities are running.


I too have noticed an increase in the Cantabile CPU load indicator when running Ivory. Months ago, using Build 3236, Ivory wouldn’t cause Cantabile load meter to go above 21%. Now it’s spiking at times to 50%. I’m running Windows 10 with all the latest security patches and have the OS ‘tuned’ per multiple guides out on the internet, to include Brad’s glitch free guide. By trade I am a computer systems engineer so I love digging into the weeds with a system to make it a lean mean computing machine. I am running the latest Cantabile 3 build 3247. I’ve used LatencyMon frequently to try and diagnose what might be causing the issue. So far I’m stumped. I’ve tried changing parameters within Cantabile to no avail. I’m running the latest build of Windows 10 with all current security patches.
Cantabile 3 Build 3247
2.8 GHz Intel i7-4810MQ (4 cores, 8 threads, 6MB cache)
32GB hyper-x RAM
512GB mSATA SSD for OS
(2) 1TB mSATA SSD’s in RAID 0 for sample libraries
MOTU UltraLite-mk3 Hybrid audio interface with latest ASIO drivers
I’m running 192 sample rate at 4 ms latency
48kHz 24-bit audio

So you have hyper threading enabled? You should disable that.

Also I’d try to set the samplerate to 44.1. Just for testing and see if it changes something.

Also I’d double check with the internal sound card and the ASIO4All driver.

I personally use the MOTU micro book and its driver is shit!!! You can’t push it to a playable latency without dropouts. So I use the ASIO4All driver with this interface. Works like a charm.

Task Manager shows Cantabile using around 12% and around 5GB memory is in use generally (total is 8GB, Surface Pro 4, latest updates, Cantabile 3245). Any other background processes are tiny 0.2%, 1.2% etc., or zero. FreeG definitely seemed to create spikes when on-screen but is 70-80% cpu usage - as shown in the Cantabile window - too high anyway?

I’m using a Steinberg UR44 with its own driver. I’ll try ASIO4ALL and see if it changes things.

FantomXR -

I believe I have hyperthreading enabled. I will check the BIOS tonight to confirm.

I’ve always utilized my system at 48kHz because I can hear an audible difference between 44.1 and 48kHz. Much cleaner audio. I do notice a slight increase in CPU load at this rate.

I’ve never tried the ASIO4All driver, I’ve only ever used the ASIO driver that came with the Motu Ultralite-mk3.

Those were just a few hints for things you could test / check. I don’t say that those settings will solve your problem. But maybe it helps to identify the problem.

Thanks for the suggestions. I will try out different settings and drivers to see if I can improve the performance.

Hi, Not sure if it is relevant, but last week I was going to do some Guitar recording on my WIN10 music computer in Cubase (not Cantabile) via my Helix Guitar pedal as the audio I/F (very low latency, which has worked fine before for this purpose) and I gave up after two nights. It was so glitchy. Task Manager (allegedly) showed nothing untoward. On the third night when I shut down, there was an update to apply. It was fine after that. Coincidence, or a ghost in the machine?

The sooner I get onto WIN10 pro where I can hopefully control the updates again, the better!

Could find anything in the BIOS about hyperthreading. Very odd. I ran a WMIC command which shows that hyperthreading is enabled on the system, 4 cores and 8 logical processors. Within Cantabile I set the number of audio threads to 4, not 8, and set the multiprocessor mode to compatible.

I installed ASIO4All and got that configured within Cantabile. Amazing difference with the load meter! Much lower and not spiking anymore.

Yes… it’s kind of weird that the ASIO4All driver seems to work much faster and more reliable than the MOTU driver…
So your problem is gone?

The problem is gone! So far the Cantabile load meter shows about the same percentage as it was last year using a certain set of plugins.

1 Like

So, it is gone as a result of using ASIO4ALL rather than the MOTU ASIO? That is very curious! ASIO4ALL is really WDM/KS being made to masquerade as ASIO.

The MOTU WDM/KS drivers are really awful, and I solved a bunch of problems merely by disabling them in the device manager (MOTU Audio WAVE drivers, not the others, which are the ASIO ones). Perhaps that is the culprit? I will do some tests myself with some of my heavier synths (Linplug Spectral, for instance).

To use my MOTU boxes as system audio, I use Voicemeeter Pro ASIO to interface to the MOTU ASIO now, which does sample-rate-conversion internally.

The MOTU Audio Wave drivers force the internal hardware to switch sample rates when it encounters a change, which it does very messily.


1 Like