Cherry Audio VST interface draw glitches/weird behavior

Tags: #<Tag:0x00007f977d19dd38>

I’m currently on the trial of Cantabile Performer, loving it. However I’ve found this weird issue with all Cherry Audio VSTs,

  • the ui scales around like mad when you drag a window.
  • If you close a window the vst UI halves or doubles
  • general chaos.

I’ve recorded a video to capture this behavior.
https://youtu.be/gdIUaA0gWbI

I’m on windows10 and using 2 benq 4k monitors.

I’ll also send this to cherry audio

Cheers
MB

I have the same issues you describe with lowdown bass pedals vst.
on win7, for me on my tiny screen (by comparison)
The part where it scales down after the window is closed could be that
the vst is scaling to fit the screen vertically when its reopened, which it does (for your screens, probably it’s native size). I can scale it up to 150% then when I reopen it, it’s back to just under 90%.

I’m having a similar issue with SurgeXT VST and have been meaning to document it and post to this forum. I suspect it can be fixed by one of the Cantabile GUI settings, but I don’t know which ones.

Welcome to Cantabile forums Matt.

Looks like you may have discovered a bug in Cantabile. I don’t have the Cherry Audio vst, but I get a similar scaling problem with Surge or SurgeXT, like dbrendon says. This weird scaling behavior only happens for me in Cantabile C4. If I open Surge in version C3, the plugin scales properly.

I tried disabling “Plugin GUI Up-scaling”, but made no difference. I also tried disabling “Hi DPI User Interface” and unchecking GPU Accelerated Rendering (OpenGPL)" in settings, but made no difference. Hoping @Brad can look at your video.

1 Like

I get this problem with Cherry Audio too. Only in C4 though.

1 Like

Yes, there’s some issues here… mostly caused by plugins using incorrect API methods calls to determine the current window scaling resolution.

Usually though those problems go away with HiDPI mode disabled. I’d need to look into that if that happens.

Brad

I just tried C3 just know, (out of curiosity) I have the zooming issue shown in the video
however it is only when I zoom in. when i click and drag to zoom out
there is no issue.