Cantabile Disables audio coming from other apps


#1

Hey Folks,

Don’t know if this has been asked before, but when I run Cantabile and it works fine, I can’t hear any audio coming from other apps like chrome or Spotify. I need Chrome in order to watch tutorials for certain plugins and switch back and forth between the two apps. I know I can do this if I disable the audio engine in Cantabile, but it’s slow to reactivate. Am I missing something? Thanks for the help!

Cheers


#2

I don’t think this is something Cantabile is doing. It’s probably some setting in your computer/soundcard. Have you checked the audio settings in Cantabile? Others in this forum may be able to help you more.


#3

What type of soundcard do you use?


#4

This is because Cantabile captures the audio driver exclusively. This is the case for most WASAPI and ASIO drivers. There are some multi-client drivers (multiple applications can use the same audio device), but that’s not guaranteed.

If your audio drivers are not multi-client capable (as it appears), you can use a workaround: Install VoiceMeeter on your system and set Cantabile to use VoiceMeeter Virtual ASIO driver. Also, you’ll need to set your Windows sound device to VoiceMeeter Input.

Now set VoiceMeeter Hardware Out to your audio device.

VoiceMeeter will now mix all your Windows sound (including youtube) and your Cantabile output and send it to your audio device.

The only downside: you’ll need to have VoiceMeeter running all the time, otherwise your Windows sounds will be mute… But you can set VoiceMeeter to run on startup and sit in the System tray, so no biggie.

Cheers,

Torsten


#5

@Torsten, could I use VoiceMeeter to run Cantabile and my DAW next to one another? In principle, I don’t have Amer’s problem with my Focusrite 18i1 and I can run normal Windows apps next to Cantabile without a problem. But I cannot run Cakewalk or Studio One at the same time as Cantabile. Does VoiceMeeter add any latency (in other words: can I use it on my gig laptop)?


#6

I would suspect it does, but I’m not sure. @terrybritton is our local Voicemeeter guru - Terry, can you help here?

Cheers,

Torsten


#7

Voicemeeter, in Virtual ASIO mode, is very fast. The latency is pretty slight, but you would notice it if trying to monitor your input while wearing headphones. I recommend turning off the A buttons (the monitors) on inputs like vocal or drum mics after you’ve established your levels. (You can hear both PLENTY well enough without headphones on!)

Voicemeeter Banana offers three hardware inputs, while the newer “Potato” offers five.
https://www.vb-audio.com/Voicemeeter/potato.htm

If you use as the A1 monitor your ASIO audio interface, then the latency is controlled by the buffer size of that interface. If using it as WDM, you set the buffer in Voicemeeter. 512 works fine for me for all applications.

Terry


#8

Hey everyone, thanks for all the help with this! Voicemeter ended up doing the trick! I was using the Realtek soundcard that came with the computer, but I got a Focusrite Scarlet 2i2 now now, and that solved the problem as well right out of the box.

The new issue occuring now is that I can’t hear anything unless I switch it to direct monitoring when I have my guitar plugged in; I should mention that I’m also using the headphone output of it, and it works fine for direct monitoring and I can hear the dry signal. But when I switch that off so I can hear the VST plugins I’m using, nothing comes out, although the indicator shows that it’s receiving input. Any ideas folks?

Thanks again everyone!

Cheers


#9

Maybe it’s just in the nature of things that a 2 channel interface does not manage 36 channels. sar.audio could help but actually the better solution would be an audio interface that manages more channels and works with a multiclient driver.

http://sar.audio/manual.html


#10

What is it you want to hear exactly? Your post is a bit unclear: Is it your guitar (processed through Cantabile) that you want to hear through your audio interface? Or does your audio interface stop output of other VST instruments when you plug in your guitar?

If it is the first, then check the audio path through Cantabile: if the interface is receiving a signal, then how does it then flow through Cantabile? Check the Cantabile level meters throughout your song file; also check the Monitor panel on the left side for the individual levels.

Once you are sure that Cantabile has a valid signal at its output, check that the audio interface settings are correct in Cantabile (output ports correctly assigned to your Focusrite output channels).

I don’t think that the 2i2 has a mixer app, unlike the bigger Scarlet interfaces - that would be another thing to check…

Cheers,

Torsten


#11

@Juergen Thanks man, I’ll give SAR a shot when I get a chance!

@Torsten

Exactly this! Things worked perfectly with your tips, after changing the Preset/Destination column to be the plugin, the signal went through processed by the plugin. Thanks a bunch for your help man, things are working great now, just need to mess around and find a good tone now. :slight_smile:


#12

Check out this thread from a year ago. Following Brad’s instructions, I’ve been able to run Mixcraft and Cantabile simultaneously Using midi controller in Cantabile and DAW simultaneously