Cantabile 4 Beta

Cantabile 4 is now stable enough that I’m labelling “beta” and I’ve made it available from the regular download page.

Of course, if you find issues, please post them here or email me.

12 Likes

Congrats on going to beta!

3 Likes

Hey @brad,
Why the stable v3 is the 3694? Wasn’t 3702 the latest?

Hi @cpaolo, thanks for reporting. Well spotted. Fixed.

Scotsman in the room: “I kinneh break it!”
Me: Neither can I.

Terry

3 Likes

Nice work Brad. I downloaded and tried it last evening. It came up using my default song file from C3, and everything worked from the get-go! No changes required!!!

2 Likes

Hi!
Didn’t find if this already mentioned but some VST3 plugins are not detected
(fabfilter VST3 plugins for instance)
They are working great with C.3

regards, Alexander

Hi Alexander,

Are you sure about this, they seem to be detected just fine here:

Can you send me a debug log?

  1. Start Cantabile
  2. Make sure your plugin path is set as intended. (Tools -> Options -> Plugin Options)
  3. From the Tools menu, choose the “Scan Plugin Folders (Full)” command and wait for it to finish.
  4. From the Tools menu, choose Open Settings Folder
  5. Close Cantabile

From the folder opened in step 4, send me the files, log.txt, log-previous.txt, settings.json and plugins.json along with a note on where the plugin is installed and I’ll check it out.

@brad just saw your reply, sorry for that. Just created a new thread…
replied there

regards

Hi @Alexander

I had a look at the log… it looks like you’re running the 32-bit version of Cantabile but trying to load 64-bit plugins.

Brad

2 Likes

You were right. My bad!
:face_with_head_bandage:

regards

Hi @brad,

After 4044 install, Cantabile does not start. Not even the PromptPlatformDialog selection. Nothing on task manager, no log generated. Rolled back to 4042.

Paolo

Hi @cpaolo,

Yep, I’m getting a number of reports of this today, but I haven’t been able to reproduce the problem here. I’ve taken down builds 4043 and 4044 until I figure it out.

Would you emailing me a copy of your background rack and your settings.json file?

Brad

Hi @cpaolo,

I think I’ve resolved this issue. Please download build 4045 and let me know if the problem continues.

Thanks again for reporting this.

Brad

Thanks, Brad. I already sent the files you asked for. A bit of overlapping… no matters

OK thanks. Hopefully I won’t need them and 4045 will put things back on track.

2 Likes

4045 fixed it here!

1 Like

Phew… crisis averted. That’ll teach me to do not midnight builds just before going to bed. :frowning:

5 Likes

4045 is working well. Thanks again.

2 Likes