Cantabile 4 Alpha Available

@brad, I think I may have found a bug in 4026. I am unable to [Add] an External tool. All buttons are greyed out. Can anyone else confirm?

Works fine for me. Have you tried entering text in the fields?!?

Yes. All fields are disabled. It works fine for me with C3.
Now, I just tried External Tools on my desktop machine and I have the same issue with C4, but it also works fine for C3.

Thanks for reporting. It’s a bug when there’s nothing in the list. Fixed for the next build.

Hi @brad,

Found a possible bug in v4 while working with @dave_dore’s new B-3X Factory rack. When clicking Custom Button 2 to create a new state the GUI Editor takes the foreground in v4027 but doing the same in v3701 the GUI Editor is placed in the background.

Hi Al,

This isn’t a bug, the timing of the display items when opening many things at the same time is not always the same. It is a part of the way tasks are done in C3. I am going to see if I can improve this using the new delays features Brad just released. I’ll let you know if I can improve this part after I get the hang of using the new feature, I’m sure I can, the flexibilty and precision is definitely there I just need to get familiar with it. But it will be for Cantabile 4 only.



1 Like

I found a reliable and reproducible way to crash Cantabile 4 on my system. So far I’ve only noticed this for a specific song. I will try to reproduce this with a new song.

The Song has a few linked states (like Verse 1, Chorus 1, Verse 2, Chorus 2,…). When I switch between states normally, it works just fine. However, when I switch to live mode (which also switches the view to note view) and load the next state (i.e. Chorus 1) via a MIDI binding, Cantabile crashes. I tried remove all racks and plugins successively and the error persists even if the song consists only of those linked song states (no racks, plugins, bindings, notes).

I’ve looked through the log files and the exception causing all of these crashes is this one:

00030419     3244   [13344:2]: State loading 'Chorus 1' for '012 Cry for You test'
00030419        0   [13344:2]:   Starting route operation: loading state
00030420        1   [13344:2]:     Nested route operation: enabling route
00030480       60   [13344:2]:   Finished committing re-route: +10=86, 60ms
00030493       13 ! [13344:0]:   Exception
System.NullReferenceException: Object reference not set to an instance of an object.
   at #=z_eiTETclZPdN8kJrfv$_YkY=.#=z_3MVLrY=.#=zzqarF8LKzkEO(Boolean #=zpWVXrbdJvryl)
   at #=z_eiTETclZPdN8kJrfv$_YkY=.#=zypRNpOHUQG$E()
   at #=z_eiTETclZPdN8kJrfv$_YkY=.#=zhcvEUuwrwMNy(#=z3vUjCF9At6cxpv1WDME8fF_EZIRy #=zCRjUXdg=)
   at #=z3DsZ$6mc6sg5HEWbB6cFJ94QHoI9sko$Dw==.#=zTUXYunV71qw9(#=z3vUjCF9At6cxpv1WDME8fF_EZIRy #=zcMP2zHY=, #=zxTlFO3wNt6uckfIcAY$$otUBMjPTyBLK8A== #=zpxevcK0=)
   at #=z3DsZ$6mc6sg5HEWbB6cFJ94QHoI9sko$Dw==.#=z1uDihjv44VhRDz47vRKpv3Y=.#=zXWoV6h$SjeJW2LbX0w==()
   at #=zvvrZhv$mUDhTaYcmBKJy83I=.#=zSg_VIOrbneAmdLjMDfKq$gI=.#=zyAOIqojeQT4R$xBSHIiZ0sI=()
   at #=zw0r96JkvhWgpZcu4Jn$lAp7DOdNJw00jJw==.#=zUbGSh0kVKTPg()
   at #=zrUVWfdzVkeJxA6KE5gRiBM4=.#=zJzAO2xWPi9_VwvNrbw==.#=z7vZ2h4AjjuFDj5CPXA==()
   at Topten.GuiKit.PostedCallback.<>c.<.cctor>b__2_0(Timer t)
   at Topten.GuiKit.Timer.on_TimerTick()
00030493        0 ! [13344:0]:   Launching crash reporter...

At this point I really hope this is a bug and not faulty memory as the stack trace looks really wild.

EDIT 1: Just tried building an empty song. It really seems to be somehow connected to linked states. When I create the same song states as above, switch to live mode, switch to the next song state, it crashes. If the song states are not linked, it seems to work fine. However, if I then create a new linked clone, it crashes immediately.

EDIT 2: When I unlink the states in that first song, it seems to work as well.

EDIT 3: I did some more testing to rule out that notes view or the MIDI binding are causing the problem. I can crash C4 consistently as long as I’m in live mode and switch to a linked state.

Hi @Thijon,

Thanks for reporting this. This is the one bug that’s stopping V4 from going to beta and I’ve been chasing it for a few weeks now but never been able to reproduce it. If you can repro it, I could really use your help to get it sorted.

Would you mind sending me an email with a copy of the song, any linked racks, your background rack and a copy of your settings file. (available via Tools -> Open Settings Folder… settings.json is file I need).


1 Like

I sent you the files. All you need to do to reproduce the crash is:

  1. Open the song
  2. Enable live mode
  3. Switch to song state 2 (which is linked to “2 Linked”). You don’t need to use the binding in my background rack. Just clicking the state in the ticker bar suffices.

I suspect that the background rack is not actually involved. It might be a good idea to try the song on its own first. I.e. with default settings and no background rack.

Hi @Brad, I might have noticed an issue with V4 (I am on latest build 4028).

When I convert a Linked Rack to an Embedded Rack, I lose all the bindings from the Linked Rack. The Embedded Rack will have none. Is that intentional behaviour, a bug, or have I missed a setting on this?

I came across this with an Superwave Equinoxe Rack, but found it as well with an Omnisphere Rack, so I assume it is a generic issue


Hi @adderoo,

Thanks for reporting. This has actually been a bug since v3. Fixed for next v4 build.


Build 4029 is now available and fixes a long standing critical bug in GuiKit’s virtual list implementation. (thanks @Thijon for the help). It also fixes the lost bindings mentioned by @adderoo above.

Assuming nothing else crops up, I think this is ready to move to beta (finally).



Hi @Brad, thanks for the update. I confirm the lost bindings issue while converting to embedded rack is solved indeed with 4029.

Glad I could help!

I think there may be a problem with build 4029. When I open my primary setlist, I now get the following error.


When I click OK, Cantabile crashes without giving me an opportunity to send a crash report.

When I reinstall 4028, the setlist loads properly.

There is definitely an issue with that build… build 4030 should address it and will be up soon. is up now.



Hi @brad, I just noticed an issue with Build 4032 (but may go back further)
I’m using Korg M1 V2.2.1. with Preset Model: Use Plugins Programs
I am unable to use Cantabile’s plugin menu to “Rename Program …”. The dialog box opens with the name of the existing name "Init Combi ", but after I edit the name and click [OK], the name does not get updated in the Cantabile Plugin Preset List.
I also tested with Korg WaveStation and there the rename does work.
I also confirmed that the issue occurs in 3096, so it may be related to the M1, but it seems strange that it’s Cantabile’s Rename function that is not working.
Any ideas?
Thank you - David

If this is only one plugin where this is happening, and it’s when the preset model is “Use Plugin’s Programs” then this is probably an issue with the plugin itself.

When in this preset model, Cantabile doesn’t store the preset names. Instead the new name is passed to the plugin and the plugin is supposed to remember it. So… if it’s not being stored then it’s probably a plugin issue.

Closing this topic, continued here: Cantabile 4 Beta.

1 Like