Assign Midi Controller

Hi, I’m a bit stuck on how to assign midi controllers in cantabile 3. In cantabile v2 i’d right click and select assign midi controller, does anyone know of a similar function in cantabile 3. I’d like to have master volume controlled via my keyboard.

Hey Chris,

Go To View> Background Rack

Go to bindings Tab

Add Binding from Main Keyboard

Fill in event and target areas

Note: Using the “Background Rack” to create the midi binding makes the Volume control work on all songs without any special programing for each song. It used to be called the “Global Rack”. Good Luck!

Hi Chris (and Dave Dore)…

Just a comment on Dave’s excellent response. Using the same keyboard (Axion 61 original model), I am able to assign keyboard controls to MIDI in Cantabile 2, but it doesn’t work in Cantabile 3 for that specific keyboard. My other two keyboards do work using the mentod Dave illustrates.

My specific example is using the VB3 plug-in VST. In Cantabile 2 (C2), I assign Slider 1 to volume and it works perfectly. I exit C2 and go to C3, and go through the Binding process (or optionally use the VB3 “Learn” mode, and C3 recognizes the Axiom Slider, but The Volume knob display on VB3 goes to the 10am position and won’t move from there. Perhaps I have some configuration difference between C2 and C3, but that’s part of the issue… I can’t see at a glance all config settings in C2 and compare to a similar list in C3.

Hi Chuck,

Can you show a screenshot of your binding page?

Hi @cfcboc

It’s not clear from your post whether you’re using Cantabile’s bindings, or VB3’s own internal mappings - sounds like perhaps both. Also some details on which CC the keyboard is sending might help get to the bottom of this.


Also struggled with the same problem but found an easy solution
Go to your vst plugin where you want to add a controller
in the right corner you will find 3 vertical lines - click on them and select Create parameter binding and it works exactly the same as in cantabile 2.0 :slight_smile:

1 Like