Addictive Keys issues

So I just bought Addictive Keys triple play on their 50% off sale and I’m having a couple of issues in Cantabile.

  1. After loading a set list AK doesn’t make any sound until I’ve opened the GUI at least once.

  2. I have the pseudo C3 presets set to different AK presets. When I switch pseudo presets it instantly changes the parameters (fx levels and such) but can take 30 seconds to a minute to change instrument samples. When I change AK presets manually it changes nearly instantly so I know the delay isn’t coming from AK.

I can work around issue 1, but I need to fix issue 2 for AK to be useable live.

Hi Jeremy

I am running C3 32XX and 35XX… No problems with AK. It runs well both in and out of rack. My AK rack has my custom presets in the rack states. I have no problem switching to upright or grand or electric grand or custom presets. Running Win 7.

Sounds like a bug in the plugin to me where the plugin responds instance via it’s own UI but not when loaded via the VST api. Best bet would be to capture a video of it (if you can) and report it to XLN. Feel free to pass on my contact details in case they want to discuss it.

Although I’ve had AK for awhile, I just recently have considered switching to it for my go-to piano, mainly because it is less resource-intensive than Ivory or Keyscape, both of which I like a lot, but both tax my computer in a live setting.

But I am seeing the same behavior (issue 1), and was getting ready to post here to see if anyone else was seeing it. Please update here anyone has an update on this.

I’ve logged a support ticket with XLN - I’ll post back if I hear anything.

1 Like

My response from AK:

Thank you for contacting us! I’m sorry to hear about your issues. We do not support Cantabile. However if this DAW have full support for VST and loads plugins correctly it should work just fine. Don’t hesitate to get back to me if you have any further questions!
Best regards,
Fredrik Blom

My reply:

That was a particularly unhelpful response. :frowning: Cantabile has full support for the standard VST API, and yours is the only VSTi that has had this issue.

Is there any way to set a MIDI program number to a preset and just have AK switch to that program with a MIDI Program Change message? Without some way to automate program changes your application is of rather limited use for live play.


I don’t have a solution, but perhaps another piece in the solution to this puzzle: when I first noticed this issue, I had just started using the 35xx builds, namely Build 3532. So I decided to try the most recent 32xx build (3289) thnking that maybe the plugins are loaded differently. I loaded the exact same Set List, in which AK plugin is part of the 2nd song. The problem did not occur!

Just to be sure, I downloaded and installed the most recent 35xx build (3534), loaded the same Set List, and the problem is back. The patch did not load until I went into the AK GUI and selected it. I then re-installed Build 3289 and everything worked as it should.

P.S. all Cantabile builds and plugins were the 64-bit versions

Hope this helps

1 Like

Excellent. Now @brad just needs to figure out how 35xx is loading AK differently from 32xx and we may haveat least a partial solution.

HI Guys,

I’m in contact with XLN and this will and a few other bugs will be my top priorities for next week. Stay tuned.



I’ve been doing some testing on this today and haven’t been able to reproduce any issues. Here’s what I did:

  1. New Song File
  2. Loaded Addictive Keys
  3. Loaded Studio Piano on Preset 1 and Electric Grand on Preset 2
  4. Closed Addictived Keys UI
  5. Saved the song
  6. Shutdown and Restarted Cantabile.
  7. Played some notes - worked fine
  8. Switched to the other preset - worked fine and different sound.
  9. Retried the whole thing in a preloaded set list - worked fine.

Is there some step I’m missing? I’m running v1.1.5 of the plugin, downloaded today.


If someone could post a video or some screenshots detailing exactly what’s happening that would be helpful.


The only thing that jumps out at me is that I’m putting AK in a shared rack. I’ll try putting AK in at the song level this evening to see if it works differently for some reason.

Same here. I added Addictve Keys into a Linked Rack.and made sure to select a preset from the AK GUI before saving the rack. (The Linked Rack was already in a Song that was already saved in a Set List but I did a Save All after adding the plugin.)

One other note, although I doubt that it matters: the preset I selected when I save the Linked Rack was one that I had modified and save as one of “my presets”.

I won’t be near my music rig for the next few hours, so I can’t provide any other update until later this evening (US Eastern Time).

Follow up:

First I downloaded Build 3535. I then loaded a song that has my “piano” Linked Rack with the Addictive Keys plugin. No Sound. I opened the Rack (Routing view), but didn’t open the plugin GUI. No Sound. I then double-clicked the Addictive Keys plugin row (still in the Routing view) to open the plugin. The AK UI appeared and about a second later, my selected preset opened (I didn’t have to select it). After that I had sound.

If I closed Cantabile and repeated the process, I got the exact same results.

One more experiment: I created a song with AK as a plugin, not in a rack. I got pretty much the same results. When I first loaded the song, no sound. If I double clicked the plugin in C3 to ope plugin UI, but made not to hover over the UI, no sound. As soon as I hovered the mouse over the plugin UI, it loaded the selected preset and I had sound.

Not sure if that means anything (and if it does, it seems like an AK problem and not a C3 problem), but just making the note in case it helps someone troubleshoot.

EDIT: When I went back to my racked version of AK, and tried this same experiment, I got the same results. Moving the mouse over the plugin UI somehow triggered it to load the preset.


Hi Roland. If I am not mistaken, I noticed a few people have been having this problem with other VST’s as well. I had it with Electric 88. I had to replace it with another VST. For all I know, it might have been pilot error. I still have no problem with AK tho. Hopefully someone will come up with a solution soon.

Hi Guys,

Made a little progress: this seems to be related to hi-resolution window support. I’m hoping between XLN and myself we can figure this out.

Until then, the current work around is to set Cantabile → Options → General → User Interface like this:



1 Like

I confirm that this workaround works for me. Thanks @brad!


@brad, I can confirm that this fixes both the loading issue and the patch changing issue I was experiencing before. However, it causes problems with the GUI display.

This is the entire window that pops up. So I can either edit the VST or play it, but not both. Kind of a bummer.


Hi @BigTwisty,

What do you have Cantabile’s Main Window Scaling set to and what are your scaling settings in Windows control panel?


Cantabile’s main and other window scaling are 100%. Windows scaling is set to 100% on my large monitor and 200% on the Surface Pro 4 screen.