Yamaha MOXF8 and Cantabile


#1

I know that this has been covered but I’ve never been able to get this to work.

What I want to be able to do is run Cantabile to handle all my patch changes and configuration. This is a similar to what you can do with MOXF Performances. Has anyone been able to make this work? And if so, might you be interested in helping me troubleshoot (e.g., maybe even a Skype call)?

I’m probably NOT going to use soft synths through the MOXF Audio interface, just mapping, patches, splits, etc.

Thanks in advance -
Pat


#2

Hi Patrick,

I don’t have a MOFX8 but I have read up a little on them when I was looking at them. Do you already use Performances you have made on the MOXF8? If so I was thinking you could just use a banked program change call to MOXF8 with a binding from Cantabile saving a lot of re- invention. The User Performance addresses are included in the PG change mapping tables.

Dave


#3

Thanks Dave.

Unfortunately there are some limitations with the Performances that are pushing me toward using Cantabile:

  1. You can only have 4 parts (patches) in a Performance
  2. I’m using up many of the performances already for some of my other projects (don’t ask me how I went from no bands to 4 bands :wink:).
  3. Navigating to the performances across user banks is a bit tedious, where with Cantabile I can setup set lists and use a CC to increment.

BTW - I’m going to do something similar with the JV1080 that I’m using in the funk/disco band with my Novation Impulse controller driving it.

Pat

PS - I’ll try to experiment more over the next couple of days - maybe time has made me smarter.


#4

Hey Patrick,

OK, I see the limitations now, thanks for the reply. On a side note have you tried the MOFX8 editor VST? Now that Cantabile has VST3 support it will run inside Cantabile. Just making sure you knew about it, it sure looks like it might help your cause.

https://usa.yamaha.com/support/updates/moxf6_moxf8_editor_standalone_vst_win.html

Best,

Dave


#5

If i’m understanding what you’re looking to do, you will want to have the MOXF in song mode for this to work. Song mode will give you 16 parts on 16 MIDI channels that you can then send program changes to select the sound for each part, and use Cantabile to send out the selected range of notes for that part on the appropriate channels. You won’t need to select songs on the MOXF then — just leave it at song 1 and let Cantabile do all the routing to each part. Though i’d recommend avoiding part 1 (MIDI channel 1) which still gives you 15 channels to play with — setting the volume of part 1 to 0 is an easy way of avoiding any sound other than what is routed through Cantabile. Also you may get strange things happening with program changes on channel 1 as it is the default system channel.

Hope that’s helpful,
– Jimbo


#6

Thanks for the tips Jim. I’ll go ahead and give that a try later today.


#7

I’m still having issues. I can’t seem to get this to work.

  1. I’m using USB to connect from he MOXF to the PC
  2. Using the “DAW” profile (Local control OFF), it still seems to be playing sounds from the MOXF as if it were on.
  3. I’ve setup both inputs and outputs to Cantabile, and I see activity on the input, and to the output rack, but not to the MOXF output in Cantabile.

I’m also going to use Cantabile to setup the Roland JV1080 (using it for my second synth). as well as Kontakt for samples. Perhaps I’ll start with the Roland and see if there’s something else amiss.

I’m going to keep Plug-in away (see what I Did there?) until I get this to work. It’s probably something strange like a port setting on the MOXF.


#8

Getting closer. Got the Local On/Off on the MOX figured out. It’s a bit weird but I’ve got that sorted out.

I’ll update the thread for posterity when I get a minute (and Brad - IOU some anniversary $$$ :slight_smile: ).

Pat


#9

I have a positively Precambrian Yamaha CP-85 (Vintage 1995) that Sometimes goes Local Off when I power up my DAW.

I don’t recollect it happening with Cantabile, but it doesn’t happen often enough that I’ve tracked it carefully