White fader knob disappears when setting low / high volumes


#1

Hey guys,

since I have started working with Cantabile there is some kind of strange behavior regarding the “knob” of the levels of an object:

When you set it either to a very low or high setting it disappears. Why?

Does this makes any sense?

Best,
Chris


#2

Hi Chris,

I’ve seen behavior like this in other windows apps if the display is made more readable by increasing the DPI (or whatever other method might be used) to make a small screen easier to read.

Doug


#3

This is almost certainly a side effect of using a binding that sets the value outside the range displayable by the slider. What do you have selected in Options -> Keyboard and Controls -> Control Curves?


#4

I use encoders so there is no curve.


#5

Actually there are still two curves used - the MIDI one and the slider one. And even so there is still a range associated with the binding.

I think the problem here is that the default MIDI curve allows gain values up to 14db, but the default slider only goes to 7.3.

Try either:

  1. setting the max range of the binding to 7.3 and it should clamp it appropriately.
  2. changing all three the curve settings to use the same curve.

Brad


#6

Okay. But why does the slider only goes to 7.3db but can go to +14db when accessed via midi?


#7

That is entirely up to you: you can set the slider curve, level meter curve and MIDI control curve separately:

You can actually define your own control curve --> see the guides section on Control Curves

When the curves are all the same, the slider shouldn’t disappear, but sometimes it is useful to have a different MIDI control curve (e.g. I prefer to have 0 dB at MIDI value 64)

Cheers,

Torsten


#8

Ah, alright. Now I know what you mean!

Okay. So I see… if I set it to “Classic” it seems to work like I expect.