What is the typical range of your Cantabile % meter?

I’d be very interested to know how much the % meter fluctuates on your systems.
Obviously, everyone’s demands on their respective systems is different, but I assume we’re all looking for a certain stability to prevent potential spikes.
My system seems to be getting sensitive to screen redraws and I can see spiking when certain GUIs are open.
Anyone know of any reliable schemes for lowering the priority of screen redraws over and above the normal ‘background processes’ tweak?


I was asking myself the same today.
Especially, what is your C3 load - cpu load Ratio?

My C3 load peaks easily (with glitches) even though my cpu loads rarely exceeds 20%.

I can use the same set of plugins in Forte without problems.
In most of my songs, the 88-keyboard uses a multi layer template of Kontakt Grandeur, Kontakt Scarbee EP-88, Dexed and Reaktor with a pad instrument. They are played simultaniously and controlled with a nanokontrol. A very flexibel setup. I have been playing this setup in forte at 96 Samples for years without any problems.
In Cantabile i had to raise the latency to 128 samples and still get glitches.

My Setup:
Lenovo T440p, i7, 16GB Ram, 2x SSD HDs
RME UCX (128 Samples)


Hi, this is exactly what I just reported to Brad who kindly asked me how I’m dealing with Cantabile as a new user.
Cantabile eats more CPU than Forte that’s my experience too (years of gigging with Forte)… But the more I dig into C3, the more I can say it does more!
For “realtime” audio, you can’t rely on Forte or task manager global CPU indicator.
If you have, let’s say a 4 core CPU and you’ve got a long VSTi => Fx chain this couldn’t be multithreaded and you’ll max the only one core that it’s sent to. You’ll have glitches with the global CPU meter showing only 25% usage. Asio metering is much more accurate.

Please see this article:


Main takeaway points:

  • you can’t compare Cantabile’s load meter to Forte’s (they measure different things)
  • task manager’s (nor Forte’s) CPU load metric isn’t very useful for real-time audio
  • Cantabile displays “time load” - which is what really tells you how close to a drop out you are.

I hope this helps!

Thanks for the replies, guys.
Something is lurking inside my setup that sends it from a 17-23% load up to an occasional 41 to 59% spike. That’s a big jump.
I wanted to know if anyone else sees these kinds of spikes.

Have you checked for DPC/ISR issues?

Hi Brad
Well that was revealing!
Google Chrome was quite an offender. It runs processes in the background that are so pervasive that they have to be quit before the app can be uninstalled.
Haven’t yet found which culprits are causing the jumps yet.
Question - it seems to make sense to run LatencyMon with Cantabile running. Would you advise running both with and without?

Sorry, I was mostly replying to Steffen in my last post.
Ade, make sure to optimize your system for audio using Brad’s guide.
Maybe Process Lasso could help. It’s a 3rd party task manager where you can set thread and I/O priorities. I’m using it with Cantabile too. It seems to help smoothing a bit setting C3 at hight thread and I/O priority. (The “realtime” setting made it worse for me).

Hi everybody,
when i wrote “peaks easier, higher cpu load than…” i didn’t mean any meters in software of taskmanager.
i just realized that performing with the same plugins in forte didn’t cause any trouble but with c3 i had glitches.

brad, i’ve read that article already. beside many others that you wrote.

so here’s my workaround:
switching to cantabile made me rethink my whole setup.
i will use all main keyboard sounds (piano/rhodes/dx piano) from the roland rd-300nx. this will take a lot of load off the laptop and will make my setup more flexible as i am not restricted (on main keys) to the sounds that i programmed for the song.

all the best

My computers are pretty much audio optimized - however it’s been a while since I ran a latency monitor and it was revealing, more in terms of how some apps were making surprisingly high calls in the background. Chrome specifically.
What I am trying to zero in on is the occasional jump which takes a nominal load and jumps it up by 15-20%.
As far as the DPC checker was concerned, it was green lights all the way.
But …
some plugins are graphics hogs which cause problems when their GUIs are open. Answer - don’t play with GUIs open - or find a way to put those calls to the back of the queue.
So, I’m very interested to know the range of spikes that other users might be experiencing.

Steffen, if that’s the case then we should really be discussing why that’s happening. Forte’s metering doesn’t provide real world feedback. The danger of that is that the user may feel ‘safe’ even when the system is failing.
However, your experience is that you can run higher loads in Forte than in Cantabile. That’s something that would concern all of us here, and the idea of offloading to hardware, while absolutely practical in terms of getting your work done, is not really a solution - it’s a band aid.
Do you know which specific plugins were pushing your system over the limit?

1 Like

Adrian, what exactly are you doing to Chrome to prevent its background calls?

I uninstalled it! :smiley:
Using Opera instead.

1 Like

I like Pale Moon, myself. Maybe I should check Opera out.

I did some more testing:
i tried different settings in the audio engine:
changing the number of audio threads to the number of my system cores worked better than using the virtual cores. multi-processor mode set to aggressive works best.

I made a new song with the same instruments i use in forte:
1x kontakt (Scarbee Classic EP-88 and Grandeur)
1x HalionSonic with a DX Piano
1x Reaktor 6 with JP4-C Ensemble (Pad)
no further processing like amp sim or eq were added.
if i play more notes (solo-like), glitches occur.
i had LatencyMon running and it didn’t show any problems.

the same instruments (w further processing) run forte are never glitching. if i’m really pushing it like playing glissandi up and down the first glitches occur after the 3rd or 4th glissando.

Again: i’m not talking about comparing load or cpu meters here. my main goal is to perform without glitches.


Hi @Steffen,

Sorry to hear you’re having these problems. A couple of questions:

  1. When the glitches occur, is there an associated spike in Cantabile’s load meter or page fault counter?
  2. Could you try disabling Cantabile’s multi-core support (number of audio threads = 1) and let me know if that makes any difference.
  3. Is this problem new to 35xx or does the same problem happen in 32xx?


Hi @Brad,

  1. The load meter exceeds 100%, i’ll check the page fault counter later.
  2. disabling the multi-core support made things worse. Setting the multi-core support to the physical count of cores (4) worked best. Using all virtual cores seemed to glitch earlier.
  3. I just purchased Cantabile and only used 35xx. I’ll check with 32xx later.


1 Like


did you read through Brad glitch-free book and do the performance-tweaks he suggests? Like disabling core-parking and disabling all energy-saving-technologies. Especially if you work with a laptop, there might be a lot of this energy-saving options.

I read that you use a RME UCX. I also use a RME interface. A babyface pro in my case. Let me tell you what I discovered two days ago:

I had some glitches especially right after booting the computer. So the first glitch occured about 90sec. after systemstart. I wanted to know what was going on there. So I created a simple song within cantabile, which has a plugin loaded. I recorded a MIDI-track, routed it into the plugin and looped it. I restarted the computer a few times, started Cantabile, loaded the song and fired the MIDI-track and the glitch occur in the exact same moment. I had LatencyMon running while this test and it said, that my system runs fine (even though I heard a glitch). That lead me to the conclusion, that it has nothing to do with drivers (which is good).
I started to investigate that a bit more and installed ProcessMon from SysInternals. It’s free and very very useful:

What it basically does is, logging all (!) events that are going on on your computer. There are tons of informations.
But: After a few tests I found out that TotalMix caused these glitches. Everytime the glitch occur, I had a report in ProcessMon, that TotalMix exits a Thread. So my assumption is, that TotalMix does something in the background and blocks a core for that short moment. I went into BIOS and switched off HyperThreading (what you don’t need anyway if you set Cantabile to using physical cores only) and the problem seems gone. TotalMix still exits a thread but doesn’t seem to block a core anymore.

Anyway: I see no reason why Forte worked great and Cantabile doesn’t. I hope you get it running. If not, feel free to contact me. I have a whole list of things that I have done to improve my system. It’s anyway time to drink a coffee together. :wink:

Regards from the neighborhood,
Christian R.

1 Like

@brad, i double checked some stuff concerning your questions,

  1. i don’t see spikes in the load meter or the page fault counter. page fault is around 2000-4000pf. the page fault counter exceeds 4000pf when glitches occur.
  2. i installed .3289 no difference

Hi @Christian,
i worked through all of Brads performance tweaks.
But since i have worked with that laptop for several years with forte without any problems (and still do) it don’t think that there is anything wrong with my hardware.

you are always invited for a coffee!

1 Like

Hi Steffan,

Could I get you to try one more thing… start Cantabile, give it a minute to load everything then stop and restart the audio engine (Power button top right of Cantabile’s main window). Give it a second again and then see if the same problems happen.

I haven’t seen this myself, but others have reported that this can help and I’d be interested to hear if you get the same result.