Weird issue with NI Replika/ReplikaXT plugin

I fully suspect this to be a bug within Replika and Replika XT, but I thought I would post it here to see if anyone else has seen this, because Cantabile is my only VST Host and I really do like Replika except for this issue. (Everything here pertains to both plugins, so I will just refer to ReplikaXT for simplicity.)

ReplikaXT has a Save As… function to save your own presets separate from the factory patches. It comes up with a popup dialog so you can enter a new name for the patch, but it will only allow me to type spaces and special characters, no numbers or letters! I don’t think this is related to the known issue with Replika XT where it requires a certain version of OpenGL to be supported by the graphics card because everything else works perfectly with this plugin, but I guess you never know.

There is a workaround where I can save the patch using only special characters, then go to the folder in Windows where the patch is stored, and rename the file there, but this is a real pain.

Has anyone else seen this or can anyone else repro this problem? I get the same behavior on my MS Surface running Win8.1 and a Lenovo Yoga 900 running Win10.

Can you paste a name into the box, with letters?


No. I thought of that, and created a new name in Notepad and tried to copy/paste that text. I also tried to reight-click in the box hoping that it would have a Paste option. But it is not a standard TextBox control.

sometimes the “old” method of ctrl-c / ctrl-v works in pasting when right mouse cllick does not. I assume you tried this too?

Yes I did try the Ctrl-V method of Paste.

Hi @Roland_Robertson

You don’t have Cantabile’s keyboard capture turned on do you? If so, Cantabile’s probably stealing most of those keys and sending them to the onscreen keyboard.


@brad I really thought that was going to be the answer. But no, I didn’t have the Capture Keyboard feature enabled. I did enable it (and verified that it was working as designed) and disabled it again. But it made no difference.

Like I said, I am confident that this is a quirk in that plugin. I am mainly curious if anyone else uses these plugins with Cantabile (or any other host) and has or has not seen the behavior.

Hi Roland

Do you know if the same problem happens in other hosts? If not let me know and I’ll look into it.


I downloaded a trial version of Ableton Live, and it did not have this problem.

Ok leave it with me I’ll check it out tomorrow.

OK, I’ve looked into this and Replika seems to be behaving inconsistently. I’ve contacted NI about it.


Technical notes for future reference:

  • Cantabile is correctly dispatching the VST effEditKeyDown and effEditKeyUp events
  • Cantabile is providing the correctly translated character codes.
  • Replika is returning true for some VST key events and false for others.
  • When Replika returns false, Cantabile dispatches the key through normal Windows message dispatch mechanism and it gets displayed in Replika
  • When Replika returns true, Cantabile assumes the key has been processed and suppresses further dispatch of the event.


  • Disabling Cantabile’s sending effEditKeyDown and effEditKeyUp and dispatching everything via Windows messages causes the keyboard to work perfectly (but will break other plugins).
  • Disabling Cantabile’s message dispatch and always sending effEditKeyDown/Up causes most characters to work, but punctuation characters appear twice. (This will also break other plugins).

Thanks for looking into this.

1 Like

No problem. If I don’t hear anything useful from NI I can probably add a compatibility flag and handle specially for these plugins. We’ll see…

I just applied the update to the Replika XT plugin and this bug appear to be fixed. (I didn’t test the Replika plugin, but it also had an update too.) Thanks Brad for helping to bring to NI’s attention.

Thanks @Roland_Robertson good to know.