Waves plugins in Cantabile

in Cantabile 3 I can’t start the shell plugins (Waves).
When I try to open, there is always an error of illegal characters in path (caratteri illegali nel percorso, in italian).
I’ve this error only in Cantabile, in Cubase, shell plugins work well from path where there are installed.
Any suggestion?

Hi @giannicorsi

I’m not aware of any problem with Waves plugins but I just tried to test it here and my copy has expired. Let me get that sorted out and I’ll let you know what I find.

In the meantime a couple of quick questions:

  1. Cantabile 2 or 3?
  2. Which version of Windows?
  3. x86 or x64?
  4. Does the error display during plugin scan, or does the scan succeed and the plugin fail to load when you try to insert into a song?

Also if you could send me a log file that would help. Start Cantabile, reproduce the problem then from Tools choose “Open Settings Folder”. Close Cantabile and email me the files log.txt, log-previous.txt, settings.json and plugins.json.


Hi Brad,
the problem affect Cantabile version 2 and 3 on my Windows 7 64bit(before) and 10 64bit (now) daw and also on my Windows 10 64bit laptop.
Only with x86 version, and the error display does when I try to insert plugin in a song.
The x64 version seems doesn’t have this problem.
I will send you the log.

Thanks for your help,


Why do the shell plugins take so long to scan? It wouldn’t be so bad, but every once in a while Cantabile decides to re-scan them on start up and it takes 20-30 minutes.

Cantabile will rescan them it it detects the time stamp on the WaveShell dll has changed (ie: new version installed) or if there’s a new version there with a new file name.

As for why it takes so long I’m not really sure - I think it’s just there’s a lot of them and they’re slowish to load. Does it take just as long in other hosts? If not, let me know and I’ll take a closer look at it.


I will try a few hosts in the next few days and time them for you. I agree, the shell has a bunch of plugins but from my recollection it isn’t as long in Ableton or Studio One. I haven’t updated my waves shell in a while so I’m not sure why the re-scan is occurring. This is particularly troublesome when it occurs prior to a performance.

Hi @Lempface.

You could turn off autoscan on startup:


Hi Brad,
I finally installed Windows 7 64bit on a bootcamp partition of my MacBook.
I installed the 3200 build of Cantabile 3, and a pair of Waves plugins.
I currently have no other software and / or plugins on the system.
Anyway, when starting Cantabile, plugins in shell container, now, are properly recognized, both on 64bit and 32bit version.
I need to update Cantabile, Waves Central and try on a notebook with Windows 10 where I had encountered the problem.

1 Like

Brad, the plugin scans in Plogue Bidule and IK Minihost Modular took just a couple minutes compared to ~20.

OK interesting. I’ve logged this so I don’t forget about it. I have one theory but will need to check it out.

Hi @Lempface,

I’ve been looking into this and have made some changes which I think make a big difference. I’ll probably include this in the next build but need to do some more testing first.

In the meantime if you’d like to try it I’ve attached the updated Scan Server executables. Just copy them over the existing files in your install directory (usually C:\Program Files\Topten Software\Cantabile 3.0).

CantabileScanServer.zip (155.8 KB)


One more thing to keep in mind: If you do not have any audio i/o on your PC, the scanning and loading of plugins (mostly Native Instruments) will take forever. Yesterday I took my studio pc home for maintenance and forgot my audio interface. Unfortunately, the pc has no build in soundcard, so i was feaced with this behaviour :scream:

Greetings, Tom

That’s really weird - I wonder why that would be? Cantabile’s scan server doesn’t do anything with audio interface during scan so unless the plugin itself is looking for something I can’t think why this would happen.

I did some testing and indeed - this is not Cantabiles fault. The standalone versions of Native Instrument also take forever to load when no audio equipment is used.
So always make sure you have at least the build in soundcard activated :wink:

1 Like