VST3 implementation feedback


#1

Hi Brad

While experimenting with the VST3 implementation I noticed:

  • importing my VST3’s sofar works fine
  • replacing an existing VST3 with another does not work yet: it gives an error “Value cannot be null. Parameter name key” (see enclosed picture)
  • using the new Reason VST3 rack plugin works fine (I am a beta tester there); works ok so it seems reading all the Reason Rack Extensions I have and tested sofar
  • the VST3 implementation to a bit more CPU intensive compared to VST2

Hope this is useful to you. I keep on experimenting

Ad


#2

Same Error message here when replacing a VST3 plug with another VSt3 plug.

I had some random crashes while testing the new presets implementation with OPX-Pro II VST3 plug, not tested with the vst2 version yet. Crash reports sent to Brad.

For this plug i didn’t notice a difference, it doesn’t seem more CPU intensive than VST2.

For the few other plugs i tested (essentialy Arturia plugs VST3 versions) everything works well. We’ll see with more intensive work.

p.s. : I didn’t contribute much here since the first Cantabile 3 release but use it intensively in my work, and it has been rock solid for a few hundreds gigs with 3 differents bands in France. I’ll try to contribute much more now ! :slight_smile:

Sebastien


#3

I got a hard crash (Cantabile program disappears) when loading the Arturia Buchla Easel V.

Since @AbgraalStudio did not get crashes when loading Arturia instruments, I wonder whether it was some confusion with the audio ports going to Voicemeeter in this case? (I was testing on a PC that is normally only used for music listening, using Cantabile to host IK Multimedia’s ARC2 room correction plugin fed via Voicemeeter’s inserts.)

I could understand this possibly being the case now that the port structure of Cantabile has been made to change to be in keeping with the new port system in VST3.

Terry


#4

More quick tests, all at song level by inserting plugs directly :

  • OPX-Pro II : while replacing Vst2 by Vst3, midi In route and Audio out are disabled

  • Arturia plugins (tried with 5 plugs) : while replacing Vst2 by Vst3, error message “Failed to pass data to core (error 13212)”

  • Blue3 : while replacing Vst2 by Vst3, error message “Failed to pass data to core (error 13212)”

  • Diva : while replacing Vst2 by Vst3, “different audio ports number” notification. Pressed ok, the Vst2 plug is inserted, but trying to open it by double clicking or to delete it crashes Cantabile.

  • Diva : inserted the VST3 directly, it works. Trying to change to another sound inside Diva : freeze of Cantabile.


#5

With me, Arturia Buchla Easel V VST3 loads fine in Cantabile


#6

All Arturia plugs I have tried worked great when inserted directly in VST3 format, no crashes here, but u-he plugs (tried diva and repro-5) seems to lead to a systematic hard crash of Cantabile, like you


#7

Further testing:
VST3 instruments plugins that load well (simple usage with changing a few presets only sofar):

  • AAS Chromaphone
  • AAS Lounge Lizard
  • AAS String Studio
  • AAS Ultra Analog
  • AAS Strum GS
  • Arturia V-Collection VST3’s
  • Cakewalk Z3TA+2
  • Cakewalk Rapture Pro
  • Modo Bass
  • OPXPRO
  • Pianoteq 6
  • Reason Rack Plugin (with a large number of Rack Extensions; so cool to have these now!)
  • Syntronik
  • Waldorf PPG wave 2.2
  • Waves Grand Rhapsody
  • Waves Electric 200
  • Waves Electric Grand 80
  • Waves Electric 88
  • Waves Bass Fingers
  • Waves Bass Slapper

VST3 effects plugins that load well (simple usage with changing a few presets only sofar):

  • Overloud GEM EQ550
  • Overloud TH3
  • Ignite Amps PTEq-X

Problem issues:

  • GSi VB3 II (it reads it in and plays the basic preset, but after changing presets changes all to 0)
  • Fabfilter effect plugins do not load, as for now

#8

So far, if I place any Waves VST3 effects plugin after whatever brand VST3 instrument (even after a Media Player), there is no sound. The VST3 instruments play well without the extra effect. When I use a Waves VST2 effect instead of a VST3 effect, it works again well.

I suspect there might actually be an issue with more effect plugins following an instrument; thus VST3 effect plugins do not seem to recognize the audio that is supposed to go in. VST2 versions work fine.


#9

I tried using the Arturia Buchla Easel V in several other audio setups on the same PC.
The Voicemeeter Inserts lead to the hard crash.
The Voicemeeter ASIO out works, but makes clicks in the audio that are constant rhythmic ones.
The Voicemeeter WASAPI is distorted, and my usual tricks of stopping and restarting the Cantabile audio engine is not working any more.
The Realtek WASAPI works fine after some clicks initially during the first few seconds of use.
The Focusrite ASIO works fine.
All tests done with matching sample rates in both Voicemeeter, Cantabile and Realtek.
So, something in Voicemeeter ASIO is not working very smoothly, and WASAPI is broken on it also.


#10

Doesn’t work well :

  • Every Softube Fx plugs from Volume 1 and Console 1 : inserted VST3, no output signal, had to edit the audio port of the plugs to make it work (input ports were sets to output ports assignations, weird !). Saturation Knob, Summit Audio EQF-100, Trident A-Range, Tube Delay, plugs can’t have sound at their output. Weiss limiter (unusable for latency cause) works great without a glitche (except latency !).
  • Softube Heartbeat loads but no sound (routing mess as fxs ?)
  • GSi VB3-II and Rotary: loads well, but changing preset inside the plug every parameter goes to 0 !!!
  • Liquidsonics Lustrous Plates FX (from Slate) : loads well but no sound, it seems there’s no audio port routing problems like Softube, just no sound.
  • Izotope FXs and Iris: loads well, works well, but when deleting the plug Cantabile just close itself
  • Fabfilter FXs : loads well but no sound

Works well :

  • Slate Digital All pass FX plugs vst3 : Eiosys air and desser, Th-u Slate, VBC, Verbsuite Classic, VMR, VTM (latency)
  • Roland VS TR-909
  • all Arturia including Pigments
  • Pianoteq 6
  • IK-Multimedia Amplitube 4 (Leslie)
  • GG Audio Blue3
  • Softube Modular
  • Cherry Audio Voltage Modular
  • Steinberg Padshop and Retrologue 2 (installed with Cubase 10 Pro)

#11

Argh I Forgot :
Works Well :

  • GGAudio Spin

Doesn’t work well :

  • Everything U-He (instruments and fxs) : loads and works well, but Cantabile force close when deleting plug.

#12

Same behaviour with me with GSi VB3 VST3 version: when changing presets all parameters go to 0!!; Something’s wrong there. VST2 version still behaves ok


#13

For me it is VST3 plugins once loaded cannot be replaced and when you try to delete the U-he Diva synth there is a crash.


#14

Thanks guys… this is exactly the kind of feedback I need to get this stable. I’m away from my PC most of today but I’ll look at all the mentioned issues asap.

Brad


#15

I basically get a problem with all Fabfilter VST3 plugins. They do load (although actually on several occaisons, Cantabile freezes), but even when I have a simple Cantabile setup with only a media player, followed by a Fabfilter effect, there is no final sound.


There is audio leaving the media player (see picture), but no audio entering the Fabfilter plugins. Same happens with Waves plugins.


#16

Some good news: I have the Reason Rack (VST3 only, offical launch tomorrow 25/9) plugin working in the latest Cantabile VST3-reading version. This is for me at least good news, as I can use my 90 Reason only Rack Extensions now in Cantabile (and other VST3 accepting DAWs)


#17

Thanks everyone for reporting these issues.

I’ve spent today making a number of fixes which are available in build 3617 now:

  • Fixed - crash processing some VST 3 plugins in 64-bit audio mode
  • Fixed - audio ports command should be disabled on failed to load plugins
  • Fixed - exception when trying to replace non-upgradeable plugins
  • Fixed - various fixes for some VST 3 plugins
  • Fixed - incorrect cursor sometimes displayed in menu bar
  • Improved - display a better error message when replacing plugin fails to load
  • Improved - removed redundant VST 3 logging

There are still unresolved issues which I’ll continue with tomorrow.

Brad


#18

Thanks Brad! I`ll try the latest update and will let you know my findings.


#19

Hi Brad

What I have observed:

Issues resolved with build 3617:

  • Replacing a VST3 plugin with another one

Issues remaining:

  • A VST3 effects plugin does not read in the audio, neither from a VST3, VST2 instrument or audio file/Media player ( I have this with several Waves and Fabfilter plugins in any case)
  • the GSi VB3 issue

#20

Is there a way to determine if the plugin you have setup in the song is VST2 or VST3? I cannot find an obvious way. Thx