Using Cantabile to give Piano Lessons (or Cantabile Lessons!) via Skype or Hangouts on Air

Tags: #<Tag:0x00007f97846994e8> #<Tag:0x00007f9784699358> #<Tag:0x00007f9784699178> #<Tag:0x00007f9784699088>

This is a double post only to help out the search.

These are comprehensive instructions on setting up Cantabile, the Voicemeeter Pro “Banana” virtual mixer software, and Skype or Hangouts-On-Air to be able to give piano lessons to students online and remotely, in case any of you supplement your income by giving lessons.

You could use the exact same setup to teach someone how to use any audio-producing program that uses ASIO where you need to interface with either video-conferencing software or recording/streaming software (like OBS) that only accepts WDM style inputs. Give lessons on using DAWs, Cantabile, standalone instruments and VST plugins, etc.

Here is a link to the post at my website if you’d like to share the article:

Here is the link to the Voicemeeter setup file mentioned in the video:

Thanks to @LeesKeys for getting this conversation started, which led to the making of this video.



I did a test hangouts stream last night with my son and there were some audio problems, which I later traced to user (me) error. another issue which I have yet to resolve is a problem with signing on to a Hangouts session. I created a test Hangout, copied the URL, closed Hangouts, clicked on the URL and rejoined the Hangout. But then 15 minutes later when I tried to rejoin the session again, I got an error message “you’re not authorized to start this video call”. Same thing happened last night when I did a test Hangout with my son. He was able to join the Hangout using the link I sent to him, but later in the evening he couldn’t rejoin with the same URL. I had to send him another Event invitation from with the new URL- but I looked at the original URL and the “new” one and they are the same.

This is pretty confusing and I wonder if I’m overlooking something basic. Any ideas?

If you started the broadcast and did not stop it (but instead just closed the window or used the red “hang-up” phone icon), it will stop itself in a couple hours and you will need to create a new event. Did you try and see if it was still listed in the YouTube Live Streaming ==> Events page in your Creator’s Studio area? You should always be able to re-enter from that page if it is still available by clicking the button that says “Start Hangout On Air”.

If you do not start & stop a broadcast, and simply leave by clicking the red phone icon, then the event stays active forever, as long as you never started the broadcast.


Here is the checklist I provided in the article version of the video appearing on my website:

For Hangouts-On-Air – CHECKLIST

  1. Set up a YouTube channel if you haven’t already

  2. Click your user icon at the top right and select “Creator Studio”

  3. Click at the left into “Live Streaming” and click on Events

  4. Click on the far-right on “Create new event”

  5. Select “Quick (Using Google Hangouts On air)” from the radio buttons toward the right near the bottom – that sets up a Hangout-On-Air as the format

  6. Set it from “Public” to “Private” or “Unpublished”.

  7. Start the hangout by clicking “Go Live Now” — that does not mean you need to start calling now, it just lets you get the viewing links and set up the audio and video in advance. (You can also schedule events to happen in the future in advance… even after this step!)

  8. At the lower right, click the “Links” button to get the link to the YouTube video to share, and also an embed code for putting it on your blog page (which can be a private page, of course, only visible to your student), and then DEFINITELY copy the link from the top address bar that leads back to this HOA, which you can email to yourself and to the other person(s) so they can join it. When you return to it, just hit the “Join” button and you are in. Up to 10 people can participate in a normal hangout. (Up to 25 if you have a “G-Suite Basic or Business” account.)

  9. Click the gear at the top and set your microphone to Voicemeeter Output and your speaker to Voicemeeter Input. I advise changing the audio from “Voice” to “Studio” and keeping your levels at or below -12dB. Click “Save”.

  10. This HOA is now set up – clicking the “Start Broadcast” button will begin the recording. You can continue without recording by just leaving this open and not hitting the “Start Broadcast” button. When finished Recording (that is, “Broadcasting”), hit “Stop Broadcast” FIRST and then hit the red-phone button at the top to hang up. If you do not hit “Stop Broadcast” before hanging up, it will continue recording for four hours then disconnect itself.

  11. Once all this is set up, hit the Red Phone to hang up and shut the hangout window if you are not making the call right away. This all stays available as long as you don’t use it (so retain that link from the address bar you got – makes it a pseudo “Skype” for you and your student to use, with better audio!). This now also appears in the list of your scheduled events at at the bottom, where you can change the time so it is scheduled for a specific date by editing the “Basic Info” page, or you can alternatively start the hangout from there on your end, and get the address bar link and other links to share if you had forgotten to earlier. It will stay there until you use it, so if you don’t ever broadcast and stop-broadcast, it stays around to use again and again. You can get rid of unused ones by checking the box to its left and going to the top under “Actions” and selecting “Delete”.

  12. Extra: You actually can view the live stream from the tab to the right of the “Basic” one which now shows a “Live Control Room” link. View the stream from the “Preview” section by hitting the play button in the middle of the video there. The “Public” view will not be active until you show up to start the broadcast.

That’s it! Seems like a lot the first time, but it is really quite simple. This checklist will always be handy, though!

When ready, click the link you saved to enter the hangout, hit “Join” and optionally start the broadcast (begin recording) when you are ready. Or just re-use this as a hi-fidelity version of Skype by having students join at the proper time with their link.


Between your video and explanation above, I think I understand the process pretty well.

So as long as the Hangout Event is active in Youtube (hasn’t been ended or deleted and doesn’t have a future start date/time), I can click on the saved Hangouts link anytime to join the Hangout.

And it doesn’t matter whether my Youtube Events page tab is opened or closed.

And as long as the Hangout is active, anyone with the link can join the hangout. So it’s not like Skype in which the “connection” is closed at the end of each call. It’s available to tap into at any time.

Do I have this right?

1 Like

I’ve been able to click on my test Hangouts link numerous times this morning, connected right away. Now about 30 mins since my last post, here’s the screen I get. I found that if I go back into my Youtube Events page, click “start hangouts on air”, this seems to refresh the link and it works again. It seems as if no one is using the Hangout, it goes “inactive” and needs to be reactivated by the person who originates it- at least that’s the way it looks to me. I guess the best thing to do would be to go the Event, and click “Start Hangout on Air” a couple of minutes before the start time for each lesson.

Well, that seems odd on my end. I wonder if it is from an expiring cookie or something?
I’ll have to take a look to see how the “Start Hangout On Air” link and the one in the address bar might differ. There could be a time-code based component in the URL of the latter.

Otherwise, you are doing everything right, no doubt about that! This is a new wrinkle I’ve not encountered, likely because I always start mine from that events page. I’ll test it and append the video and article with what I find if there is an easy solution!


My latest challenge is audio at the other end of the Hangout. My son and I were chatting on a hangout last night. The audio quality was, as you promised, much better. However, he told me "everything you’re hearing is coming back into my headphones. I had trouble understanding what he was talking about but it appears that when he spoke, his voice was being “bounced back” so that he was hearing himself speak in real-time and with a very slight but distracting delay. I turned the B button off in the Voicemeeter virtual input channel and the bounce-back stopped, but then he was no longer hearing the signal from Cantabile. I must have something set up wrong in Voicemeeter

It sounds like his signal coming in on your side is being sent out the B1 output.
Make sure your keyboard is coming in one slider (VAIO _or _VAIO AUX) and that is being sent out B1, but his signal is coming in the other one and is not being sent out B1.

Also, if one tries to monitor their own microphone via A1, there will usually be a slight delay.

Just so long as the hangout’s speaker setting is not set to go to the same VAIO or VAIO AUX slider that the keyboard is going to, there shouldn’t be a problem.


Can I do that with regular Voicemeeter? Or will Banana solve the problem.

Banana is required for this setup to work.

(Well, you COULD use a virtual audio cable as Hardware Input 2 in regular Voicemeeter, but the presence the VAIO AUX channel in Banana eliminates that being necessary.)


Well well, seems like I just can’t win. VM Banana set up and running, looks good. All settings are as recommended in your video. However, I now havea problem with distortion from Cantabile. Audio out of Cantabile is crystal clear until I start a hangout, if I close the hangout then audio goes back to being clear. Doesn’t matter whether audio in Hangout is set for Voice or Studio- as long as a Hangout is active, the audio is very distorted and as soon as I disconnect the distortion disappears.

I’ve tried restarting the audio engines in Voicemeeter and Cantabile. I’ve tried rebooting Windows. I’ve tried running my internet connection via ethernet rather than wireless, shutting down unnecessary background processes and adjusting the bandwidth within the hangout. When running the Hangout, CPU usage is 38% and physical memory is 76% (not great but shouldn’t be high enough to cause a problem- I think). The Hangout does use a lot of memory- the Memory usage drops to 56% when I shut the Hangout down. I have 6GB of RAM and the laptop tops out at 8- i know, more would be better, but buying another laptop is not a viable option.

So I’m out of ideas. Suggestions?

Sounds like the sample rate is not set to 44.1 in Voicemeeter or something.
If it is, try restarting Voicemeeter from the menu (top item) to see if it syncs then.


Restarted VM. Still getting the distortion. All sample rates are set at 44.1 in Windows for Playback and Recording options. The only thing that doesn’t read 44.1 is VM Skype/HOA Aux output, which I see no way to change. My only other observation is that if when I start the Hangout, very little distortion. It gets much worse within a few minutes, whether I’m playing intermittently or continuously. Also, the problem doesn’t occur with Skype

Are those your actual settings?

Egads - I think my setup file must have included a bit TOO MUCH information!!!

The Skype/HOA column should definitely not be set to 96000 Hz unless you wanted it that way.

Use this file and tell me if it changes – if not, then you need to change it manually. (2.5 KB)

Elsewise, I’ll have to make you a video to show how to change the AUX slider to 44.1.


To change the VAIO AUX sample rate, go to

C:\Program Files (x86)\VB\Voicemeeter\VBVMAUX_ControlPanel.exe

From the Options menu, change the sample rate to “Internal Sample Rate: 44100 Hz”

You may need to re-start your machine.

I’m hoping that was merely a screen shot of my own setup you shared from the video. I have it setup to 96K so I can play Foobar2000 hi-res files mixed with lower res files in a playlist.

You also should have the “Preferred Main SampleRate” in Voicemeeter set to 44100 Hz.


I changed the sample rate, rebooted with VB Aux now running at 41k. But the distortion persists

Is that the Grand Rhapsody? Could it be using 48k samples?

That definitely sounds like a sample-rate mismatch. See if it works with other instruments???

I’m a bit flummoxed! I have not run into this kind of issue in about a year coming from Cantabile.


The distortion persists for all plugins. I’m flummoxed too. Hate to cry uncle after all these hours spent to get things up and running. If you have any other ideas, give me a shout.

Update - Lee and I got on a Hangout-On-Air to look things over this morning, and it turned out the issue was solvable on Cantabile’s end as the CPU was maxing out (likely due to running streaming software at the same time). Unloading other instruments that were loaded but not being used made even the CPU-heavy Waves Rhapsody Grand usable, as that was maxing out continually beforehand with Pianoteq and Addictive Keys running at the same time. Addictive Keys alone (with the others unloaded) was the leanest-running of the three - plenty adequate for piano lessons! :slight_smile:

So, the big takeaway was that what worked when not streaming in Cantabile could present a challenge when trying to run Voicemeeter and a Skype or Hangout-On-Air session at the same time.


1 Like