USB Audio Interface

Tags: #<Tag:0x00007f97922082e0> #<Tag:0x00007f9792208100>

I am considering changing my audio interface. I have a first-generation focusrite Scarlett box, 2i2. It works all right, but I’m wondering if a newer audio interface will give me better latency.

You will get what you pay for! :wink:

Everybody seems to be very enthusiastic about the RME Babyface and other RME products. Their drivers apparently are the best of the best. I hope to own one myself one day.

Terry

Hi,

You don’t say what latency you are currently getting? Focusrite make very good interfaces. I use a first gen 2i4 and at whatever buffer settings I have (I can’t remember, but can check if you wish), then I do not notice latency when playing.

Equally important is your computer and how well it can do with feeding the buffers. What is the Cantabile load with your most complex song?

Well, me and some other guys on the forum do have problems with crashes related to their driver. When changing audioports (via the setting menu of cantabile) it’s just a matter of time when the crash will show up.

1 Like

@FantomXR I had no idea anyone had issues with any RME drivers!

FWIW, I am still plowing along with my MOTU Ultralite mk3 hybrid and 828 mk3 hybrid boxes, though they can be a little cantankerous at times and require special care if feeding them sample rate changes.

Terry

1 Like

@Derek Here is my laptop
DELL LATITUDE E6420
Intel Core i7-2640M 2.80GHz
250GB SSD
16GB
Windows 10 Pro
Cantabile Performer 3

I have latency settings working pretty well. I am at 8-10ms and works pretty well. I do have a few plugins Iris, Hive and sonnivox eighty eight that tend to spike things.

I am just wondering if a newer version of focusrite with newer drivers would work better.

Yep, @terrybritton, if you visit the Audio I/O window, you will soon crash with RMI. You don’t even have to make changes. My Behringer backup ASIO I/F gets numbers that rival the RME and doesn’t crash. The Behringer is not anywhere near as flexible as the Babyface and TotalMix, tho.

2 Likes

@RackedBrain which Behringer do you have? UMC404HD with the XLR outs.

@oddfact Yes, UMC404HD

1 Like

Steve

I have 2 Focusrite 2nd generation. interfaces. Never had a latency problem. I understood the 1st generation had terrible driver issues. I also made sure they were powered interfaces, as usb power only, tends to drop out as computer power needs change constantly.
What settings are you using on your Focusrite? Have you updated your drivers?

I have to say that it’s a first for me to hear of anyone having problems with RME drivers! I’ve never had a moment’s problem with any RME interface - and I’d hate to be without TotalMix. Have any of these problems been reported back to RME?

Here is where there was discussion before

Yes. As usual “it’s not our fault.” was the reply.

As those crashes only occur with cantabile they blame C3 of course. :disappointed_relieved:

Very odd. I’ve never experienced an RME driver crash, with Cantabile, or anything else! It’s the last place I’d look for fault in the event of a crash - more likely a plug-in IME. But I’ve never used the UFX, so…

Mine was Babyface. I think it’s the same driver.

I’m using a Motu Ultralite avb and have been pleased for the past two years. There are a lot of options that can work depending on what your “work flow”. Example #1. i had a friend tell me that the Presonus Quantum has the lowest latency of any Thunderbolt interface…but @ 192k??? Who records there?? Well I looked at the spec for 44.1k and its 2 ms…the same as the Motu. Also keep in mind that when talking about Round Trip Latency, those figures are for recording an analogue signal in, processing it and sending it back out to the speakers to be heard. Since we are dealing inside the “box” the figures should be half… Also the not known secret is that RME helped Motu with their drivers and thats another reason that both can claim Thunderbolt performance over USB…Good Luck

1 Like

I just bought a 4i4 3rd gen and it’s working fine. I like it’s size – fits on my laptop next to the mouse-pad during greenroom warm-up and I have quick access the volume knob. Power over USB is convenient too. Latency is about the same as my 6i6 2nd gen.

Interesting - I run a Fireface UFX on my studio machine and a 1st gen Babyface in my live rig. Had no problems I was aware of with Cantabile so far, but just tested this in 3613 on my studio machine, and created a crash.

  • Opened audio ports for the Fireface
  • Edited the metronome port - chose a different output on the Fireface, one with a higher port number (Analog 9 to ADAT 16)
  • Closed options
  • some seconds later, Cantabile crashes
  • Sent the error report to @brad

Now I went back to Cantabile and went through the same procedure, but chose an audio port with a lower number that was already used in the setup (went from ADAT 16 to Analog 9) - no crash. Looks like Cantabile and Fireface don’t get along when new audio channels get put into use.

I don’t think this happened when I installed Cantabile on this machine - feels like a bug that crept in later…

@brad: not sure if this is in line with what you have heard from other RME users?

Cheers,

Torsten

@Torsten I’ve never been able to pin this down. The symptom was “occasionally it would crash…eventually” and then it became “It WILL crash, even if you cancel out…just not in the next 10 seconds”

I saw Christian’s post and just decided to just work around it.It has caused me to not replace my studio machine’s ProSonus 1818SL with UFX.

Richard

Yep, this is consistent with other reported issues.

It seems the RME driver doesn’t like having the set of enabled channel buffers changed within the same process. I’ve code walked this several times and checked logs and Cantabile definitely seems to be doing the right thing as far as enabling/disabling the channels and it’s completely unloading and reloading the driver. Also the crash appears to not be on a thread created by Cantabile - which hints that this is something related to the driver.

I don’t have ab RME device here to test with so I’m relying on log and crash files for this.

In the meantime, if you’re having trouble getting channel assignments to stick because it keeps crashing, this should work:

  1. Start Cantabile
  2. Stop the Audio Engine
  3. Options -> Audio Ports -> make assignment changes
  4. Close Cantabile
  5. Start Cantabile, new assignments should take effect.

Brad

2 Likes