Unlocked states behave as if locked

Tags: #<Tag:0x00007f97803ea908>

I recently upgraded from an older version of Cantabile 3 to the most recent Cantabile 3 & 4, and suddenly now all my song states behave as though they’re always locked even when they’re not. The only way to update a state is now to do it manually (Ctrl-U) or to lock it and then unlock it. Is this an intentional change?

Here are steps to reproduce:

  1. Create a new song using Cantabile 3 or 4.

  2. Create two song states. Ensure both states are unlocked (the default).

  3. Create a route from any input to any output. Ensure the “Enabled” state behavior for the route is checked (the default).

  4. Disable the route in one state but not the other.

  5. Switch states a few times. Note that the route stays disabled in both states or stays enabled in both states instead of alternating as expected.

Have you got the enabled state behaviour box for the route checked?

P

Yes, see step 3 of my post.

Have you tried reproducing those steps on your installation of Cantabile? If so, what is the result?

Sorry, read your post quickly, whilst out and about. I’m not going to be in front of the computer until Monday now, will have a look then.

P

I can not reproduce this behaviour. No matter what I try, and whether I create the route first or the states first. But one thing I noticed, the “Enabled” state is not checked as default for me, but I might have set the default behaviour at some point to be off.

Thank you for checking, @TorstenH.

After many tests, I now think maybe the bug I’m seeing has something to do with loading a particular song into Cantabile. If I ever load that song, Cantabile never again auto-saves my states in any subsequently loaded song until I completely close Cantabile. Even freshly created songs won’t auto-save their states.

Since Cantabile auto-loads the last song on opening by default, the only way I can get states to auto-update is to first get out of that song, then close Cantabile, then start it again, and then be careful never to load that song again. Since the song in question is the template I use for all other songs I create, I guess I’m going to have to try to recreate that one from scratch and hope the bug doesn’t reappear.

1 Like

Okay, after yet more experiments I think I may have nailed it down. I think the problem only arises after executing a “Reset All” command (e.g., from the Tools menu or via a binding). After executing “Reset All”, all states stop auto-saving even if I create a new song or switch to a different song. Can anyone confirm this?

This has been fixed for the next build (4049) which should be up later in the week.

Wonderful! Thank you, @Brad!

1 Like