Translation file issue

Tags: #<Tag:0x00007f9794a6cbc8>

Hi @brad

There seems to be a problem with multibyte characters in multi-line text.

Multibyte characters immediately after a newline (’\n’) will not render correctly.
If you put a space (’ ') after the newline, it will render correctly.

It seems that the same phenomenon is occurring in Chinese.

Cheers
kohola

Hi @kohola

Thanks for reporting… can you send me an example piece of text along with a screen shot of how it’s appearing and another showing how it should appear.

Brad

Hi @brad

The bad encoded characters are displayed as square characters.
In Japan, this character is called To-Fu (processed soybean food). :smile:

dialog1
{
“phrase”: “If you’re having trouble restarting, you might like to use the following\noptions to disable normal startup functionality and regain control.”,
“translation”: “再起動に問題がある場合は次のオプションを使用して、通常の起動機能を無効にし\n制御を回復することをお勧めします。”
}


{
“phrase”: “These settings will be used as the defaults for new recording sets.\nTo set the default port configuration, use the \“Set as Default\”\ncommand in the recorder ports panel menu.”,
“translation”: "これらの設定は新しい録音セットの概定として使用されます。\n概定のポート設定を設定するには録音ポートパネルメニューの \"概定として設定\“を使用してください。”
}

Thanks for that. I’ll look into this but it might be next week before I get to it. Bear with me.