Time load jumps from 70% to 200% randomly


#1

Hi everybody,

I’m using C3 performer x64 with a Lenovo laptop i7-4510U @ 2.00Ghz and a RME Babyface Pro.
I’m experiencing randomly time load jumps from 60% to 200% which causes gliches.

Windows 10 is fully optimized for audio, latencyMon doesn’t show any problem.

It seems that every time time load jumps, windows writes something on the hard drive in c:$LogFile.

Please help me.

Best regards,

Sylvain


#2

Hi Sylvain,

Try going to Tools>Options>Diagnostics>Logging. You will see the check boxes for logging. Try unchecking all off them and click OK to get back up and see if same things happens. This way you can rule out the log file write as the culprit. I doubt it is, Remember to put it back like it was if it’s not causing a problem because later @brad might need the log files to be sent for a look see. It would be good if you could detail your Ram amount, Solid State Disk size if you have it and what loads are making the spike (what vst instruments are you loading?)

Dave


#3

Hello Dave,

I’ve unchecked all boxes in the logging options but it does change anything.

My laptop as 8 GB of RAM and a 512 Go SSD drive.

When I preload my play list, the memory consumption is 70%

I’m using 2 MIDI keyboards plugged in my laptop with a powered USB hub.

Each keyboard is routed to a different VST synthetiser : Diva for the first one, TyrellN6 for the second one. These VSTs are developped by U-He.

When I play on the first keyboard with Diva the time load is around 30% but can jump suddently to 120%
When I play on the second keyboard with TyrellN6 the time load is around 70-90% and can jump suddently to 120% or more too.

I know that the processor use is high with this configuration but I don’t understand why the time load is so instable.

Best regards,

Sylvain


#4

Hi Sylvain,

Diva might be your problem - it can be very hungry and unpredictable, even on a machine with a good processor like yours.

You could try running Diva within jBridge using Performance Mode. I do that with various very resource-hungry plugins (Diva, Serum notably), and it can dramatically smooth off your resource using and keep it under 100%. The only drawback is that you lose visibility of the load being incurred separately for Diva. It’s worth a try anyway.

Another thing - make sure you have wifi and Bluetooth disabled. They can cause big load spikes.

Neil


#5

Hi Neil,

Tell me if I’m wrong, but jBridge is necessary with 32 bits VSTs in cantabile 64 bits.
Do you mean I should use the 32 bit version of Diva with jBridge ?

Sylvain


#6

Yes, that’s the general intent of jBridge. So yes, you can use the 32-bit version of Diva with jBridge, which is what I do, or you might be able to convince jBridge to bridge to the x64 version, although it might put up some resistance. I don’t think running the 32-bit version would be a problem though, as it’ll be running in its own separate process / memory space.

Neil


#7

Just adding a thought @Neil and @lasyl , you could just adjust Diva’s ‘Accuracy’ control to see if Diva is the primary culprit.

Dave


#8

That, and I gather you have to be very picky about matching Diva’s Multicore setting to the multicore support in Cantabile. Try toggling that and see what happens.


#9

Hi,

I think I’ve found the solution : the multi threading option in Diva was disabled.

It’s working now :smiley:

Thanks a lot for your answers

Have a nice day.