There's got to be a bug in C3 and it's bluetooth operation?

Been trying now for near a day to get Cantabile 3 to even “see” a connected and working (in other apps) bluetooth controller. It refuses point blank to do so. I did just do the latest update so I’m not sure if that’s it or not, but something is not working.

Previously as soon as I started C3 the blue paired light would come on on the device, now nothing!

And further, when trying to create an assignment for the Input port created for the controller, the only option I get is the iConnect MIDI 2+ or Onscreen Keyboard?

Hi Dennis

Update of C3, or your bluetooth? If was C3, you can revert to previous version that worked for you, just to check out C3. Your bluetooth device would surely need a driver. You could re-install the bluetooth device again. I am no where near an expert on this, but it just makes sense to use process of elimination. I personally stay away from bluetooth devices, just because of these type of problems, and dropouts, and latency. Hope you get it working again.



Thanks Corky. I will try a reversion.

1 Like

Cantabile currently doesn’t support bluetooth midi devices. (It’s mostly implemented but some technical issues are preventing me from releasing it).


Thanks Brad - I was sure I was using this Korg nanokontrol before with C3??? But if it doesn’t support it I guess it wasn’t…

Not via bluetooth you wouldn’t have been… unless you were using some intermediate virtual midi cable and something like MIDIBerry.

yeah might have been that, now I think of it - new problem is I have gone back to all USB and C3 is not seeing the USB Korg Nano Kontrol either? Trying to create a MIDI input port and it does not show in the list?

I’d need to see a debug log:

  1. Close Cantabile
  2. Make sure the device is plugged in.
  3. Start Cantabile
  4. From Tools menu, choose Open Settings Folder.
  5. Close Cantabile

From the folder opened in step 4 send me a copy of log.txt, log-previous.txt and settings.json and I’ll check it out.

Sent Brad…but just discovered the weirdest thing after some further testing - the nano is getting powered up by USB, windows device manager is seeing it as a valid sound controller, however neither C3 or Sonar was actually seeing it at all.

Tried it in another port and voila it works! So for some reason the USB port was supplying power but not allowing data transfer, weird!!!

1 Like

Hi @pax-eterna

Yeah, I just had a look at the files you sent.

Cantabile’s MIDI device scan was showing the “Microsoft GS Wavetable Synth” as the only available MIDI device so this was obviously a problem at the windows level, and not Cantabile.

Anyway, glad you got it sorted…