Suggestion - Disable window focus on Song/State Change

Recently I’ve started viewing PDFs of the songs I’m playing, first in Acrobat, then in Drawbridge (Surface annotation app). Now I’m trying out MusicReader, which is designed to be a sheet music viewer.

I’ve set up some midi footswitches to toggle between songs and states, which makes switching to the next way easier. However, every time I switch to the next song, Cantabile takes screen focus, which means I have to manually switch back to my sheet music app, and advance to the next page. It would be very helpful if there was an option to disable the window focus when changing songs/states. It would still be nice to have the overlay popup of the next song that is loaded, but I don’t want it to switch focus from other apps.

Hey Andrew,
What OS are you running? There is a free windows tool that might help fix this it’s here :

Hi Brad!

Along the same lines of window focus, is there a way to bring Cantabile to be on top of the VST plugins when it is selected (i.e. I click on the UI)?

When I have several plugins open, I can’t see controls in the UI unless I manually drag each one out of the way. That’s a lot of dragging.

Perhaps a “Main Window On Top” option in the View menu? Also, a Ctrl-S hotkey to save Song would be great. I’m a compulsive song saver as well.


I’m on Windows 10 x64 on my Surface Pro 4.

That’s a cool looking app, but I’d like to reduce the number “things” running on my computer at the same time for better CPU performance. :wink:

I also don’t want the sheet music on top all the time, I just don’t want Cantabile popping up when I hit a footswitch. Deskpins would add an extra step to “unpin” the window before switching back to Cantabile.

Hrm… I wasn’t aware that it did that so I’d need to look into it. Do you have any plugin editors open? (Wondering if this is being caused by one a plugin GUI taking focus for some reason).

Ctrl+S will save the current song or rack that’s on view. (If it’s not, check your key bindings in Options → Hot Keys)

Nope, just the main Cantabile window. I have a pair of bindings set to footswitches that trigger the next/previous song/state. I tried both instant and delayed, and they both pull window focus away from other applications when they are triggered.

Ok that’s an issue then. I’ll look into it when I get back from hols.

Logged it

1 Like

Brad, on my Win7 laptop screen especially, open VSTs hide most of the main UI with no way to bring it on top. Did you have any ideas on how to improve this?


This was a deliberate change over Cantabile 2 where the main window can move in-front of other popups. The reason for the change was that it clogs up the task bar and it’s very easy to lose popups in the background.

While I understand the desire to have popups in the background, I think it’s better the way it is now, but interested in hearing what others think.


I’ve been trying to reproduce this problem but haven’t found any issues. I’ve tried delayed and instant next/previous state switching, song switching by program number and a couple of other variations and none of these seem to cause Cantabile to move to the foreground or to take focus. I also tried with a couple of different plugin editors open and that worked fine too.

So there must be something else in your setup causing this, but I’m really not sure what it might be. Do you have any triggers configured, running external scripts, anything else?