Stuck Notes - SOLVED

Hi All,

Thanks to everyone on my recent post for all your suggestions and help. Somebody mentioned the possibility of conflicting midi signals causing the problem so i looked at the bindings section for each song. Over the past year i have been experimenting with various keyboards and control surfaces and have been assigning volume bindings on them all as well as other functions, when i looked i was horrified to see up to 5 or 6 redundant volume bindings for the various items all on the same midi channel. I suspect as i am sustaining notes/chords and adjusting volumes during gigs these are conflicting and giving me stuck chords?.
I deleted all but the current bindings on each song and went the whole gig last night with no stuck chords at all :slight_smile: , have a double header of gigs next weekend to prove it but i really think ive found my problem :+1: , thanks again to everyone for your help, will keep you posted ,



That I am sure is a HUGE relief!!! :slight_smile:


Definitely Terry, can start to relax now :slight_smile:

1 Like

Hi Steve,

I hope that was the cause, but I’m a little skeptical. Volume bindings shouldn’t really affect held notes. A turned down volume might hide a held note but otherwise can’t really see how they’re related.

Fingers crossed…


Hi Brad, could have just been lucky last time out I guess. Have you got any ideas or best guesses ?

Hi all, well Brad you were right unfortunately :frowning:, on the third gig since i thought i had sorted this stuck chords problem its happened again…twice !!! . Not sure where to go now, any ideas people ?

You need to capture the MIDI when it happens in order to diagnose it, either using the MIDI monitor or Cantabile’s MIDI recording feature. I don’t think there’s any other way apart from trial and error.


Hi Neil, can I run the midi record feature in Cantabile while I’m playing the gig?, Can you tell me where to find it please


I had a similar problem with my Kronos, which was driving me mad and I was blaming the Kronos for stuck notes.

I had to eat humble pie, as it was the fact that I was using the MIDI CC for sustain to trigger our smoke machine (via DMXIS mapping from MIDI to a DMX channel), so if I happened to press the pedal on my FC300 mapped to that CC whilst I was playing notes on the Kronos then the notes were stuck. I didn’t have this problem with my older rig and had been using that CC for years!

The other problem I have had in my studio with stuck notes was with my MOTU MIDIEXPRESS 128. If it is plugged into a USB 3 port then I get all sorts of problems with stuck notes, but it is fine in a USB 2 port. I have had other problems with legacy USB devices. My old Focusrite Saffire would only work correctly in a USB 2 port. If it was in USB 2 then it when I used to shut Cantabile 2 down, the audio driver would not be released - but it was fine in a USB 2 port.

If I were you, I would monitor the MIDI activity going into your computer using something like MIDIOX so you can see what is happening before MIDI gets to Cantabile, and then use the internal diagnostics if you need to go deeper.

Hopefully my experience may give you some pointers to check.

1 Like

Hi Derek, thanks for sharing that with me, funnily enough i have both my keyboards going through a USB 3 hub before going into the laptop. Earlier on i noticed it and wondered if that might have been causing it so i have now plugged them in direct. After what youve just told me hopefully that might do it (fingers crossed),

Thanks, Steve

To the left of the “Set List” tab is a “Recording” tab. You select what you wish recorded below by ticking the appropriate boxes. It can even be set to auto-start! (In Preferences/Recording there are useful settings for auto-naming format, etc.)


1 Like

Hi, Steve

Yes it can depend on the age of the interfaces/hubs on how backwards compatible they are. A lot of audio interface manufacturers still design for USB 2 as that gives them all of the bandwidth that they need.

The problem now is getting enough USB 2 ports on a computer as the world moves on. My DMXIS USB I/F and MIDISPORT 2x2 are fine on USB 3, but certain things do not like it and you need USB 2 (or a compatible USB 2 hub into a USB 3 port). In my Studio, my Nord G2 Engine seems to choke on USB 3 as does the MOTU MIDI EXPRESS 128 and also my Belkin Wireless adapter. So you need to try and see and beware that despite the USB 3 claim of full backwards compatibility that it seems to be hot and miss.


1 Like

Hi all, bit of an update for you. I think i have finally solved my problem, 3 gigs now and counting with no stuck chords/notes :). Following on from Derek’s and others ideas on here i made a few changes to my set up. I changed my keyboard from a Nektar P6 to an M-Audio Axiom Air (which by the way also had stuck chords issues but it was the only other keyboard i had), changed my USB 3 hub and all my USB 3 leads to a powered USB 2 hub and leads, and powered up my keyboards with separate 9v power supplies.

I had wondered if it might have been a power issue so i decided to get external power supplies for the keys. Although my USB 3 hub was powered i decided to change to a powered USB 2 hub after previous comments, and some comments made on the troubleshooting page of the Nektar website.

As i have made a few changes at once i cant be totally sure whats cured it, but my gut feeling is probably that the keys or connections were probably just not getting enough power to deal with all the things going on at the same time.

Anyway, thanks again to all who gave me such good suggestions and ideas,



Glad you solved the issue.

I’d take a guess that it was a USB 2 versus USB 3 issue.

I forgot to say that I did have a problem moving to the Focusrite Scarlett 2i4.My old Focusrite Saffire 6 interface was quite happy being bus powered from my laptop, but the new 2i4 must be drawing more power and couldn’t be powered from the laptop. I just had a load of flashing lights on the IF and “plug and pray” on the USB port continually connecting and disconnecting the interface. Switching to a powered hub solved that.