Stream Deck Choose Song/State buttons not working?

@brad I’m finding that the ‘Choose Song’ and ‘Choose State’ buttons do nothing when pressed. IIRC they used to open a full page of Songs/States? Maybe a folder action?

Or am I remembering incorrectly?

I could create a folder instead, but I liked having the current Song/State displayed on these buttons.

Another interesting (though far less important) bug? If I press my 31, 32 and 34 cue buttons simultaneously Cantabile triggers playback! No other cue button combination does this. Not important, but maybe a sign of something amiss?

Thanks for reporting. It was working last time I checked. I’ll look into tomorrow (don’t have my StreamDeck with me right now).

That’s weird. I’ll need more info, are these StreamDeck buttons you’re referring to? How are they configured?


Yes, Stream Deck buttons.
SD Cantabile 04
Similar for the others: CC31-34

Thanks @brad. No urgency with this stuff.

Hi @The_Elf,

I just tested the Choose Song functionality here and it seems to be working fine for me. One thing to be aware of, for this to work you need to have the “Cantabile Choose Song” Stream Deck profile available:

This profile is normally installed when you install the plugin, but if you answered No to install it when prompted it might be missing.

Does this help?


I just tried this and didn’t see this behaviour. This is almost certainly related to a binding you have configured somewhere. If you can narrow it down and let me know how to reproduce it I can either explain it, or fix it.

I do have both of those profiles. Oddly, the buttons work on the 3x5 SD, but not on the XL. May be worth uninstalling and re-installing the SD plug-in?

And I was getting the 31/32/34 behaviour with no bindings in place - I even disabled all my Background Rack bindings. But maybe there’s something getting past me, I’ll do some more digging later today.

I uninstalled and re-installed the Cantabile plug-in for Stream Deck. This cured the Song and State page problem. Strange, but I think this one is resolved.

But I just tried creating a completely empty Song (i.e. no bindings), and switching off all Background Rack bindings… my 31/32/34 ‘cue’ buttons still trigger play. I’m stumped by this one. It only happens when I press all three buttons simultaneously, and it happens with each button in either toggle state.

This cue button problem does not happen on the SD 3x5, but does on the SD XL 4x8 - same laptop.

The more I dig…

I noticed that my ‘TALK’ button was not displaying correctly. It was ignoring the active and inactive states - only displaying the title. It did work functionally, though.

I copied one of my ‘Cue’ buttons and replaced my ‘Talk’ button and edited the controller number. This then worked perfectly.

Definitely strange things going on. Again, this all on my SD XL. I’m wondering if something odd is going on with buttons outside of the 3x5 button matrix range?

Hi @The_Elf,

Anything in your background rack that might be triggering this? For a really clean setup you could create a separate blank configuration.

fwiw: I was testing with StreamDeck XL too.


I don’t want to risk breaking my rig, so I will have to pass on that - there’s too much potential for disaster.

I can say that ALL of my Background Rack bindings are disabled and the Song is blank.

This is a pretty ‘edge case’ scenario anyway. I’m going to leave well alone.