Strange performance impact of Cantabile Media Player

Here’s an interesting one for @brad:

When I use a media player for backing tracks to rehearse to, it seems to affect the time load of other plugins in my song. Example: I have Blue 3 running at 4% average, around 6-7% maximum. I start playback of a simple MP3 file, and suddenly Blue3 moves to 5% avg, 11% max. This happens across all loaded plugins, so a song that plays nicely at 22% average, 30% maximum suddenly jumps up to 31% average and 55% maximum.

I can’t imagine that playing a simple mp3 file should be such a strain? A simple VST mp3 player plugin that I tested in the same song doesn’t show this behavior; it plays the file, and the other plugins aren’t affected.

Could it be that the media player has some kind of thread priority that throttles the other plugins?

I would move my playbacks to the VST player plugin, but unfortunately it’s not well controllable via MIDI or VST parameters, so can’t use it as a replacement.

@brad: would be great if you could look at that behavior of the Media Player - it’s not good to have media playback affect other plugins’ load that much…



1 Like

Out of interest which version is doing this? Thanks :slight_smile:


Currently running 4063 on my Live Cube. But I’ve experienced this behavior for quite a while now…

1 Like

I’ve seen that too… :confused::confused::confused:Since à long time ago.

Just did a bit of testing with a sampler vst instead of media player - I used sfizz, a free sforzando sampler that works with MP3 sources; simply loaded the MP3 files as samples and sent a note-on to play, note-off to stop.

A bit clunky, but works. And no time load impact on the other plugins when using sfizz, so there must be something funky going on with Cantabile’s media player hogging the threads…

Hi @Torsten,

That does seem excessive. I’ve got some other perf issues to investigate too. I’m a bit busy the next couple of days, but I’ll try to get to it before the end of the week. (ping me if you don’t hear back).


1 Like

If it helps, I’ve noticed a reasonable jump in time load in projects with media players in as well. Nothing that’s causing glitching but a larger than expected increase in load …


1 Like

Hi @Torsten,

I’ve had a quick look at this and not seeing anything remarkable here.

My quick test was 4 instances of Blue + a simple mp3 file. Regardless of mp3 playing or not, load on each plugin instance is about 4-5%. I also tried at different sample rates since sample rate conversion is the most CPU intensive part of playing mp3 file.

So some questions:

  1. Does this happen with .wav files as well as .mp3 files?
  2. Are the mp3 files at the same sample rate as your audio driver?
  3. Does changing sample rate conversion quality in Options -> Audio Engine make a difference?
  4. Are you running with Windows high performance power plan?


Yes, just converted one of the mp3 to wav - same performance impact

Yes, all 44.1

no, tried all options; typically is “Good” in my settings, but changing to “Fast” doesn’t help (didn’t expect it since no sample rate conversion necessary :wink: )

of course…

Could be a bit more complexity is needed to reproduce - my songs typically are around 25-30 plugins in 15-20 racks with complex routing and quite a bit going on in the Background Rack

Again, a VST media player (vstPlayer – Mirax Labs) playing the same MP3 files doesn’t produce this performance issue, so I assume there’s nothing specially crazy about either my files or my setup.

I am still suspecing that the Cantabile media player runs at a different thread priority and takes resources away from plugin processing when it shouldn’t strictly be necessary - or something similar, with media players being treated differently from plugins…



Hi Torsten,

Still trying to reproduce this and figure out what’s going on. Could I get you to create a detailed profile log for me:

  1. Start Cantabile
  2. Tools -> Options -> Diagnostics
  3. Audo Engine Profiling -> Detail Level -> Over the Top
  4. Close Options
  5. Reproduce the problems, start media player, wait 5 seconds, stop media player, wait 5 seconds (repeat that a couple of times perhaps).
  6. View -> Profiler
  7. Menu at top right -> Save.

Send me the saved profile and we’ll hope that provides some clues.


Mail should be in your inbox!

Was this ever reproduced or resolved?

Yes, the issue was reproduced and resolved. As far as I recall, there was an issue with the re-drawing of the waveform view.

1 Like