Strange Numeric Keypad Actions


#1

I just updated to the latest build (3558) and have been noticing some strange keypad actions.

I use a USB numeric keypad to load songs from my setlist. I use a program called AutoHotkey to map the Tab key to “S”. This allows me to punch in a number, and press tab to load the song.

Now… if I press 4 the setlist decrements one song, and 6 increments one song. The other keys work fine. I do not see either of those listed in the hotkeys section so… what gives?

I tested it outside of Cantabile (notepad) and everything works fine.

Thanks,

Rick


#2

Does it do it with the Num Lock on? I ask because 4 is decrement arrow and 6 is increment arrow on standard PC Numeric pad. The Num lock should force the number instead of the arrow command.


#3

Dave,

I’m pretty sure I tried it both ways, but just to make sure… I’ll give it another shot tonight.

Rick


#4

Ok… problem exists numlock on or off. Only in Cantabile. Build 3558 x64. I tried typing in Notepad, and everything works the way you would expect. Numlock off… 4 and 6 are left and right. Numlock on, and I get numbers.

In Cantabile, 4 and 6 only increment or decrement with Numlock in either state.

Does anyone know of a diagnostic keylogger?

Thanks,

Rick


#5

Hi,

Dumb Question. Have you checked locale and keymap settings just in case Windoze has decided to change them for you (has happened to me before). Unlikely, but worth ruling out.

If they are printable keys then you could just try opening notepad and typing to see what you get to do some “logging”.

Cheers
Derek


#6

I haven’t checked the Win settings, but I did some rudimentary checking with notepad. I rambled in about 5 lines of BS, and with the Numlock on, I get numbers. With it off, the cursor shuffles around my document the way you would expect.

The really weird thing is that with the Numlock on, only the 4 and 6 are acting odd. The 8 and 2 are fine.

If no one else is seeing a problem in build 3558 x64, I’m going to give something else a shot. I already use this program called AutoHotKeys to map the TAB key to ‘S’. That way I can use a USB numeric keypad to select songs. AutoHotKey can see if you pressed a number key on the main keyboard, or the numeric keypad.

We’ll see!

Thanks for the help!

Rick


#7

Did you try the one built into Cantabile it’s pretty good for tracking down stuff

here’s the console window

Set everything back to previous settings when done. Might help track it down.

Dave


#8

Hi @RickRepsher

This is almost certainly my fault… but I’ll need to look into it to figure out why.

Build 3558 includes a newer build of GuiKit (the UI library Cantabile is built upon) which has been undergoing a lot of changes to try and normalize keyboard behaviour across Windows and OSX. My guess is I’ve messed up something in the process. I did test it alot, but keyboard handling is way more complicated that anyone would guess.

If you need this fixed asap then best bet will be to go back to an earlier build. I’ll post back here when fixed.

Brad


#9

First off, thanks for all of the suggestions. Although they didn’t solve my problem, I learned some new things in the process.

I found a way around the issue. By using this AutoHotKey program, I grabbed the Numpad4 and Numpad6 and passed just 4 and 6.

Thanks again!

Rick


#10

Hi Rick,

I’ve taken another look at this today and haven’t been able to reproduce any issues on my end in either 3558 or the next build. Given the number of upcoming changes in GuiKit related to keyboard I’m going to set this aside and ask you to try it in the in the next build.

If it persists on your machine I’m going to have to do a deeper dive to figure it out.

Brad


#11

Brad,

Thanks for the update. I actually dropped back to 3543. I was what was previously working on my machine.

I actually found a few weird things.

  • When selecting channels for the MIDI ins, if I click on, let’s say channel 8, all of the other channels are selected, so… 1-7, 9-16. I cannot unselect it without going “down the line” and clicking on each channel.

  • Text boxes in random places do not allow you to type in them.

I’ll try the new one when you release it.

Thanks!

Rick


#12

Just out of interest, is this everyone or just you?


#13

I don’t know, but I can say that Cantabile is the only place I am seeing the issues. I’ve tried two text editors, Word, and Excel. They all seem to work fine.

And when I jumped back to V3543, the problem went away.

Rick


#14

I’m curious to see if anyone else replicates it… I don’t have that build)


#15

New build is up now… let me know if these problems still happen.


#16

Brad,

Is this a new build of 3558?

Thanks,

Rick


#17

I also have some kind of “trouble” with it.

Sometimes I use the quick-access menu to set values of gain-sliders. It’s not possible to enter values with the numpad, because although the numbers are overtaken by Cantabile the arrows are also triggered. So f.e. if I press 6, Cantabile takes 6 into the quick-access menu but also go to the right with the cursor. That means that the gain-slider looses focus in that case.

Tested with the newest build.


#18

LOL. Well that’s super frustrating. Will fix for the next build.


#19

Fixed in 3561 available now.


#20

Thanks Brad! I cannot test this weekend, but I’ll load it next week and report back!

Rick