Sound carryover from previous state?

Is it possible to switch to a new state, and have the last key played from the previous state continue to sound for the length of time that sound is set to sustain? It seems that neither Instant nor Delayed state switching will do this because when I play the first note of the new state, the previous state’s note is abruptly cut off.

That will only happen if you change plugin settings, where the plugin cuts abruptly (eg plugin patch change), or if you change audio routine on the output of a plugin. To avoid abrupt cut off and have the ability to keep held/sustained notes sounding over state changes, you need to switch MIDI routing. For example, imagine a song with two parts, one piano with Ivory, another a synth patch with Omnisphere. Have two MIDI routes from your controller keyboard, one to Ivory (route only enabled in state 1), and one to Omnisphere (route only enabled in state 2). But both plugins are enabled in both states. When you change from state 1 to 2, any held/sustained piano notes will continue to sound from the plugin it was routed to, and the MIDI note off or sustain release control will still go to Ivory when it eventually happens. But any newly-played notes after the state change will route to Omnisphere, just as you’d expect.

This impacts a little on how you set up songs - typically you want to have all the plugins you need for a song enabled throughout, and do your sound switching by enabling/disabling routes. If you need to do patch changes on plugins (or racks), try not to do them at times when you need a smooth state change (or held keys); you may need two instances of the plugin/rack for this, if you need held notes on one sound and new notes on a new sound, on the same plugin.

Hope that makes sense.



thanks, Neil. That does make sense. I never thought about handling it using midi routing. I’ll try it out.

Great answer Neil. I think you deserve the “@Torsten award for posts that should be sticky”


Great explanation!

I’ve not done this so often - I don’t need sound carry over that frequently in my setups - but your post has encouraged me to experiment more with state-dependent routes. At present I simply turn racks on or off per state and leave routes as they are. Sometimes I have state-dependent routes to change controller assignments (a separate route that converts aftertouch to modulation that gets re-assigned per state…)

One similar concept is around effect carryover (especially reverb / delay tails). If you need to make sure the effect goes on whilst at the same time you change the sound feeding the effect (e.g. a monster delay on your guitar, but then you change from hi-gain to clean on your amp plugin…), it helps to keep the effects separate from your sound source. I.e. don’t use the delay built into your amp sim, but use a separate plugin. This way, you can let the delay ring on at the end of your solo and switch back to crunch sound with only a bit of room.

If need be, you may even need two or three delays to deal with different delay settings between song sections. I’ve just had a nice editing session creating the guitar sounds for “still haven’t found…” (U2) and actually used 3 delays and 2 reverbs to make sure I have no ugly reverb or delay cutoffs. And I removed all the delay and reverb blocks in S-Gear so I could be extremely flexible in routing my guitar to the various effects on a state-by-state basis. You don’t really want to see the routing section - really messy :blush: :wink:



1 Like

I’ve finally gotten around to trying this out and I must be doing something incorrectly. I have all plugins activated on each state.I’m controlling plugin activation by changing check marks to X’s where I don’t want the plugin to sound on a particular state. When I switch to the new state, the previous state’s sound cuts off abruptly. Is this where I need to make the changes or do I need to go into the Control column and make some changes in the midi channels section?

What you’re doing is correct - two things to check:

  1. Are your plugins changing patch when you change song state? If so, it may be that the plugins themselves are muting the sound, and not holding onto held notes; many plugins mute the sound on patch changes. If you need consecutive song states to have different patches on your plugins, the trick is to have multiple instances of the plugins, so you’re not switching patch on the important transitions.

  2. Make sure the audio routes out of your plugins are all enabled on all your song states - it might simply be that when you change song state, you’re muting the output because the audio route is disabled.

As an aside, you can actually re-use MIDI routes, as an alternative to enabling/disabling. So for example if you’re playing two sounds for song state A, have two active routes to your plugins, and then for the next song state, you can change the MIDI route target to a different plugin, change the channel mapping, keyboard ranges etc., to point to your next sounds, effectively re-using the same routes. I find that makes it a lot more manageable when you have lots of sounds/states. And Cantabile is still clever enough to deal with the note-off messages, so you don’t get stuck notes.



That was it! Some of the audio routes were disabled. Thanks again.

1 Like

Thanks Neil, good tip.