Song stopping same spot

I have two songs that stop at the same time before they are supposed to. I’ve checked midi messages and even tried changing them. I’m running 5 media players 4 for wave files and 1 for midi control of harmonizer, guitar processor, and lights. Any ideas?

Hi. Dumb question, but are the media files all the same length? I have songs where a MIDI file is the master and audio files are the slave tracks, and I need to make sure the MIDI file is the same length as the audio tracks, because if it finishes before them it will stop the transport for all tracks.

I think i found the issue, the midi file does end sooner than the audio tracks, actually the midi track controlling the lights. I just didnt know it would stop playing, as i thought i would somehow have to add an end song message for that to occur.

Grab the “Ending” indicator on the MIDI track Timeline and drag it out to where you need the actual stop point of the song to be. Click the “hamburger” icon and select “Zoom to Play Range”. Then click “Save Play Range” and you should be good to go. Your issue happened to me a lot when I first started using multiple Media Players for Audio/MIDI tracks.

Doug

2 Likes

I didn’t know where to find the “ending” indicator but I extended the lighting track and that fixed it.

Thanks

See the two marks at the Left/Right of the Timeline on the attached image. One the LEFT is the START POINT and the RIGHT is the END POINT. Drag the “Corner” shape to adjust the Where the Playback starts and ends (you can drag the ENDPOINT into “dead Air”.

3 Likes

Well you live and learn. I never new you could do that! I have been doing it by ensuring that the last light cue note (for DMXIS) in the MIDI file is repeated just the last piece of audio. This was my fix in Cantabile 2 days of course.

I understand. :slight_smile:

I use the Drum Kit MIDI track as my “Clock” (Master) and used to have issues if the drum part ended before the actual end of the song. My fix, at the time, was to add a light ride cymbal on the last beat. I then discovered that I could move the Timeline “End” line. Also, I’ll move IN the “Start” line if I mixed in a Plugin “pop” at the beginning of my Performance track to avoid the noise.

Doug

Thanks I’ve never been at this view.

Maybe you could tell me something about dmx lights. I am running a few dmx lights and using a controller that has midi input ( a cheap one), I did put a terminator at the last one, I find that I have to shorten the duration of the notes for the lights and make sure notes don’t overlap. I’m thinking that the lights must need time to switch off before changing color. Is there an easy way to program dmx lights?

Doug,

Sorry, but I’m an “old school” guy. The only way I know how to control lighting is with a wall switch. :joy:

Doug

1 Like

Sorry I was asking other fellow, Derek he had mentioned that he used cantabile for lights.

Hi, if you check the guides page, Brad has linked to a few guides I have written including how I use Cantabile and DMXIS together

This recent thread also has a lot of useful info.

My mistake, I apologize. I was being humorous without paying attention to who you were replying to.

I assume what you are describing is running a MIDI cable to a DMX controller (the kind with sliders to control lights on specific channels), which is different from the DMXIS systems that have been discussed on other threads. Based on what you’ve described, i think i can elucidate what’s going on.

The MIDI description for the controller i have (probably similar to yours) states that it only responds to MIDI note on commands. Unfortunately, a note off command can look like a note on command with a velocity of 0 – thus the controller may not distinguish between note on and note off (actually, the note off command is not even needed - at best it will do nothing, and at worst it will be interpreted the same as a note on). So what happens, worst case with notes overlapping, is that the note off for the previous note can override the current note on.

So you have two options: either somehow remove the note off commands from your MIDI stream, or, as you’ve noted, shorten the duration of the notes as much as possible to guarantee no overlap.

Hope this is helpful (even if it turns out to be not totally correct),
– Jimbo

Thanks for the info I will play around with this it may be less time consuming to edit out the note off commands, rather than shortening every note

Well I found a use for the piano roll view, somewhat quicker to fix the light durations than the event view list :grinning: