Some VST instrument plugins not detected or throwing an error


I have Cantabile Solo version 3 (x64) latest build.

  1. For some daft reason my Gforce M-Tron PRO 2 (x64) and Virtual Strings (x64) plugins are not detected. They are in the same folder structure as my Gforce IMPOsCar2 (x64) and Minimonsta (x64) plugins which get detected OK.

  2. Linplug SaxLab 2 (latest build) throws an error on VST plugin scan ‘Run-time Check Failure #1 - A cast to a smaller data type has caused a loss of data…’. If I click ignore it carries on scanning but omits SaxLab 2 from the list. I have downloaded the latest version from Linplug.

I have Sonar Platinum on the same PC and they are fine in that. Weird!

Hi @capt_henry

Thanks for reporting this. Could you send me a copy of your log file.

  1. Start Cantabile
  2. From the Tools menu, choose Scan Plugin Folders (Full)
  3. Let the scan run
  4. From the Tools menu, choose Open Settings Folder.
  5. Close Cantabile

From the folder displayed in step 4, locate the file log.txt, log-previous.txt, settings.json, plugins.json and plugins.cache.json and I’ll check it out.


Hi Brad

I have zipped up those files but I get a ‘new users cannot upload attachments’ message copying the zip file to the reply.

I’ve attached them in reply to the email sent to me about this post.


@capt_henry Sorry, didn’t get that email. Not sure where replies to notifications from the forum would go - probably to nowhere.

Can you please resend them to Thanks


I have been having intermittent problems with SaxLab2 since I started using it several months ago- same error message as Capt Henry. The error stopped for about a month after I installed the next experimental build of Cantabile (can’t remember which one). Now it’s back. It seems to happen most consistently if it’s included in a song which is loaded in a setlist. @capt_henry , are you getting the error when loading it within a song alone, within a setlist or both?

Last night at band practice I had to go through each song which includes SaxLab2 and delete the plugin, in order for my setlist to open.

This morning I created a new test setlist which included several songs with SaxLab. Loaded the set list, closed Cantabile, reloaded SetList 3 x, no problems. Then I re-added Saxlab to the songs in the problem setlist from last night’s practice. The first time it loaded OK, the second time, the error message popped up.

Very frustrating. Its intermittent occurrence makes it difficult to problem-solve, but until I do the plugin can’t be trusted.

Hi @capt_henry -

did you email the logs to me? I haven’t seen them.

@LeesKeys - I’ve pinged LinPlug again about this. It’s really strange that you’re getting this error since its only supposed to happen in a debug build - which you shouldn’t have. I suspect a conflict with another plugin that’s loading a debug version of the runtime library, but it’s just a guess.

One thing that might be worth trying is hitting Retry - Cantabile should (might) crash and offer to send a crash report. If so, please do that - I might be able to glean some clues from it.

Also, could you do a search through your plugin folder for a file named MSVCRTD.DLL and let me know if it exists. If so, try renaming it to something else and see which (if any) plugins in your song/set list fail to load.


Exactly the same error I get. I’m a new user of Cantabile and only building up songs at the moment. This error crept in I think on the last update.

Hi @capt_henry

I’d be very surprised if this is related to the Cantabile build - the old builds are all available here if you’d like to go back and check.


Hi Brad

Yes I did on the 14th (Monday) to from the email address associated with my forum account. The files were in a ZIP file named Cantabile

No bounce back error so it must have been delivered or in a spam folder. Why not enable me to upload files on the forum?

By the way I was on v3154, updated today to v3158. When I click on retry on Saxlab 2 error window two or more times it continues without error now, but the plugin is not in the list, neither are the othes I mentioned.

Checked for MSVCRTD.DLL in the plugin folders with a windows search but no match.

Hey Guys,

I just heard back from Linplug with this reply about the SaxLab2 problem:

There was apparently a broken link on our website and people git the 2.2.0 debug version, we’ve updated the link to the 2.2.1 release version. The ones affected may contact us directly to obtain just a 2.2.1 dll so they not need to download the full installer again.

I hope this helps!

1 Like

Yes, that solved the SaxLab 2 problem and Gforce String Machine problem for me. The new SaxLab version is available on the LinPlug website.

Only last weird issue was with M-Tron Pro 2. Still didn’t show up until I re-installed M-Tron Pro 2, then all OK.

Thanks, you are a star!


1 Like

thanks, I will be downloading the new version of SaxLab :grin:

And that seems to have taken care of it