Solved: Why has the name of my output port changed?


I’m faced with a problem concerning route selection under Output Ports. Previously, when I added a new instrument, let’s say Omnisphere, and then clicked on “Add Route”, I could select “Stereo Out” as my output port, which I would then map to my preferred output port on my Scarlett interface, as can be seen in this screenshot with a previously added instance of Omnisphere.

But now, if I want to add a new Omnisphere instance to a song, Cantabile no longer offers me “Stereo Out” as the output port; instead, its let’s me choose between “Stereo Out 1” though “Stereo Out 8”, as can bee seen in the following screenshot.

I probably made some change to my settings somewhere without realising it, although I do not remember making any changes, and I certainly have not changed my output ports in Cantabile’s Tools > Options menu. Does anyone have any idea what I am doing wrong and how I can get my good old “Stereo Out” back?


It’s just because the Omnisphere plugin has 8 separate stereo outputs, that you can route different sounds to internally (primarily in Omnisphere’s multi mode). Unless you’ve adjusted internal routing in Omnisphere, I believe you’ll find your sound on Stereo Out 1. Don’t worry, you didn’t do anything wrong, this is perfectly normal :slight_smile:



Thanks for your quick response, @Neil_Durant. So this has happened because I started using Omnishere’s multi mode, then? And it will happen even if and I add Omnisphere to a song but don’t use the multi mode (because that is what’s happening)?

In that case, I have a follow-up problem/question: I am using the media player to play certain pre-recorded midi tracks, but how do I get the signal from the media player to play though Omnisphere. Here is a screenshot of my routing:


Hmm, actually I thought Omnisphere just by default had 8 stereo outputs, regardless of whether you use multi mode or not, but I could be wrong there. Either way, it’s perfectly normal - Cantabile detects how many inputs/outputs a plugin provides, and gives you options to attach routes to any/all of them.

When you say “how do I get the signal from the media player”, do you mean your MIDI ? What you have set up in your screen shot looks correct. If that’s not working, perhaps it’s because the MIDI played by the media player is on different MIDI channels, that Omnisphere is not set up to play on? You can check this using Cantabile’s MIDI monitor.



Thanks Neil, you have helped me solve the problem: diving into the midi file, I found it was set to CH3 while the multi in Omnisphere was set to CH1, so it was just a question of aligning the two. Everything is working as it should now :smile: