[SOLVED] UVI Falcon 2.8 VST3 Crashing Cantabile on Plugin Scan

Hi, Brad

I have just installed the latest UVI Falcon V2.8, which is working fine in Cubase, but Cantabile 4 is crashing when it gets to the VST3 version during the plugin scan. When it gets to the VST3 plugin, the Cantabile GUI is available for about ten seconds and then you lose everything with no errors reported.

There are no crash logs.

If you start Cantabile without a plugin scan, then the Falcon 2.8 VST2 is loading and playing fine.

I was on a much older build of Cantabile (4032 from memory) as my musical activities tail off in the spring/summer(!), but have just updated to the latest and have the same problem.

Any ideas?

This appears to be a problem with Falcon, reproducible in Cubase. I’ve contacted UVI with a video showing the issue.

I’ll post any updates here.

4 Likes

Hi, Brad.

Thanks for checking. Strange as I am sure it was ok in Cubase. I’ll double check tonight. I’ll also raise a case with UVI then.

Hi Derek, brad, same problem here. But I am sure this is working with Cubase 12.
Just for info.

Regards.

Hi, it is working on Cubase 12 for me as well, but see next post…

Hi, Brad

Thanks for checking it out. I have done some further digging tonight, including installing a new Falcon 2.8.1 version which came out today - fixing a crash in Ableton, but same issues. But the same or similar.

Here is a copy of my support request to UVI - ticket #81216

Hi, I installed Falcon 2.8 on 5th Octobe,r and I am having some strange issues. Not as per your first suggested article that came up, I do not believe I have multiple VST DLLs on the system as I always non-silently install to known locations.

In Cantabile, when the Falcon VST3 plugin is scanned, Cantabile/Plug check results in an application crash. I could see and use the Falcon VST3 plugin in Cubase, so I assumed it a Cantabile issue, and I reported it to Brad, the Cantabile developer. However, Brad is also getting the crash in his version of Cubase (in addition to Cantabile). See the video that Brad made, which also shows what I am seeing in Cantabile on the plugin scan.

https://www.dropbox.com/s/nr8k9cmde4ldvn0/FalconCrashOnScan.mkv?dl=0

With 2.8.0, if I loaded Cantabile and bypassed the plug in scan, I could load and play the VST2 version of Falcon, but there was no sign of the VST3 plugin in Cantabile

Also, I noticed that in Cubase 12 Pro (latest released build), it is seeing the VST3 plugin, but not the VST2 plugin of Falcon!

I noticed tonight that you had released a new 2.8.1 version of Falcon which included a fix for an Ableton crash, so I downloaded and installed and I get the same behaviour as before. A VST3 crash in Cantabile, but not Cubase, and Cubase not seeing the VST2 plugin, which is in a location that is scanned.

Interestingly, after the 2.8.1 install, if I load Cantabile now and byass the plugin scan, I see both VST3 and VST2 plugin versions, and I can load and play both - I am certain the VST3 version was not visible when I was trying this with 2.8.0, but cannot be 100% sure.

Please let me know if you require any more information
Regards
Derek Cook

As I said, the different behaviour is weird!

Hi,

If you are having this problem I would encourage you to submit a ticket to UVI as they have no other reports from other users and cannot replicate it

I have pointed them to Brads’s video and said at least one other person has an issue

Only advice UVI has given me is to search for duplicate plugins (I had and told them that in the ticket) and uninstall/reinstall which has made no differemce

They also said that showing only VST3 plugins in Cubase 12 is normal. but I am a little sceptical of that as other plugins (like my U-HE synths) show both VST2 and VST3 but maybe there’s a reason for that. I will check

Hi Derek,
done ticket #81293.

Regards.

1 Like

Just to refresh on this bug: I tried to start my Cubase12 on another PC which also have the last version of Falcon and got an error saying that 32 bits plugins are no more supported by Cubase.
This probably means the Falcon installer messed up and installed an 32 bits version of the plugin in the 64 bits directory target: C:\Program Files\Common Files\VST3\Falcon.vst3\Contents\x86_64-win
May be C4 is hanging due to that ? I updated my ticket accordingly so let’s see what UVI support will answer.

Regards.

1 Like

I am not convinced that Cubase always correctly detects why a plugin failed, and as I mentioned, the 2.8 VST3 is working fine in my Cubase Pro 12 instllation, but it barfs in Cantabile. For now I have removed the VST3 version

Have had no feedback from UVI after I pointed out that I had checked all the things they asked me to check before I submitted my ticket :wink:

I had feedback from UVI today. They thought it might be a regression issue between PACE (iLOK) and Falcon, so asked me to update to the latest iLOK version and try a 2.8.2 version of Falcon, which I have done but unfortunately I still get the crash.

I have reported that back to UVI.

For those testing this with Cubase, I found I had to delete the Cubase AppData folder before I saw any issues in Cubase (See the video linked above).

1 Like

Hi

Just a small situation update. Today I had a new version of Falcon from UVI to try via a private link, and the VST3 plugin in this version no longer causes the reported crash.

I have reported that success back to UVI, so hopefully there will be a formal release soon.

The install also put a new version if the iLOK drivers on my system, so maybe that was something to do with it.

2 Likes

Hi same here a new 2.8.2 made the trick and now all is OK.
Thanks to UVI for having solved this really anoying issue.

2 Likes

For those interested, the issue here (according to UVI) was an issue with the PACE Licensing that crashed if a protected DLL was unloaded too quickly after being loaded - like during a plugin scan.

2 Likes

That was their working assumption. Their first fix didn’t cure it, but the second one did, which included an iLOK pace driver update.

I have marked this thread as solved.