***SOLVED*** Sustain pedal not working when using plugins with Performer Solo

I just noticed this weird problem. Using Kontakt Player (5 or 6) as stand alone and everything works ok. If I add the same instruments without any modifications to Cantabile Performer, the sustain pedal is not working although Cantabile detects the signal (the signal “led” blinks and the Midi monitor also shows it correctly as sustain #64) and also the Kontakt (inside Performer) detects it.

Furthermore, for example The Grandeur flashes the “Pedal light”, both as stand alone and via Performer but the pedal dos not affect the signal in any way, when running inside Performer :confused: This also applies for example for UVI Workstation so, I presume there’s something fishy with the Performer/settings.

Is this something obvious? Running Win10Pro (latest), Cantabile Performer Solo 3.0 build 3630 x64.

First, did you check if the pedal send CC#7? To verify that, use Cantabile MIDI monitor, or a standalone program like MIDI-OX.

Hi, thanks for the reply :slight_smile: This is what Performer’s Midi monitor shows, while pressing the sustain pedal (three times in a row):

Well, the CC#7 and its values are correct. Plus, the standalone Kontakt and UVI work fine. So it’s suppose something is wrong with your Cantabile settings, (or, maybe Kontak?).
When I installed Cantabile, I didn’t find any setting able to disrupt sustain pedal. In all my VSTs, sustain acts as sustain. And yes, I use Kontakt pianos (Noire, mainly). I never changed damper/sustain pedal related settings.
I suspect anything wrong is in your Cantabile. Most likely in the songs/racks.
I know it’s weird you have the same behaviour in UVI workstation, can’t help you, the only UVI instrument I own is the B-5 Hammond, where the sustain pedal switches the Leslie speed.

Hi Olli,

can you share the song file (pack into a zip file and drag into the browser to upload)? I have NI Komplete and could take a look at the song file to see if something’s wrong with the routing…

Cheers,

Torsten

Thanks for the replies guys :slight_smile: I think I found the culprit: My trusty old Kawai K1II, which I’m currently using as the Midi controller apparently sends “All notes off” after every key press. I created a Midi filter with MidiOX (because I didn’t yet know how to do that with Performer) and filtered the All Notes Off away. Now the Sustain pedal works correctly :slight_smile:

Does this make any sense? I’m a rael newbie with Midi, so that’s what I just tried to figure out myself.

Created a Midi filter for CC#123 in Performer and sustain now works. Problem solved!

uuuh, that’s nasty…:scream_cat:

Cool!

Hi @Olli_Raatikainen,
it certainly makes sense…I had to do the same because my Roland D50 has the same behaviour (i.e. sending “All notes off” when no keys are pressed).