[Solved] Slaved Midi Synch Not Working

I’m trying to Midi Sync C4.156 to Ableton Live 11, which sends clock via Bome Midi Translator on virtual port BMT 3. I’ve got C4 configured to receive clock:

MidiSync_1_Screenshot 2023-12-26 064233

… I have Ableton’s transport running, and I’m receiving F8 pulses. However, Cantabile never shows a tempo (I’ve tried [Fast but unstable], [Balanced], and [Slow but stable]):

MidiSync_2_Screenshot 2023-12-26 064143

Turning on Route Midi Clock for a Cantabile port, I can see the pulses in Midi Monitor …

MidiSync_3_Screenshot 2023-12-26 064044

… but NOTE that the arrival of pulses jitters between 18 and 20 msec. Maybe that causes Cantabile not to synch?

Maybe the rule-based nature of Bome is causing delay / jitter? I could try LoopMIDI or a (gasp) physical MIDI loopback cable, but don’t have time for that before my all-day rehearsal in (yikes) two hours!

… or other ideas??

BTW, MidiView shows similar Jitter behavior:

Never mind. Didn’t realize that Cantabile does not show the (derived) tempo from MIDI Synch. (I’m used to the RC-505, which does).

My plugins in Cantabile are receiving the correct tempo, it’s just not shown numerically by Cantabile.

Seems like I’d want to indicate the correct tempo no matter the source; and maybe even list the source (internal, VST, midi in, etc.).

Strange, as when I have had Cantabile in a slave mode, it shows the tempo

It would be great to see what Cantabile thinks the tempo is when it is slave mode …

Hi Clint,

Have you select MIDI clock as the master transport?


Yes (see below) … and my VSTs seem to be receiving the modified tempo … I’m just not seeing it on the display.

MidiSync_2_Screenshot 2023-12-26 064143

1 Like

It’s hard to see from your pictures as they do not show the whole of the status display and the tempo, but this is what I get when I occasionally do a test of DMXIS settings; I develop the show on my DAW PC, but the DMXIS unit is buried in my GIG PC rack (which is networked to DAW PC when they are in the studio together) along with my Nord G2 Engine.

As you can see below, Cantabile on GIGPC is happy syncing to DAWPC and the Cantabile transport is also in sync. The connection between the PCs is via RtPMIDI.


Thanks @Derek

So … when I was new to Cantabile (3+ years ago), I changed the Secondary Text of the Big Blue Box in the upper center from the default Tempo and Time Sig. to a custom display that included the time signature and the song title … and promptly forgot about that … (I was thinking that tempo was duplicated immediately below, so the space could be put to better use …)

Fast-forward three years …

I am now experimenting with slaving C4 tempo to Ableton, and I was expecting the slave time to show up somewhere. I was looking for it where the Metronome time is shown … the widget that shows [ - ] when in MIDI Slave mode.

Now I get it … the Metronome widget goes to [ - ] to indicate MIDI slave mode and the slaved tempo is shown in the Big Blue Box …

1 Like

No problem, assume you have it sorted now.

I do not know if you saw it, but when I was looking to introduce looping capabilities into my rig, I looked at Ableton, but TBH I did not like it much and the learning curve looked pretty huge. I wanted a solution integrated into Cantabile, so I went the way of using a looping plugin called MuLabs, and I wrote a guide on how to use it

Not suggesting in any way that your approach linking Ableton and Cantabile is wrong in any way, but just thought I would point out that there is a looper option (probably one of many) that works inside Cantabile.